Users permissons write to home directory

after using the command: useradd and then passwd.
the created users have no permissions to write to the home directory.
i especially want to change these permissions so that these users can run pine.
i use Suse linux 7.3
isaj1Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

psimationCommented:
Do you mean they have no permissions to write to "THE" home directory, or to "THEIR" home directory?

By default, when adding a user, it creates a home folder for the user inside the /home folder. So adding user test will create a folder called /home/test.
The user should have full permissions on that folder, but will not usually have permissions to do anything outside that directory.

If you have no permissions inside the user's home folder, then the umask is set to something different in the /etc/bashrc file. My system has umask=002 meaning that you can set permissions of up to 775.
0
isaj1Author Commented:
okay thanx i will try that
0
collins23Commented:
have you tried out the yast utility ?
either on the command line or in x-windows.
just type yast on the command line.
go to admistrative tools.........
i don't  know about your machine but mine doesn't accept useradd
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

isaj1Author Commented:
that is wierd not to accept useradd.
go to yast and after filling in all the required fields, press F4 and then F10.
this ought to work.
0
isaj1Author Commented:
some esle about the useradd command. after using it, then you have to set a password for that particular user.
do this using
passwd username
then enter the password tiwce.
0
shepson990Commented:
finger <username> will tell you if that user has a home directory. If it doesnt
mkdir /home/<username>
chown <username>:<username> /home/<username>
usermod -d /home/<username> <username>
0
CleanupPingCommented:
isaj1:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
GhostModCommented:
PAQed - no points refunded (of 50)

GhostMod
Community Support Moderator
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.