weblogic 6.1

Hi ,
On weblogic 6.1 I get this error :

####<Feb 24, 2003 4:39:13 PM IST> <Info> <HTTP> <YOAVGOL01> <crmServer> <main> <system> <> <101053> <[HTTP crmServer] Loading web app: webApp_crmServer>
####<Feb 24, 2003 4:39:13 PM IST> <Info> <HTTP> <YOAVGOL01> <crmServer> <main> <system> <> <101060> <[crmServer] Loading "webApp_crmServer" from directory: "D:\dexOL\webroot\templates">
####<Feb 24, 2003 4:39:13 PM IST> <Info> <HTTP> <YOAVGOL01> <crmServer> <main> <system> <> <101160> <Deployment descriptor is malformed, check against the DTD: org.xml.sax.SAXParseException: The content of element type "web-app" must match "(icon?,display-name?,description?,distributable?,context-param*,filter*,filter-mapping*,listener*,servlet*,servlet-mapping*,session-config?,mime-mapping*,welcome-file-list?,error-page*,taglib*,resource-env-ref*,resource-ref*,security-constraint*,login-config?,security-role*,env-entry*,ejb-ref*)"..>
####<Feb 24, 2003 4:39:13 PM IST> <Debug> <HTTP> <YOAVGOL01> <crmServer> <main> <system> <> <101155> <Could not resolve entity "-//BEA Systems, Inc.//DTD Web Application 6.1//EN". Check your dtd reference.>
####<Feb 24, 2003 4:39:32 PM IST> <Error> <HTTP> <YOAVGOL01> <crmServer> <main> <system> <> <101062> <[webApp_crmServer] Error reading Web application "D:\dexOL\webroot\templates">
java.net.UnknownHostException: www.bea.com
     at java.net.InetAddress.getAllByName0(InetAddress.java:571)
     at java.net.InetAddress.getAllByName0(InetAddress.java:540)
     at java.net.InetAddress.getAllByName(InetAddress.java:533)
     at weblogic.net.http.HttpClient.openServer(HttpClient.java:191)
     at weblogic.net.http.HttpClient.openServer(HttpClient.java:254)
     at weblogic.net.http.HttpClient.<init>(HttpClient.java:117)
     at weblogic.net.http.HttpURLConnection.getHttpClient(HttpURLConnection.java:119)
     at weblogic.net.http.HttpURLConnection.getInputStream(HttpURLConnection.java:311)
     at java.net.URL.openStream(URL.java:798)


Anybody know why??
yoavgoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NetWizeCommented:
<Could not resolve entity "-//BEA Systems, Inc.//DTD Web Application 6.1//EN". Check your dtd reference.>

As the DTD for the web.xml or in the weblogic.xml is not in the local cache, the Weblogic tries to connect to the web to dynamically load it at fails (no local DNS?)

The first error <Deployment descriptor is malformed, check against the DTD might either result from that "not knowing the DTD" or your web.xml really is malformed:
1st all <servlet>-definitions
2nd all <servlet-mapping> definitions
3rd (if there is anything) the rest (there is a order as well)

What DTD are you including in your web.xml and weblogic.xml ?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Application Servers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.