Ghosting XP using sysprep

I used sysprep on a Dell GX260 to do a ghost to a GX110. The ghost went fine but the computer still freezes on startup. It gets as far as:

<partition info>\Windows\System32\Drivers\Mup.sys

and then hangs. Any ideas about what wrong, and what I should do to fix it? Thanks.
Dancindan84Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

EDStechCommented:
Might be something you're already doing, but just to clairfy..

How are you running sysprep?  Command line, or GUI?

I'm using sysprep (and a host of self-designed tools) to handle imaging of a GX260T back and forth from Fuijtsu laptops, and had a heck of a time getting it to work right until I started running sysprep in scripting mode.. from the command line.

Try running sysprep from the command line with the reseal option.  (Quiet, reboot, and mini are all optional.. I use my own windows setup process, so the full setup was wasteful.. your actual needs may vary.)

sysprep.exe -reseal -quiet -reboot -mini
0
Dancindan84Author Commented:
Thanks, I'll try that. I was using GUI mode with reseal and mini.
0
EDStechCommented:
I suspect the command line thing won't fix the problem for you if you were already resealing in the first place.  But it's worth a try, sysprep doesn't exactly seem like the pinacle of Microsoft greatness.

With that in mind, lets try to address the MUP.SYS deal..

http://www.earthv.com/tips_detail.asp?TipID=63

Sounds like MUP is trying to load the hardware (as you would expect at bootup) and failing?  Does Dell list any extra drivers for the GX1 that you may need to install on the GX2 before prepping?
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

alextoftCommented:
Sysprep runs into big problems when a prepped image is loaded onto a machine with a different hardware architecture - more specifically a different IDE controller.

In order to get the machine to boot a different IDE controller it is neccessary to take the following steps.

Boot off XP CD.
When setup menu appears, select 'Setup XP', NOT repair...
Install will search for Win installs.
When it finds your install, select 'Repair'.
Allow process to completely finish - it looks like it is reinstalling, but it's not.

System will now boot and install/files/registry will be unharmed.

Alex
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
alextoftCommented:
oh, forgot to add...

once you're up, sysprep it again and save it - then you have an image for that particular hardware setup.

0
EDStechCommented:
"In order to get the machine to boot a different IDE controller it is neccessary to take the following steps."

No it isn't.  Not always, at least.

As mentioned above, I'm running one single XP image on entirely different hardware types.. Dell GX260T desktops, Fujitsu S6010, S6110, E7110, and P220 laptops, as well as Intel VC820, SE440BX-2, and AL440LX motherboard based systems.  Once I figured out the reseal and the usage of the command line instead, it worked like a charm.

I had to write a tool to install the custom system-based applications for each model (Dell service utility, Fujitsu service tool, etc) but the machines boot up just fine at least.  ;)


Granted, I'm not saying that running the XP repair will not fix it, I'm simply saying that running XP repair is *not* a requirement.  There's something else broken here, it's just a matter of finding what it is.
0
Mighty_SillyCommented:
I agree with DEStech.  I have a single (prepped) xp image that installs fine on several model of Gateway PCs & Laptops & DELL workstations.

Occasionally I'd run into a problem but all were fixed by downloading latest BIOS updates.

-Silly-
0
Dancindan84Author Commented:
Well, I have the latest BIOS updates on both machines, tried yanking all my PCI cards like the earthv article suggested, and ran sysprep from the command line with -reseal and it still hung at the same spot. The repair seems to have worked though. Thanks for the help.
0
Dancindan84Author Commented:
The entire idea behind sysprep is that you should have to do this, but that's microsoft for you.
0
EDStechCommented:
Dancin: You mean, *Shoudln't* right?  :)

Sysprep is flakey sometimes.. it's kind of a "It works, or it doesn't work" kind of app.



Probably a bit beyond the point, but here's another thing to try...

Install the image on the working machine, sysprep it, and build the image.  Then, install the image on the other machine, repair it, then re-sysprep it, and build the image again from the "bad" machine.  Then, install the twice-prepped image onto the first machine again and see if it works.  That way, you get the "fixed" code as part of the image, as well was whatever good parts worked on the first system after the first prep.

Just a random suggestion.
0
Dancindan84Author Commented:
Whoops, yes I most certain meant shouldn't. Fat fingers little keys syndrome.

I may give that a try. I do get paid by the hour. ;)
0
alextoftCommented:
Well, if you get paid by the hour - ignore me :o)

I've tried it and it doesn't work. I oversee about 1000 machines of 7 different architectures using Powerquest DeployCenter (posh version of drive image), piping sysprepped XP images to all of them.

The primary cause of boot failure in these scenarios is the IDE controller drivers. An XP install will only use 1 set at a time and sysprep has not been written to substitute suitable alternatives - mainly because at the stage of the boot sequence where the failure occurs, the OS is not really yet capable of any big thinking. If you're lucky, the odd pair of systems might share a compatible controller, but I've not seen it often (we use a mixture of Dell & Hewlett Compackard).

Anyway, best of luck - hope your hardware has more in common than mine does.
0
EDStechCommented:
Ok, chalk this one up on me being stupid and forgetting the key point... :(

For some reason, I confused -reseal with BMSS.

In your sysprep.inf file, you need to add the line:

[SysPrep]
BuildMassStorageSection=yes


Assuming that you are not currently running the BMSS in your sysprep.inf, For my own curiosities sake, could you re-run your original (broken) image with the BMSS line, and see if that cures the problem with the MUP?

Sorry, total brain freeze earlier.  -reseal just makes the wizard show up upon reboot.  I think I need to upgrade to higher clockrate memory.
0
Dancindan84Author Commented:
Well, I would... but I got all the machines finished yesterday and got rid of the image that didn't work and just kept the one I did after the repair. I'll likely have to do the same process again in July/August when we get more machines on our replacement cycle (I work at a college). I'll keep this bookmarked and post what happens then.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.