?
Solved

get ing 158 MB from a unix U6000 unix server

Posted on 2003-02-24
5
Medium Priority
?
303 Views
Last Modified: 2013-12-16
I there
I need to get 158MB of data from a unysis U6000 unix version 4 server whith 14 terminals a tape and a floppy disk to a more modern system linux or win
i have tried to plug the tape whith the backup to a linux machine but i cant see de data in the tape i have only one option i think... make it the hard way... whith the floppy but... i need a compreesion utility that the old unix thesn't have :(( tried to put rar for unix zip for unix that alow spanning to varius disks but it didnt work tar cant see the floppy making an interface to a com didnt work maybee im doing someting wrong have a litle experience in linux and none in pure unix
im in big trouble...
any sugestions????
0
Comment
Question by:fragax
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 7

Expert Comment

by:sppalser
ID: 8019731
tar is not always a good transport between flavors of unix.  I have used Unisys SVR4 in the past and if you were to use the the cpio command that is native to the Unisys SVR4 unix along with a GNU cpio executable on the linux side you should be able to port your data files.  From the root use the following syntax:

     # find ./data_directory -depth -print | cpio -ocv -C10240 -O/dev/rmt0

If you don't want the whole directory you may first want to create a file list with the find command and dump it to a file:

     # find ./data_directory -depth -print > /tmp/file_list

Then edit the file /tmp/file_list and remove all the file names that DO NOT want.  Once this has been done issue the following:

     # cat /tmp/filelist | cpio -ocv -C10240 -O/dev/rmt0

Next find a GNU cpio executable to load on your linux box then restore the tape.  The native linux cpio command may even work so give it a try.

Not sure right off the top of my head what the linux or GNU switches would all be but from root may be something like:

     # cpio -icdmuv -I/dev/tape_device_name

          - or -

     # cpio -icdmuv < /dev/tape_device_name

Now the problems you are having on the linux side may be that you need to configure the tape drive into the kernel before you can read in the tapes.


Hope that helps.

0
 

Author Comment

by:fragax
ID: 8020460
thankx for the input  sppalser i will try it out
about the linux i have instaled mandrake 9 and i cant start the linux box up i think that the viper tape drive has seen better days :(((
any input for the diskette spanning?
just in case the tape doesnt work...
apreciate any sugestions
0
 
LVL 7

Expert Comment

by:sppalser
ID: 8020605
Diskette spanning has never worked real well for me, maybe others have had success.  As fo the linux not starting is that before or after adding the viper tape drive?  If it is after, make sure you don't have a SCSI ID conflict going on.  One should be able to pick a decent used viper drive or compatible at a reasonable price somewhere.  Otherwise if you have a DAT drive you could put that into the U6000 (so long as it is 8GB or less) at the proper SCSI ID then go back to the linix box for the restore.  Another option if you have networking installed on both machines would be to do an ftp transfer from U6000 to linux.

Good luck.
 
0
 

Author Comment

by:fragax
ID: 8029932
well the linux box doesnt start after i puted the viper tape and the U6000 doesnt have any conections to internet or ethernet and i cant find a modem or or an lan isa i have a nother tape from a novel server i will try it out if i can find the drivers for unix
thankx
0
 
LVL 7

Accepted Solution

by:
sppalser earned 300 total points
ID: 8034501
Would you be able to provide the exact model and hardware configuration of both your U6000 and linux machine?  Would need to know the brand, model numbers and ID's of all your SCSI devices and what brand and model of SCSI Host Adapter is being used on the linux side.

If the tape drive is working on the U6000 and all the SCSI rules are being followed, there is no reason why the linux system should not start.  Now it could be that your linux box is using the newest SCSI technology which could be an issue.  If that is the case then you may need to add an older SCSI adapter like an Adaptec 2940au or 1542CF or something similar to your linux box and have the tape drive be the only device on that adapter.

Let us know what you have in the two boxes and we should be to come up with a combination that would work for you.

Good Luck.



0

Featured Post

Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

FreeBSD on EC2 FreeBSD (https://www.freebsd.org) is a robust Unix-like operating system that has been around for many years. FreeBSD is available on Amazon EC2 through Amazon Machine Images (AMIs) provided by FreeBSD developer and security office…
Why Shell Scripting? Shell scripting is a powerful method of accessing UNIX systems and it is very flexible. Shell scripts are required when we want to execute a sequence of commands in Unix flavored operating systems. “Shell” is the command line i…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
In a previous video, we went over how to export a DynamoDB table into Amazon S3.  In this video, we show how to load the export from S3 into a DynamoDB table.
Suggested Courses

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question