?
Solved

Cannot ping individual ip on other side of p2p T1 connection between 2 2621xm's

Posted on 2003-02-24
14
Medium Priority
?
451 Views
Last Modified: 2010-04-17
I've configured two 2621xm routers one each side of a point to point t1 connection.  The routers can see each other and I can ping all ports however, when I try to ping a machine on the other side of the t1 from the nearside router I get 100% failure.  I can ping upto and including the LAN interface but not an individual machine on the LAN. I'm wondering if I forgot to include something in the configuration. The following is the configs that I used for each router (names have been changed):

MICKEY_2621

service timestamps debug uptime
service timestamps log uptime
service password-encryption
no service tcp-small-servers
no service udp-small-servers
!
hostname Mickey_2621
!
enable password *******
!
no ip name-server
!
ip subnet-zero
no ip domain-lookup
ip routing
!
interface FastEthernet 0/0
 no shutdown
 description connected to EthernetLAN_1
 ip address 172.16.16.102 255.255.255.0
 keepalive 10
!
interface Serial 0/0
 no shutdown
 description connected to Goofy_2621
 bandwidth 1536
 service-module t1 clock source line
 service-module t1 data-coding normal
 service-module t1 remote-loopback full
 service-module t1 framing esf
 service-module t1 linecode b8zs
 service-module t1 lbo none
 service-module t1 remote-alarm-enable
 ip address 192.168.31.2 255.255.255.248
 encapsulation ppp
 ip rtp header-compression
 ip rtp reserve 16384 100 360
!
interface Serial 0/1
 no description
 no ip address
 shutdown
!
voice-port 1/0/0
 no shutdown
 description connected to PBX_1 (212-333-2222)
 comfort-noise
 cptone US
 signal wink-start
 type 1
 operation 2-wire
!
voice-port 1/0/1
 no shutdown
 no description
!
dial-peer voice 1 pots
 port 1/0/0
 destination-pattern 2123332222
!
dial-peer voice 8 voip
 codec g729r8
 ip precedence 5
 session target ipv4:192.168.0.100
 vad
 destination-pattern 2004444400
!
! VoIP phone number-to-extension database
!
num-exp 3.. 3..
!
router rip
 version 2
 network 172.16.0.0
 network 192.168.31.0
 no auto-summary
!
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.16.3
ip route 0.0.0.0 0.0.0.0 192.168.31.1 25
no ip http server
snmp-server community public RO
no snmp-server location
no snmp-server contact
!
line console 0
 exec-timeout 0 0
 password *****
 login
!
line vty 0 4
 password ******
 login
!
end
*****************************************************
GOOFY_2621


service timestamps debug uptime
service timestamps log uptime
service password-encryption
no service tcp-small-servers
no service udp-small-servers
!
hostname Goofy_2621
!
enable password *****
!
no ip name-server
!
ip subnet-zero
no ip domain-lookup
ip routing
!
interface FastEthernet 0/0
 no shutdown
 description connected to EthernetLAN
 ip address 192.168.0.100 255.255.255.0
 keepalive 10
!
interface Serial 0/0
 no shutdown
 description connected to Supernova_2621
 bandwidth 1536
 service-module t1 clock source line
 service-module t1 data-coding normal
 service-module t1 remote-loopback full
 service-module t1 framing esf
 service-module t1 linecode b8zs
 service-module t1 lbo none
 service-module t1 remote-alarm-enable
 ip address 192.168.31.1 255.255.255.248
 encapsulation ppp
 ip rtp header-compression
 ip rtp reserve 16384 100 360
!
voice-port 1/0/0
 no shutdown
 description connected to PBX (200-444-4400)
 comfort-noise
 cptone US
 signal wink-start
 type 1
 operation 2-wire
!
voice-port 1/0/1
 no shutdown
 no description
!
dial-peer voice 1 pots
 port 1/0/0
 destination-pattern 2004444400
!
dial-peer voice 8 voip
 codec g729r8
 ip precedence 5
 session target ipv4:172.16.16.102
 vad
 destination-pattern 2123332222
!
! VoIP phone number-to-extension database
!
num-exp 3.. 3..
!
router rip
 version 2
 network 192.168.0.0
 network 192.168.31.0
 no auto-summary
!
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.0.13
ip route 0.0.0.0 0.0.0.0 192.168.31.2 25
no ip http server
snmp-server community public RO
no snmp-server location
no snmp-server contact
!
line console 0
 exec-timeout 0 0
 password *****
 login
!
line vty 0 4
 password ******
 login
!
end


0
Comment
Question by:Lionel_
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 2
  • 2
  • +2
14 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 8013905
If you are on a PC in subnet 192.168.0.0 connected to Goofy, what is your default gateway?
Is it 192.168.0.13, or is it 192.168.0.100?
0
 

Author Comment

by:Lionel_
ID: 8013942
Default gateway is 192.168.0.13
0
 
LVL 7

Expert Comment

by:pedrow
ID: 8013944
you say you can ping all the ports on the remote router. From where? from the near router? or from the hosts on the near router's LAN?

What the output of 'sh ip route' on each router?

What are the default routes that are issued by the dhcp server(assuming you have one).

Does adding:

ip proxy-arp (yeah...i know...bad neteng)

on the ethernet interfaces change the behavior?




0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 

Author Comment

by:Lionel_
ID: 8013968
Hello Pedrow,

I can ping all ports from the near router
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8013979
So, does that firewall have a static route for the 172.16.16.0 subnet pointing back to 192.168.0.100 ?
0
 

Author Comment

by:Lionel_
ID: 8014026
These two routers are inside the firewalls.  They are connected via a t1 point to point to one another, basically for file sharing and VoIP between two branch offices.  The question is why can I from Mickey_2621 ping interface fe0/0 ip address 192.168.0.100 but not a machine connected to that interface (ex. 192.168.0.12)?

0
 

Author Comment

by:Lionel_
ID: 8014031
These two routers are inside the firewalls.  They are connected via a t1 point to point to one another, basically for file sharing and VoIP between two branch offices.  The question is why can I from Mickey_2621 ping interface fe0/0 ip address 192.168.0.100 but not a machine connected to that interface (ex. 192.168.0.12)?

0
 
LVL 7

Accepted Solution

by:
pedrow earned 225 total points
ID: 8014040
what's the default route on the hosts sitting on the remote LAN?

Do the subnet masks match? does proxy-arp change the behavior? What do the routing tables look like?

:)



0
 

Author Comment

by:Lionel_
ID: 8014081
Haven't incorporated proxy-arp yet, I will do so tomorrow morning.  The default routes on the hosts have not been changed yet but will point to the 2621 routers respectively.  However, imho this should not affect my being able to ping them from the near router(should it?).

Routing tables on each router see all networks.

0
 
LVL 5

Expert Comment

by:rrhunt28
ID: 8026383
And this seems silly, but make sure that the cables plugged into that interface are good, and working, and make sure the host is set up as well.  
0
 

Author Comment

by:Lionel_
ID: 8026507
Not a silly suggestion at all rrhunt28 as most of my service calls are because of this.  However, it seems that pedrow hit it right on the head.  When I pinged the firewall I got a good ping, when I ping any host on the remote lan I did not get anything.  This is because the firewall does not have a default route set, but the host (via the dhcp settings) do.  Their default route was currently the firewall.  After I changed this setting in the dhcp server and had all pc'c reboot all remote lan hosts were pingable.

Thanks!!
0
 

Author Comment

by:Lionel_
ID: 8026531
default route really meant default gateway (same difference)
0
 
LVL 5

Expert Comment

by:rrhunt28
ID: 8026535
Good deal.  I ment silly because I would assume most of us here would check that first, instead of taking apart router config files.  Glad your up and running.
0
 
LVL 1

Expert Comment

by:Computer101
ID: 8029327
Points reduced for a split.  You can now accept one experts comment as an answer.  After that, make another question in this topic area for the other expert.  Make the question for the amount of points intended.  Label the question, "Question for (Expert Name) and post this question number in the base of the question, i.e. For your assistance in question # --------


Computer101
E-E Admin
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this tutorial I will show you with short command examples how to obtain a packet footprint of all traffic flowing thru your Juniper device running ScreenOS. I do not know the exact firmware requirement, but I think the fprofile command is availab…
We've been using the Cisco/Linksys RV042 for years as: - an internet Gateway - a site-to-site VPN device - a leased line site-to-site subnet-to-subnet interface (And, here I'm assuming that any RV0xx behaves the same way as an RV042.  So that's …
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question