sound problem redhat 8.0 linux

hello
i am a newbie to linux and am having problem with sound.when i tried running sndconfig it said it detected my sound card (intel corp. 82801DB AC) but gave the following errors.
/lib/modules/2.8.18-14/kernel/drivers/sound/i810_audio.o:init_module:no such device
/lib/modules/2.8.18-14/kernel/drivers/sound/i810_audio.o:insmod
/lib/modules/2.8.18-14/kernel/drivers/sound/i810_audio.o:failed
/lib/modules/2.8.18-14/kernel/drivers/sound/i810_audio.o:insmod sound_slot_0  failed

i heve installed redhat 8.0 on a pc with windows 98 and xp.the sound works perfectly in the windows OS s.
would be grateful if u could help me out.
jag_linuxAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JermzzCommented:
You might need to check with your sound card company to see if that card support Red Hat 8.0 or find to update drivers for that card.
0
satej99Commented:
Hey jag,
        why don't you use the Alsa sound drivers for your card. Just download the latest drivers from the website:
http://www.alsa-project.org ( stable release ) and then untar, and run the ./configure file.

First click on the link ftp://ftp.alsa-project.org/pub/driver/alsa-driver-0.5.12a.tar.bz2
and download the file. It can be downloaded to a floppy too.
Then go to the home directory as root
then run the command
bunzip2 alsa-driver-0.5.12a.tar.bz2
then try tar xzvf alsa-driver-0.5.12a.tar.gz
( I don't remember the exact file name though , please check the file that is created after the bunzip2 command).
Then all the files would be unzipped to a folder alsa-0.5.12a

Better still you could go to /usr/local/alsa and do the untarring instead.
After unzipping the files, go into the folder alsa... (whatever it is ) and then run ./configure at the command prompt.
If you know what your sound card exactly is , you could try
./configure --with-cards=azt2320 , ( That was my sound card on my machine) . Please check your sound card details.
then type make
then type make install.
after that revert back. I will let you know what next...
Thanks,
Satej
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CleanupPingCommented:
jag_linux:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
paullamhkgCommented:
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is to:

Accept satej99's Comments as answer

Please leave any comments here within the next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

Paul
EE Cleanup Volunteer
0
RomModCommented:
Finalized per recommendation.

RomMod
Community Support Moderator
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.