• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 991
  • Last Modified:

Laptop NumLock coming ON at logon when I want it OFF.

We have 15 AJP laptops running W2K Pro, which connect to our W2K domain running AD.

For some reason, when new users log on (ie. those that pick up the Default User profile), the NumLock key comes on, which is damn annoying as they can't type letters properly unless they switch it off.

Under HKCU\Control Panel\Keyboard\ I've set InitialKeyboardIndicators to 0 (and also set every occurance of the same key to 0), and have even tried copying the administrator account (for which the NumLock key doesn't come on) to the Default User account but no joy. I've also disable NumLock in the bios.

If its any help, the exact point the NumLock comes on is after logon where the dialog box "Applying personal settings" appears, which I guess rules out anything in the Startup folder or Run registry key.
0
DanielTheManual
Asked:
DanielTheManual
1 Solution
 
DanielTheManualAuthor Commented:
Also, I've tried adding a System variable (Under System Control Panel, Environment Variables) of Numlock with a value of OFF but no luck.
0
 
DanielTheManualAuthor Commented:
Upon further investigation, it seems to be a domain issue (AD?).

The same thing happens on W2K workstations, but its only noticable on the laptops as they don't have a seperate number pad, and having the numlock on prevents users typing properly.

When logging in locally it doesn't happen, but when logging onto the domain, the numlock is coming on as you logon. I didn't think there was any way of setting the numlock status in Group Policy, and if there definately isn't, I'm stumped as to whats forcing the numlock on.
0
 
SquireCommented:
Hi,

You may find it would be solved by editing the domain policy file (ntconfig.pol) and adding in a custom .adm template file with this content:

CLASS USER
CATEGORY "Additional Extras"
CATEGORY "Set NumLock"
KEYNAME "Control Panel\Keyboard"
POLICY "NumLock on at Logon"
PART "NumLock on at Logon" CHECKBOX
VALUENAME "InitialKeyboardIndicators"
VALUEON NUMERIC 2
END PART
END POLICY
END CATEGORY

My guess is that even though you are setting the InitialKeyboardIndicators to 0, that this is being over-written at logon time. It would be worth verifying this.

Squire.
0
2018 Annual Membership Survey

Here at Experts Exchange, we strive to give members the best experience. Help us improve the site by taking this survey today! (Bonus: Be entered to win a great tech prize for participating!)

 
MSGeekCommented:
If it's not a group policy coming out it is part of the default profile.  Logon locally as the admin, turn off num lock if it is not already, copy profile over the Default User profile.  If there are any cached profiles be sure to remove them before you shutdown.
0
 
DanielTheManualAuthor Commented:
I had already tried copying the administrator profile over the default user, and logging on as someone with no cached settings, but still the number lock came on.

It only does it when I log onto the domain. We don't use ntconfig.pol, any policy settings are applied through group policy.
0
 
DanielTheManualAuthor Commented:
I found a solution. I came across a program called NumLock (http://www.rjlsoftware.com/?numlock), so created a batch file which I put in the All Users start-up folder, which, along with an 'off' switch, pointed to the Numlock executable. This produced the desired result.

I think the NumLock status is stored in each users profile, and there wasn't any way I could change all our users individual profiles.

I'll get support to close this question.

0
 
MSGeekCommented:
Copying over the default profile will not work unless you delete the users existing profile and then log in as them and have their profile recreated.  A users profile is created from the Deafult User and All Users profiles at first login, after that it is cached.  SO after you coppied the Administrator profile over the default user, did you login with a username that did not already have a profile???
0
 
DanielTheManualAuthor Commented:
Yes, I had copied the administrator profile over default user and all users, and tried logging on as a user that hadn't previously logged on before, and it didn't work.

I did say in my comment dated 02/27/2003 01:32AM PST
that I'd tried it (except I omitted the all users part).

A users profile isn't created from the All Users profile anyway, that is applied to everyone regardless of whether they've logged in before or are logging in for the first time.
0
 
DanielTheManualAuthor Commented:
I have asked in Community Support for this question to be deleted or PAQ'ed.

My solution was as above:

I came across a program called NumLock (http://www.rjlsoftware.com/?numlock), so created a batch file which I put in the All Users start-up folder, which, along with an 'off' switch, pointed to the Numlock executable. This produced the desired result of turning number lock off at logon.

0
 
MSGeekCommented:
No objection.
0
 
SvegoCommented:
Hi,

i know you asked for this one to be deleted or paq'ed but i could help giving you the URL to Microsoft Knowledge Base Article - 170903
URL: http://support.microsoft.com/default.aspx?scid=kb;en-us;170903
0
 
DanielTheManualAuthor Commented:
Svego, that was one of the first things I tried. If you read my original post, it says I changed InitialKeyboardIndicators to 0 where-ever it appeared in the registry (including under HKEY_USERS\.DEFAULT\Control Panel\Keyboard
), but it did no good.
0
 
cempashaCommented:
This question is still open and getting old. If any of the comment(s) above helped you please accept it as an answer or split the points who ever helped you in this question. Your attention in finalising this question is very much appreciated. Thanks in advance,

****** PLEASE DO NOT ACCEPT THIS AS AN ANSWER ********

- If you would like to close this question and have your points refunded, please post a question in community support area on http://www.experts-exchange.com/Community_Support/ giving the address of this question. Thank you      

Pasha

Cleanup Volunteer


0
 
PashaModCommented:
Question closed and points refunded

PashaMod
CS Moderator
0
 
ALAA_ELMAHDYCommented:
hi there ,
any one found a solution for this mattar.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now