i get an error message when trying to install a program

im trying to install a program but everytime i try to install it i get this message:

this file does not have a program associated with it for performing this action. create an association in My Computer by clicking View and then clicking Folder Options.

when i click "ok" another message comes out:

The loader successfully loaded the Windows Installer, but failed to run the Windows Installer package c:\windows\temp\instmsia.exe

the program wont load and i dont know what to do.. i figure the problem has to do with the windows installer on this system because i had this program on another system and it worked fine.. what can i do? i have windows 98 second edition
drmunecaAsked:
Who is Participating?
 
BillDLConnect With a Mentor Commented:
What is your AntiVirus programme?  Something like Norton AntiVirus 2002 runs quite a few things in the background and keeps running some of these even after you disable the constant Resident Shield mode using the programme's control panel.  If it's still showing in your system tray "greyed out" or with a red cross through it, then some components have loaded and you should remove it from your Startup folder or place a "REM" in front of it in your Autoexec.bat.

Did you specifically download the MS Installer version 2 as a separate programme and install it alone before retrying?  I'm not sure whether the Win98 recommended updates contain version 2 installer which is now needed by most modern programmes.

What is the name and version of the programme you are trying to install?
0
 
stretchspCommented:
Have you tried updating your system with all available system updates from the Microsoft Windows 98 update site.
I believe this is the link, but could be wrong

http://v4.windowsupdate.microsoft.com/en/default.asp

0
 
BillDLCommented:
What's the programme? Is it a modern one?

There is the possibility that your AntiVirus programme's resident shield is interfering. Try and use the AntiVirus Programme's options to disable it from running in the background all the time, reboot, and then try and reinstall.

I had problems like this before and, perhaps coincidentally, I installed the MS Installer version 2 on its own first, then rebooted. When I then installed the programme it installed fully and correctly.

Download it from here:

http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=CEBBACD8-C094-4255-B702-DE3BB768148F
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
stretchspCommented:
BillDL has a point, you should never try and install a program with your antivirus software turned on.  It will only cause you installation headaches.
0
 
drmunecaAuthor Commented:
my system has all the windows 98 updates to date.. my anti virus program was enabled, but even though i disabled it, the program still says the same thing..
0
 
drmunecaAuthor Commented:
i guess u were right about the program still running in the background because once i went to the startup folder the program began to work.. thanks a bunch =0)
0
 
BillDLCommented:
Thanks drmuneca, they can be a real pain sometimes although they are obviously an essential application.
0
All Courses

From novice to tech pro — start learning today.