• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 942
  • Last Modified:

Scheduled Task doesn't run on it's own... EVER!

All,
I have a scheduled task scheduled to run at 9:00 pm while I'm away from work. The thing doesn't run. Below is the log for the last two days. I have everything set fine (I think), I have looked at it MANY times. I am an administrator on my box here at work. When I set up the task I used my LAN (work) ID and password like a good boy. The thing does not run. When I kick it off manually it runs fine. When I double click the 'backup.bat' file it runs fine. If I go in and set it up to run once in the next 5 minutes it runs fine. I have this set up to backup three different parent directories out to a LAN drive that is backed up nightly. If I call our LAN support people they will tell me to just use the LAN drive to save all my files to (use it like my local drive). Any help would be appreciated.

Thanks,
Ploppin


"Backup.job" (Backup.bat) 2/24/2003 9:00:00 PM ** ERROR **
     The attempt to log on to the account associated with the task failed, therefore, the task did not run.
     The specific error is:
     0x80070569: Logon failure: the user has not been granted the requested logon type at this computer.
     Verify that the task's Run-as name and password are valid and try again.
"Backup.job" (Backup.bat) 2/25/2003 9:00:00 PM ** ERROR **
     The attempt to log on to the account associated with the task failed, therefore, the task did not run.
     The specific error is:
     0x80070569: Logon failure: the user has not been granted the requested logon type at this computer.
     Verify that the task's Run-as name and password are valid and try again.
[ ***** Most recent entry is above this line ***** ]
0
ploppin
Asked:
ploppin
  • 2
  • 2
  • 2
  • +3
1 Solution
 
SysExpertCommented:
Check the task manager and other services for a start.
Make sure that you have the right switches for your backup - please post the batch file or task that you are trying to run.

Other options are to simply run a batch file using
xcopy ...

see

xcopy /?
for details.
Simple and plenty of options.
Small and fast.

I hope this helps !
0
 
pbarretteCommented:
Hi ploppin,

Your user needs the "Logon as batch job" right.

pb
0
 
tedskyCommented:
Greetings!
By any chance, would PCAnywhere or Remote Access be set up on this system?
Anywhere I have this set up, the scheduled events do not kick in.  Haven't figured out a workaround yet, but hope someone might have a suggestion or two.
Ted
0
[Webinar] Improve your customer journey

A positive customer journey is important in attracting and retaining business. To improve this experience, you can use Google Maps APIs to increase checkout conversions, boost user engagement, and optimize order fulfillment. Learn how in this webinar presented by Dito.

 
ploppinAuthor Commented:
All,
Thanks for the comments. f:/ is my network drive, we all have space out there.

Below is the contents of the .bat file that I'm trying to run.

pb,
what do you mean about - Your user needs the "Logon as batch job", how do I check this?

tedsky,
I do not have PCAnywhere or Remote Access set up on my box. Out LAN dept can proxy into all of our boxes, I don't know if this counts as Remote Access.

******** .bat file code **************************
@echo off
xcopy c:\projects f:\projects /S /E /Y /I /D
dir f:\projects > "C:\Documents and Settings\giap01\Desktop\projects_f.txt"
xcopy c:\files\docs f:\docs /S /E /Y /I /D
dir f:\docs > "C:\Documents and Settings\giap01\Desktop\docs_f.txt"
***************************************************

Thanks,
Ploppin
0
 
wrabbitCommented:
Just a thought but does your network admin maybe disable logons during a certain time period?

You're trying to run the batch file at 9pm, but you might only be able to login between the hours of 7am and 7pm?
0
 
tedskyCommented:
It's looking more and more like Wrabbit's suggestion may be spot on.
Check with IT/LANS about logon time windows permissions.
Ted
0
 
pbarretteCommented:
Hi ploppin,

To check your rights, go to "Administrative Tools" -> "Local Security Policy" or open the interface using "Start" -> "Run" then typing:
%SystemRoot%\system32\secpol.msc /s

In the "Local Security Settings" interface, open "Local Policies" then open "User Rights Assignment". Scroll down the list of permissions until you find "Log on as a batch job" then make sure your username, or a group you belong to, is listed.

To change these settings, you would need Local Administrator priviledges.

pb
0
 
ploppinAuthor Commented:
pbarrette,
I went in and checked:
"Control Panel"
then
"Administrative Tools"
then
"Local Security Policy"
then
"Security Settings"
then
"Local Policies"
then
"User Rights Assignment"
then
"Log on as Batch Job"

and I am NOT in there.

I'll get with 'Nick Burns' and see if I can get in as a batch job scheduler on my box.

Thanks,
Ploppin
0
 
Pete LongTechnical ConsultantCommented:
ploppin,
No comment has been added lately (152 days), so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area for this question:

RECOMMENDATION: Award points to pbarrette
Please leave any comments here within 7 days.

-- Please DO NOT accept this comment as an answer ! --

Thanks,

PeteLong
EE Cleanup Volunteer
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 2
  • 2
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now