Notes 5 suddenly won't run

I have installed Notes R5 (client)from a purchased CD and also Domino Designer via a download from IBM. I've still got Notes 4.6.1 on the computer in a separate directory. I'm new to R5 and was working on it last night to create pages that look more like the R4 I'm used to. In closing a page or a database (sorry it happened quickly!), I got some message about "the page is already open" or similar. The program then quit, and since then trying to load either Notes or Domino Designer fails. It starts to load OK but then brings the error messagebox "File does not exist", and it then quits. R4.6.1 still runs OK.

Can anyone suggest why, and how to remedy? I've looked in my trashcan to see if I've accidentally deleted something but there's nothing there that was deleted yesterday.

If I need to uninstall R5 then reinstall, I'd like to retain the desktop that I'd spent some time arranging. Is it just a matter of saving the desktop.dsk file before doing this and copying it back afterwards? I seem to have 2 such files, one called desktop.dsk and another desktop5.dsk - which one (or both)? I keep my database files in a separate directory. That directory also has these 2 file names in it, although the file sizes are different to those on the c:\lotus\notes\ directory.

Thanks!
StuartOrdAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
ZvonkoConnect With a Mentor Systems architectCommented:
Your notes.ini can not have the problem.
My R5 started with your notes.ini without problems.
The only warning was that my COM3 port was not available.

0
 
ZvonkoSystems architectCommented:
Hello Stuart,

first of all, I got your email, thanks :-)

And for your R5 problem: I assume the error message was that "desktop is already oppen". The is a common error when notes client crashes. But it is resolved after next windows boot.
Did you boot in meantime?

0
 
HemanthaKumarCommented:
Goto R5 install directory, and invoke notes.exe manually. If it is successful then Check the shortcut to the notes program, and modify the Start in or working directory to point to directory where notes.exe resides. Also make sure the notes.ini is in your R5 install directory.

~Hemanth
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
StuartOrdAuthor Commented:
Thanks for the suggestions.
1. Yes I think the error message was as Zvonko says above.
2. I hadn't rebooted as I'm using a laptop that I rarely reboot. However I've done that now and the problem is still the same.
3. If I run notes.exe from File Manager, the exact same occurs.
4. I do have notes.ini in the same Notes directory.
0
 
ZvonkoSystems architectCommented:
Start your windows task manager and sort the process names.
Tell us all Windows process names starting with an n-letter.




0
 
StuartOrdAuthor Commented:
There were none when I first opened it. When I ran Notes, the program "NLNOTES.exe" was added to the list. The same happened for Domino Designer.
0
 
StuartOrdAuthor Commented:
There were none when I first opened it. When I ran Notes, the program "NLNOTES.exe" was added to the list. The same happened for Domino Designer.
0
 
HemanthaKumarCommented:
Open your notes.ini and look if it points anything besides your R5 install directory. If so correct it to R5 directory.

Also Check for "KeyFilename=" parameter in notes.ini and see if it points to valid and reachable .id file. If it is on some share dir, and could not connect then you might get file not exist problem

0
 
StuartOrdAuthor Commented:
When I first started Task Manager, there were no processes beginning with "n". When I ran either Notes R5 or Domino Designer, the process NLNOTES.exe appeared in the list.
0
 
ZvonkoSystems architectCommented:
0
 
StuartOrdAuthor Commented:
When I first started Task Manager, there were no processes beginning with "n". When I ran either Notes R5 or Domino Designer, the process NLNOTES.exe appeared in the list.
0
 
StuartOrdAuthor Commented:
When I first started Task Manager, there were no processes beginning with "n". When I ran either Notes R5 or Domino Designer, the process NLNOTES.exe appeared in the list.
0
 
StuartOrdAuthor Commented:
I'm having a rough time tonight - connection dropping out and apparently losing my comments.

I've tried the copy / delete / replace for desktop.dsk and desktop5.dsk files - sorry, no change.

I've looked in notes.ini and found -
Directory=d:\AADatabase files\Notes (this is where I keep my user files - was set using File, Preferences, User preferences)
WinNTIconPath=C:\Lotus\Notes\Data\W32 (this is the installation directory and the path does exist
FileDlgDirectory=D:\AADatabase files\Notes

I've found the line "KeyFilename=server.id" and the file "server.id" does exist on D:\AADatabase files\Notes\


0
 
ZvonkoSystems architectCommented:
You found your error :-)

Delete this line with server.id!!!

0
 
StuartOrdAuthor Commented:
AHH!
I did this, and on restarting I got the dialogue box "Choose file to be used as current user id" followed by the directory search type box looking in D:|AADatabase files\Notes where there is both server.id and cert.id. I selected server.id and it said....... "file does not exist"!!!!
So I did it again and this time chose the cert.id, but it told me "illegal use of a certifier id file"
I've also found a "user.id" on C:\Lotus\Notes\Data. So I navigated to that from the above and selected it - to get ......"file does not exist"!!
Watch out people below my window, the computer is about to arrive there!!!!
Perhaps this isn't the problem and it's looking for a file after accepting the .id file specified and failing to find that one?


0
 
ZvonkoSystems architectCommented:
Hey Start, sorry but I laughed heartily about your note :-)

In Munich is now quarter past midnight; I go now to bed.
Do you have a good idea where you can go for the rest of the day?

0
 
scottrmaCommented:
Try renaming your bookmark.nsf to bookmark.old and then try starting Notes. Notes will rebuid this file automatically when you launch Notes.

Hope this helps.

Regards,

Scott
0
 
scottrmaCommented:
Also check out this semi-related link:

http://www-1.ibm.com/support/docview.wss?rs=475&context=SSKTWP&uid=swg21100073

I notice you've got Directory=d:\AADatabase files\Notes pointing to a directory with a space in the path. Try moving this to a directory without any spaces in the path and then updating your notes.ini accordingly and then try launching Notes again.

Let us know if this works or not.

Regards,

Scott
0
 
StuartOrdAuthor Commented:
Hi guys,
My time is similar to Zvonko's (Chester, UK)
Just deleting the space from my path caused a change - no error box about file does not exist, but the program still does not start - I get the Notes window building for a fraction of a second, then nothing. This is reversible.
I then changed notes.ini to show the path without the space - still says file does not exist.
Changing bookmark.nsf to bookmark.old brought no change.
I'm off to work now - I'm a chemical engineer, not an IT pro, so speak to you again this evening if you're still willing!
Stuart

0
 
ZvonkoSystems architectCommented:
Nice day Stuart :-)
0
 
StuartOrdAuthor Commented:
I've deleted the Keyfile= line again and copied my subdirectory D:\AADatabase files\Notes to D:\AAdatabaseFiles\Notes and navigated to the server.id file in the new directory. Guess what? It still thinks the "file does not exist". When I look in the notes.ini file, it has added the line "KeyFilename=server.id" so I wonder if that id file contains a reference to a missing file.
Just for interest I deleted the line again, copied the user.id file that i'd found in c:\Lotus\Notes to the database directory. I selected user.id when asked to pick the id file and.....the rest is getting boring.
This is my last chance tonight as i'm away for the weekend!

I've installed Notes 5 on my desktop PC - is it worth copying any files from there?

Failing any new ideas, I'll reinstall, but would appreciate help on saving my desktop that took a while to set up (see first comments near the beginning)

0
 
scottrmaCommented:
If you want, post the entire contents of your notes.ini file here and we will tell you if there is anything that is obviously wrong there that might be causing this error.

Or if you just want to reinstall, make a backup of your relevant databases, your user.id file, and your desktop5.dsk file (this file has your desktop icons in it, among other things). Then, uninstall Notes and reinstall. Make sure you specify paths for the program and data directory that do not have spaces in them, I would leave the default \Lotus\Notes and \Lotus\Notes\Data if I were you. Then copy back in your desktop5.dsk, user.id file, and any other databases you wanted to keep into your new \Lotus\Notes\Data folder, and you should be all set.

Regards,

Scott
0
 
StuartOrdAuthor Commented:
OK, here it is -

[Notes]

Directory=d:\AADatabaseFiles\Notes
KitType=1
InstallType=2
WinNTIconPath=C:\Lotus\Notes\Data\W32
Timezone=0
DST=1
$$HasLANPort=1
WWWDSP_SYNC_BROWSERCACHE=0
WWWDSP_PREFETCH_OBJECT=0
EnableJavaApplets=1
EnablePlugins=1
Preferences=-2138944399
AltNameLanguage=en
ContentLanguage=en
WeekStart=2
ViewWeekStart=2
NavWeekStart=2
XLATE_CSID=52
SPELL_LANG=2057
Region=en
Passthru_LogLevel=0
Console_LogLevel=2
VIEWIMP1=Lotus 1-2-3,0,_IWKSV,,.WKS,.WK1,.WR1,.WRK,.WK3,.WK4,,4,
VIEWIMP3=Structured Text,0,_ISTR,,.LTR,.CGN,.STR,,1,
VIEWIMP4=Tabular Text,0,_ITAB,,.PRN,.RPT,.TXT,.TAB,,1,
VIEWEXP1=Lotus 1-2-3,0,_XWKS,,.WKS,.WK1,.WR1,.WRK,,4,
VIEWEXP3=Structured Text,0,_XSTR,,.LTR,.CGN,.STR,,1,
VIEWEXP4=Tabular Text,1,_XTAB,,.LTR,.RPT,.CGN,.TAB,,1,
EDITIMP1=ASCII Text,0,_ITEXT,,.TXT,.PRN,.C,.H,.RIP,,1,
EDITIMP2=Microsoft RTF,0,_IW4W,_IRTF,.DOC,.RTF,,2,
EDITIMP3=Lotus 1-2-3,0,_IW4W,_IWKSE,.WKS,.WK1,.WR1,.WRK,.WK3,.WK4,.123,,4,
EDITIMP4=Lotus PIC,0,_IPIC,,.PIC,,8,
EDITIMP5=CGM Image,0,_IFL,,.GMF,.CGM,,8,
EDITIMP6=TIFF 5.0 Image,0,_ITIFF,,.TIF,,18,
EDITIMP7=BMP Image,0,_IBMP,,.BMP,,18,
EDITIMP8=Lotus Ami Pro,0,_IW4W,W4W33F/V0,.SAM,,2,
EDITIMP9=HTML File,0,_IHTML,,.HTM,.HTML,,1,
EDITIMP17=WordPerfect 5.x,0,_IW4W,W4W07F/V1,.DOC,.WPD,,2,
EDITIMP21=Lotus Word Pro,0,_IW4W,W4W12F/V0,.LWP,,2,
EDITIMP22=PCX Image,0,_IPCX,,.PCX,,18,
EDITIMP28=Binary with Text,0,_ISTRNGS,,.*,,1,
EDITIMP29=WordPerfect 6.0/6.1,0,_IW4W,W4W48F/V0,.WPD,.WPT,.DOC,,2,
EDITIMP30=Microsoft Excel,0,_IW4W,W4W21F/V4C,.XLS,,4,
EDITIMP31=Microsoft Word,0,_IW4W,W4W49F/V0,.DOC,,2,
EDITIMP32=GIF Image,0,_IGIF,,.GIF,,18,
EDITIMP33=JPEG Image,0,_IJPEG,,.JPG,,18,
EDITEXP1=ASCII Text,2,_XTEXT,,.TXT,.PRN,.C,.H,.RIP,,1,
EDITEXP2=Microsoft RTF,2,_XRTF,,.DOC,.RTF,,4,
EDITEXP3=CGM Image,2,_XCGM,,.CGM,.GMF,,8,
EDITEXP4=TIFF 5.0 Image,2,_XTIFF,,.TIF,,18,
EDITEXP5=Lotus Ami Pro,2,_XW4W,W4W33T/V0,.SAM,,2,
EDITEXP14=WordPerfect 5.1,2,_XW4W,W4W07T/V1,.DOC,,2,
EDITEXP21=WordPerfect 6.0,2,_XW4W,W4W48T/V0,.DOC,,2,
EDITEXP22=WordPerfect 6.1,2,_XW4W,W4W48T/V1,.WPD,.WPT,.DOC,,2,
EDITEXP23=Microsoft Word 6.0,2,_XW4W,W4W49T/V0,.DOC,,2,
DDETimeout=10
NAMEDSTYLE0_FACE=Default Sans Serif
NAMEDSTYLE1_FACE=Default Sans Serif
NAMEDSTYLE2_FACE=Default Sans Serif
DefaultMailTemplate=mail50.ntf
TCPIP=TCP, 0, 15, 0
LAN0=NETBIOS, 0, 15, 0
VINES=VINES, 0, 15, 0
SPX=NWSPX, 0, 15, 0
COM1=XPC,1,15,0,
COM2=XPC,2,15,0,
COM3=XPC,3,15,0,
COM4=XPC,4,15,0,
COM5=XPC,5,15,0,
Ports=TCPIP,LAN0,COM1,COM3
DisabledPorts=VINES,SPX,COM2,COM4,COM5
CertificateExpChecked=user.id 27/02/2003
MailSystem=99
TemplateSetup=68
Setup=62
Location=Internet,212A,Stuart Ord
$IEVersionMajor=5
$IEVersionMinor=50
ECLSetup=3
$headlineClientId=EC19A7E0:7FDFA1EE-80256B6D:007DF4E1
PhoneLog=2
Log=log.nsf, 1, 0, 7, 40000
$W3LocalFormSave=0
DESKWINDOWSIZE=-4 -4 1032 748
WINDOWSIZEWIN=20 15 984 715
MAXIMIZED=1
WinNTIconCommonConfig=Universal
WinNTIconSize=2
WinNTIconPos=2
WinNTIconHidden=0
WinNTIconRect=-1 -1 1025 25
HELPWINDOWSIZEWIN=154 115 857 652
NAMES=names.nsf
$MIMESaveFormat=132
$headlineDisableHeadlines=0
EmptyTrash=0
MIMEPromptMultilingual=1
MIMEMultilingualMode=1
EnableActiveXInBrowser=1
EnableJavaScript=1
EnableJavaScriptErrorDialogs=1
EnableLiveConnect=1
ShowAccelerators=1
DisableImageDithering=1
FileDlgDirectory=D:\AADatabaseFiles\Notes
StickyColumnSort=0
DeskIconColors=0
$PinnedURLPopup=0
Win32InfoboxPos=650 343
BROWSERSIZE=158
DesignWinSplitterPos=222 -1
$CreateBookmarkLastFolder=Databases
MailType=1
DESIGNWINDOWSIZEWIN=20 15 984 715
DESIGNMAXIMIZED=0
StackedIcons=0
$Notesdes.nsfNavState=1
$HowToCatToggle=0
KeyFilename=user.id


0
 
scottrmaCommented:
So just reinstall....

:-)

Scott
0
 
StuartOrdAuthor Commented:
OK guys, thanks for your help. I'll just reinstall now. I must say I'm a bit p*****d off with Lotus - professional software shouldn't be able to do this. But hey-ho, it's problems that makes life interesting. Speaking of which I need to resolve points for this and a previous question, so I'll close this with points for Zvonko, and put a new question for scottrma to thank for your help as suggested in the help bit of the site. No doubt another real question will follow.
Stuart
0
All Courses

From novice to tech pro — start learning today.