?
Solved

Linux Dial in question

Posted on 2003-02-26
7
Medium Priority
?
343 Views
Last Modified: 2010-04-20
Hello All, Well I have been trying to set-up a Linux dial in server. I think I have everything configured properly, but it seems like the remote is not getting an IP. I am using mgetty, and it runs fine. On remote system (Win ME) I can I use the "open dialog window" option to log into linux shell, and execute ppp ( it does this automatically via AutoPPP). My logs show that it is connected. When I use "w" command it shows the user is logged in. My ppp log shows a connection on ppp0. At this point I really don't know what to expect but when I press continue on remote computer it hangs on "verifying username and password". I figure it is not establishing IP conectivity as remote does not get an ip and neither does modem on linux box, not sure if thats the next step in process. I guess my question is what do I do next?

Thnx in advance!

GR
0
Comment
Question by:GR999
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 2
7 Comments
 
LVL 8

Expert Comment

by:heskyttberg
ID: 8030136
Hi!

I'm not sure how to set the IP for your remote linux ppp modem. But in order for the Win ME to get an IP you need to setup DHCP server on the linux server.

Regards
/Hans - Erik Skyttberg
0
 

Author Comment

by:GR999
ID: 8045532
Ok I set up DHCP, my eth1 can pick up a address via DHCP, so it is working. I am still getting an error of ICPC: Timeout sending config request, when I try to dial in from Win ME computer. I am capable of dialing out on both Win ME and Linux. I don't what ICPC error means. User gets authenticated but hangs after that. Anymore clues?

Thanx,
GR
0
 

Author Comment

by:GR999
ID: 8045552
This is what I get from my log:


pppd 2.4.1 started by a_ppp, uid 0
Mar 1 06:01:39 Jimmy pppd[895]: Using interface ppp0
Mar 1 06:01:39 Jimmy pppd[895]: Connect: ppp0 <--> /dev/ttyS4
Mar 1 06:01:42 Jimmy pppd[895]: user foster logged in
Mar 1 06:01:50 Jimmy pppd[1057]: pppd 2.4.1 started by a_ppp, uid 0
Mar 1 06:02:42 Jimmy pppd[895]: IPCP: timeout sending Config-Requests
Mar 1 06:02:42 Jimmy pppd[895]: Connection terminated.


0
NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

 
LVL 8

Accepted Solution

by:
heskyttberg earned 260 total points
ID: 8047335
Hi!

Did you remember to tell dhcpd daemon to send out on ppp0 too ?

If you do like this:
ps -ef | grep dhcp

You should see something like:
/sbin/dhcpcd -n eth0

In order for ppp0 to get IP, you need to add:
/sbin/dhcpcd -n ppp0

I think you should also put ppp0 and eth0 on diffrent subnets so you can route traffic through too your local LAN when dialing in you need that.

If you are using redhat this can be done in:
/etc/sysconfig/dhcpd

Just set DHCPDARGS=-n ppp0
Or maybe DHCPDARGS=-n ppp

I'm a little onto deep water here, cause on my Linux box I have no /dev/ppp0 device I only have /dev/ppp.

I haven't dug too deep into this area yet, I was going to build an smart answering machine, but my current modem dosen't support voice so I need to get another one.

Well anyway....

I hope any of this info helps.

Regards
/Hans - Erik Skyttberg

0
 

Author Comment

by:GR999
ID: 8052298
Ok this is not working. This maybe a dumb question, but how do I assign an IP address to my linux modem. The linux modem does not even get an ip. When I see the connection established on ppp0, I ifconfig and it shows its not up. I tried using the commnads u gave for the dhcp server but since ppp0 is never up until a connection is made I cannot assign an ip to it. Even when I am able to assign an ip to the modem, it doesn't take. When I do dial-out on the modem I can see it passes the local:remote ip's, as setup in the /etc/ppp/options, just not when a dial-in is initiated.

GR
0
 

Author Comment

by:GR999
ID: 8065929
Well Hans I got it too work. Ended up being a issue with CBCP within pppd. I upgrade ppp to a higer version and fixed it. I appreciate your help. Good luck with the answering machine, sounds neat.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=55367

GR
0
 

Author Comment

by:GR999
ID: 8439475
Although I found the fix myself, I appreciate your effort.

Thx,
GR
0

Featured Post

Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

1. Introduction As many people are interested in Linux but not as many are interested or knowledgeable (enough) to install Linux on their system, here is a safe way to try out Linux on your existing (Windows) system. The idea is that you insta…
The purpose of this article is to demonstrate how we can use conditional statements using Python.
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
Suggested Courses
Course of the Month14 days, 13 hours left to enroll

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question