?
Solved

cisco rip and igrp updates failing over serial interface

Posted on 2003-02-26
16
Medium Priority
?
427 Views
Last Modified: 2007-02-12
i have a cisco 1601 and a 2611 (both with 12.2 ios) back to back via a dce/dte cable.  i have igrp routing set up on both routers.  i can see the igrp broadcasts in terminal mode, but the routers are not adding the routes to the routing tables.  the physical connection is working fine because i tested it with static routes with great results.  any help would be appreciated.

0
Comment
Question by:wsurferdude
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 7
16 Comments
 

Expert Comment

by:heng_cs
ID: 8029993
if you are referring to IGRP, you need to set a same autonomous system(AS) number on all routers. Or else, they will not communicate with routing info.

Thanks.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8030003
Are your Ethernet ports active, plugged in? If the interface is down, the route will not be propogated. Of course, they are because you said a static route entry worked. Do you have the same igrp as number on both sides?


Can you paste your configs?
0
 

Author Comment

by:wsurferdude
ID: 8030220
Here are my configs...

2611 Router


JC2611#sh conf
Using 1653 out of 29688 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname JC2611
!
logging rate-limit console 10 except errors
!
ip subnet-zero
!
!
no ip finger
ip name-server 204.127.202.4
ip name-server 216.148.227.68
!
ip audit notify log
ip audit po max-events 100
no ip dhcp-client network-discovery
!
!
!
interface FastEthernet0/0
 ip address dhcp
 ip access-group 110 out
 ip directed-broadcast
 ip nat outside
 speed auto
 half-duplex
 no cdp enable
!
interface Serial0/0
 description WAN Link to JC1602
 ip address 192.168.15.1 255.255.255.0
 ip directed-broadcast
 no ip mroute-cache
 clockrate 4000000
!
interface FastEthernet0/1
 ip address 192.168.10.1 255.255.255.0
 ip nat inside
 no ip mroute-cache
 duplex auto
 speed auto
!
interface Ethernet1/0
 ip address dhcp
 ip access-group 105 out
 ip directed-broadcast
 ip nat outside
 half-duplex
 no cdp enable
!
router igrp 10
 passive-interface FastEthernet0/0
 passive-interface Ethernet1/0
 network 12.0.0.0
 network 192.168.10.0
!
ip nat pool global 12.235.253.75 12.235.253.75 netmask 255.255.255.0
ip nat inside source list 5 pool global overload
ip classless
no ip http server
!
access-list 5 permit 192.168.0.0 0.0.255.255
access-list 105 deny   ip 192.168.0.0 0.0.255.255 any
access-list 105 permit ip any any
access-list 110 deny   ip 192.168.0.0 0.0.255.255 any
access-list 110 permit ip any any
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password radical
 login
line vty 5 15
 password radical
 login
!
end

JC2611#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 12.235.252.1 to network 0.0.0.0

C    192.168.15.0/24 is directly connected, Serial0/0
C    192.168.10.0/24 is directly connected, FastEthernet0/1
     12.0.0.0/24 is subnetted, 2 subnets
C       12.235.253.0 is directly connected, Ethernet1/0
C       12.235.252.0 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [254/0] via 12.235.252.1
JC2611#


1602 Router


JC1602#sh conf
Using 1054 out of 7506 bytes
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname JC1602
!
boot system flash 1:cpa1600-upgrade-l.112-3.P
!
ip subnet-zero
no ip finger
ip name-server 204.127.202.4
ip name-server 216.148.227.68
!
!
!
interface Ethernet0
 description local lan
 ip address 192.168.20.1 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
interface Serial0
 description WAN 56K CSU/DSU
 bandwidth 64000
 no ip address
 no ip directed-broadcast
 no ip route-cache
 fair-queue 64 256 0
 service-module 56k clock source line
 service-module 56k network-type switched
!
interface Serial1
 ip address 192.168.15.2 255.255.255.0
 ip directed-broadcast
 no ip route-cache
!
router igrp 10
 network 192.168.15.0
 network 192.168.20.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.15.1
!
!
line con 0
 exec-timeout 0 0
 transport input none
line 2
line vty 0 4
 exec-timeout 0 0
 password 7 02080B4F040B
 login
!
end

JC1602#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR
       T - traffic engineered route

Gateway of last resort is 192.168.15.1 to network 0.0.0.0

C    192.168.15.0/24 is directly connected, Serial1
C    192.168.20.0/24 is directly connected, Ethernet0
S*   0.0.0.0/0 [1/0] via 192.168.15.1
JC1602#
0
Don't Cry: How Liquid Web is Ensuring Security

WannaCry is just the start. Read how Liquid Web is protecting itself and its customers against new threats.

 

Author Comment

by:wsurferdude
ID: 8030398
Here are my configs for both routers


2611 Router


JC2611#sh conf
Using 1653 out of 29688 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname JC2611
!
logging rate-limit console 10 except errors
!
ip subnet-zero
!
!
no ip finger
ip name-server 204.127.202.4
ip name-server 216.148.227.68
!
ip audit notify log
ip audit po max-events 100
no ip dhcp-client network-discovery
!
!
!
interface FastEthernet0/0
 ip address dhcp
 ip access-group 110 out
 ip directed-broadcast
 ip nat outside
 speed auto
 half-duplex
 no cdp enable
!
interface Serial0/0
 description WAN Link to JC1600
 ip address 192.168.15.1 255.255.255.0
 ip directed-broadcast
 no ip mroute-cache
 clockrate 4000000
!
interface FastEthernet0/1
 ip address 192.168.10.1 255.255.255.0
 ip nat inside
 no ip mroute-cache
 duplex auto
 speed auto
!
interface Ethernet1/0
 ip address dhcp
 ip access-group 105 out
 ip directed-broadcast
 ip nat outside
 half-duplex
 no cdp enable
!
router igrp 10
 passive-interface FastEthernet0/0
 passive-interface Ethernet1/0
 network 12.0.0.0
 network 192.168.10.0
!
ip nat pool global 12.235.253.75 12.235.253.75 netmask 255.255.255.0
ip nat inside source list 5 pool global overload
ip classless
no ip http server
!
access-list 5 permit 192.168.0.0 0.0.255.255
access-list 105 deny   ip 192.168.0.0 0.0.255.255 any
access-list 105 permit ip any any
access-list 110 deny   ip 192.168.0.0 0.0.255.255 any
access-list 110 permit ip any any
!
line con 0
 transport input none
line aux 0
line vty 0 4
  login
line vty 5 15
  login
!
end

JC2611#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 12.235.252.1 to network 0.0.0.0

C    192.168.15.0/24 is directly connected, Serial0/0
C    192.168.10.0/24 is directly connected, FastEthernet0/1
     12.0.0.0/24 is subnetted, 2 subnets
C       12.235.253.0 is directly connected, Ethernet1/0
C       12.235.252.0 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [254/0] via 12.235.252.1
JC2611#



JC1602#sh conf
Using 1054 out of 7506 bytes
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname JC1602
!
boot system flash 1:cpa1600-upgrade-l.112-3.P
!
ip subnet-zero
no ip finger
ip name-server 204.127.202.4
ip name-server 216.148.227.68
!
!
!
interface Ethernet0
 description local lan
 ip address 192.168.20.1 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
interface Serial0
 description WAN 56K CSU/DSU
 bandwidth 64000
 no ip address
 no ip directed-broadcast
 no ip route-cache
 fair-queue 64 256 0
 service-module 56k clock source line
 service-module 56k network-type switched
!
interface Serial1
 ip address 192.168.15.2 255.255.255.0
 ip directed-broadcast
 no ip route-cache
!
router igrp 10
 network 192.168.15.0
 network 192.168.20.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.15.1
!
!
line con 0
 exec-timeout 0 0
 transport input none
line 2
line vty 0 4
 exec-timeout 0 0
  login
!
end

JC1602#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR
       T - traffic engineered route

Gateway of last resort is 192.168.15.1 to network 0.0.0.0

C    192.168.15.0/24 is directly connected, Serial1
C    192.168.20.0/24 is directly connected, Ethernet0
S*   0.0.0.0/0 [1/0] via 192.168.15.1
JC1602#
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8030445
can you post results of
router#sho cdp neigh detail


Do you have the DCE cable plugged into the router with the clockrate command?

Are you using the nat at the moment? suggest removing the nat inside/outside statements while you get this working.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8030455
can you post results of
router#sho cdp neigh detail


Do you have the DCE cable plugged into the router with the clockrate command?

Are you using the nat at the moment? suggest removing the nat inside/outside statements while you get this working.
0
 

Author Comment

by:wsurferdude
ID: 8030543
i'll try removing nat
i've tried the dce clockrate command set any where from 56k to 4meg
here is the cdp detail

thanks for taking the time to help out !
john

JC2611#sh cdp neigh detail
-------------------------
Device ID: jc2924
Entry address(es):
  IP address: 192.168.10.5
Platform: cisco WS-C2924M-XL,  Capabilities: Trans-Bridge Switch
Interface: FastEthernet0/1,  Port ID (outgoing port): FastEthernet0/9
Holdtime : 122 sec

Version :
Cisco Internetwork Operating System Software
IOS (tm) C2900xl Software (C2900xl-C3H2S-M), Version 12.0(5)WC5, RELEASE SOFTWAR
E (fc1)
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Tue 28-May-02 11:11 by devgoyal

advertisement version: 2
Protocol Hello:  OUI=0x00000C, Protocol ID=0x0112; payload len=27, value=0000000
0FFFFFFFF010121FF00000000000000D006FC3080FF0003
VTP Management Domain: ''
Native VLAN: 3
Duplex: full

-------------------------
Device ID: JC1602
Entry address(es):
  IP address: 192.168.15.2
Platform: cisco 1602,  Capabilities: Router
Interface: Serial0/0,  Port ID (outgoing port): Serial1
Holdtime : 178 sec

Version :
Cisco Internetwork Operating System Software
IOS (tm) 1600 Software (C1600-OY-L), Version 12.0(3), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-1999 by cisco Systems, Inc.
Compiled Mon 08-Feb-99 21:20 by phanguye

advertisement version: 1

JC2611#

JC1602#sh cdp neigh detail
-------------------------
Device ID: jc2924
Entry address(es):
  IP address: 192.168.10.5
Platform: cisco WS-C2924M-XL,  Capabilities: Trans-Bridge Switch
Interface: Ethernet0,  Port ID (outgoing port): FastEthernet0/17
Holdtime : 156 sec

Version :
Cisco Internetwork Operating System Software
IOS (tm) C2900xl Software (C2900xl-C3H2S-M), Version 12.0(5)WC5, RELEASE SOFTWAR
E (fc1)
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Tue 28-May-02 11:11 by devgoyal

-------------------------
Device ID: JC2611.attbi.com
Entry address(es):
  IP address: 192.168.15.1
Platform: cisco 2621,  Capabilities: Router
Interface: Serial1,  Port ID (outgoing port): Serial0/0
Holdtime : 149 sec

Version :
Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-IO3-M), Version 12.2(1a), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2001 by cisco Systems, Inc.
Compiled Sat 26-May-01 14:34 by pwade

JC1602#

0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8030735
first, on the 2600, add the serial subnet to the igrp:
router igrp 10
 network 192.168.15.0

badabing!

else:

A serial interface will only support 2Mb, so set the clockrate to 2000000
do a "sho controller serial 0/0" and "sho controller ser 1"
The results should tell you what cable it thinks is attached - DTE or DCE. Make sure the DCE cable is attached to the router with the clockrate statement.

Since they both are plugging into the same switch, try making two vlans on the switch so they won't bleed over with each other.

Also try using passive interface Eth 0 under eigrp on the 1602, and passive interface fast 0/1 on the 2600

Just for giggles, try changing it to eigrp vs igrp

no router igrp 10
router eigrp 100
 network xxx
 network xxx
 no auto-summary
 
0
 

Author Comment

by:wsurferdude
ID: 8030759
i'll try removing nat
i've tried the dce clockrate command set any where from 56k to 4meg
here is the cdp detail

thanks for taking the time to help out !
john

JC2611#sh cdp neigh detail
-------------------------
Device ID: jc2924
Entry address(es):
  IP address: 192.168.10.5
Platform: cisco WS-C2924M-XL,  Capabilities: Trans-Bridge Switch
Interface: FastEthernet0/1,  Port ID (outgoing port): FastEthernet0/9
Holdtime : 122 sec

Version :
Cisco Internetwork Operating System Software
IOS (tm) C2900xl Software (C2900xl-C3H2S-M), Version 12.0(5)WC5, RELEASE SOFTWAR
E (fc1)
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Tue 28-May-02 11:11 by devgoyal

advertisement version: 2
Protocol Hello:  OUI=0x00000C, Protocol ID=0x0112; payload len=27, value=0000000
0FFFFFFFF010121FF00000000000000D006FC3080FF0003
VTP Management Domain: ''
Native VLAN: 3
Duplex: full

-------------------------
Device ID: JC1602
Entry address(es):
  IP address: 192.168.15.2
Platform: cisco 1602,  Capabilities: Router
Interface: Serial0/0,  Port ID (outgoing port): Serial1
Holdtime : 178 sec

Version :
Cisco Internetwork Operating System Software
IOS (tm) 1600 Software (C1600-OY-L), Version 12.0(3), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-1999 by cisco Systems, Inc.
Compiled Mon 08-Feb-99 21:20 by phanguye

advertisement version: 1

JC2611#

JC1602#sh cdp neigh detail
-------------------------
Device ID: jc2924
Entry address(es):
  IP address: 192.168.10.5
Platform: cisco WS-C2924M-XL,  Capabilities: Trans-Bridge Switch
Interface: Ethernet0,  Port ID (outgoing port): FastEthernet0/17
Holdtime : 156 sec

Version :
Cisco Internetwork Operating System Software
IOS (tm) C2900xl Software (C2900xl-C3H2S-M), Version 12.0(5)WC5, RELEASE SOFTWAR
E (fc1)
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Tue 28-May-02 11:11 by devgoyal

-------------------------
Device ID: JC2611.attbi.com
Entry address(es):
  IP address: 192.168.15.1
Platform: cisco 2621,  Capabilities: Router
Interface: Serial1,  Port ID (outgoing port): Serial0/0
Holdtime : 149 sec

Version :
Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-IO3-M), Version 12.2(1a), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2001 by cisco Systems, Inc.
Compiled Sat 26-May-01 14:34 by pwade

JC1602#

0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8030797
Don't hit your browser refresh... use the "reload this question" link under your login name, top left corner of the page...
0
 

Author Comment

by:wsurferdude
ID: 8030833
i found my stupid mistake... i failed to have the s0/0 network 192.168.15.0 on the 2611 router igrp.  i used the debug ip igrp transactions and could see no conversations between the two, so i double checked my igrp netowrk listings....

thanks for your time!

i have one problem still..  i cannot achive an outside (internet) connection from the 192.168.20.0 net on the 1602 router.  this has to go 1 additional hop than any of my any other connections to the net.  this is a cable modem setup.  could the isp be limiting the number of router hops????  or is my problem still with the serial interface???

john
0
 

Author Comment

by:wsurferdude
ID: 8030846
just learning this site... thanks for the reload info.... couldn't understand why i was double posting....

john

0
 
LVL 79

Accepted Solution

by:
lrmoore earned 200 total points
ID: 8030876
I guess we found the same problem at the same time..

Interface ser 0/0
 ip nat inside
ip route 0.0.0.0 0.0.0.0 Fastethernet0/0

0
 

Author Comment

by:wsurferdude
ID: 8030967
you don't know how much you have helped me tonight...  i've just been getting into dynamic routing protocols and nat in the past couple of days.  i'm getting ready for my ccna and mcse.  nat doesn't really come into the ccna, but i've needed it for practical reasons...  now i have to study why that missing nat statement had to do with my 1602 not being able to route to the internet....  anyways... you have saved me a bunch o time...  

thanks again,
john
0
 

Author Comment

by:wsurferdude
ID: 8030985
excellent help!!  been working on my ccna and this saved me a bunch of time...  can't say enough...

A+++++
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8033083
Glad to help!
0

Featured Post

Ransomware Attacks Keeping You Up at Night?

Will your organization be ransomware's next victim?  The good news is that these attacks are predicable and therefore preventable. Learn more about how you can  stop a ransomware attacks before encryption takes place with our Ransomware Prevention Kit!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

For many of us, the  holiday season kindles the natural urge to give back to our friends, family members and communities. While it's easy for friends to notice the impact of such deeds, understanding the contributions of businesses and enterprises i…
WARNING:   If you follow the instructions here, you will wipe out your VTP and VLAN configurations.  Make sure you have backed up your switch!!! I recently had some issues with a few low-end Cisco routers (RV325) and I opened a case with Cisco TA…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…
Suggested Courses
Course of the Month10 days, 11 hours left to enroll

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question