accessing samba though a redhat 7 box via a vpn?

Hi just wondering and am getting nowhere fast, i have established a vpn between my laptop and my linux server in the office.

I problem i am having is i am not able to find any info on the net to show me how to connect to the samba directory in /home/shared where all my crap is located.

what do i need to do to establish the share or to map the drive from my laptop on a dial up connection.

Remember i have successfully established a conenction with a username and password.

skidlidAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ken_330Commented:
hi skidlid,
       your info isnt enough , what is your OS in the laptop? what is the LINUX server running which os?
      If u didnt install linneighbourhood, I believe u need to use smbclient ....SAMBA native commands...to check n list any available share ...in UNIX...U need to familise with these smbclient commands....etc
 smbclient -L HOSTNAME -U .....for - U ..samba 2.06 n above
no -U for 1.9x...
      then u need to create an account for your client before your client can sees a share appears....in the network neigbourhood if its a win98box.IF it is a linux box, u can only use smbclient to view until u install a linux neighbourhood vpn.Look for smbmount ..to mount shares..refer to samba books...

     HOpe its helps
0
ken_330Commented:
oh ..i forgot ,
        u need to set your linux server to accept encrypt passwd in the smb.conf file before it allows a win98box to logg into smb.As for Unix, u need not to do anything ,for its using plaintpasswd text by default

bye
0
skidlidAuthor Commented:
ok here is my smb file:

am working on mounting the /home/shared directory...at momnet, but i cant still get access from the outside world, i mean the vpn is working but i cant browse anything. I have a dyn dns working on my box so i telnet into it from outside world and use webmin, i have the 137-139 ports open. I am guessing that i havent mnted the share so its not letting mesee anything, anyhow here ismy smb.conf. Ohh and i am using win2k to access it from the net.

#======================= Global Settings =====================================
[global]
netbios name = Samba
workgroup = Ozxpress
server string = File Storage

bind interfaces only = yes
interfaces = eth1 192.168.3.0/24

printcap name = /etc/printcap
load printers = yes

max log size = 50
security = share

socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
dns proxy = no

# WINS / VPN
# ----------

preferred master = auto
wins support = yes
wins server =

# Other handy directives
# ----------------------
# domain master = yes
# local master = yes
# os level = 65
# remote announce =
# remote browse sync =


#============================ Share Definitions ==============================

[printers]
printing = cups
print command = lpr -r -P%p -o raw %s
browseable = yes
printable = yes
public = yes
guest ok = yes

[shared]
comment = Shared Folder
path = /home/shared
writable = yes
public = yes
printable = no

[website]
comment = Web Site
path = /var/www
writable = yes
public = yes
printable = no
create mask = 0755
0
ken_330Commented:
hi Skidlid,
       i advice u read again my first comment carefully,n u get a samba book ready at hand for reference.
       You had to try to access it locally first which u didnt mention whether u sucessfully did it ? u dont have to mount a share to be access thru samba ,when u use swat
to configure a (create) share ,its is automatically allow to be browse if its set browseable to yes.Also,try to goto
the XGUI file manager to check the share's properties whether it is set to 777 mode.IF not , set it by clicking with the mouse which is easier then the command line.
      Being done that, then go to command line,use smbclient -L HOSTNAME -U to see a list of share being configured.At the commandline : testparm to see if any errors occure? No errors, then it is correctly setup.
Obviously , u need to create an account in LINUX or UNIX
by loggin in as ROOT ,superuserlevel like :
try this :             adduser Trial
                       passwd Trial    

then                   smbadduser Trial:Trial
u would be prompt:     smbpasswd.


account created.
then u try to exit n loggin in with the account name n passwd , u would be able to access into the homeshare.


IF u still have doubts,it best to refer to samba book.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CleanupPingCommented:
skidlid:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.