?
Solved

GRUB boot loader has serious problems

Posted on 2003-02-26
9
Medium Priority
?
364 Views
Last Modified: 2013-12-06
My GRUB boot loader is so screwed up!  When I boot the computer, it starts up around the BIOS, getting the hard disks and CD-ROMs ready, yadda yadda, but when it gets through and tried to boot from the master disk, it totally crashes.  I end up at the DOS-like screen with a L, followed by a flashing cursor afterwards that I can't type anything into.  The last line literally looks like this: L_

I am able to type this message through this computer only because the boot disk loaded Linux.  You know, the boot disk that Red Hat Linux creates for you at the very end of the install?  Yeah.  But there's a huge problem ... my native OS is Windows, and Windows XP is installed on my master disk, while Linux is installed onto the slave.  Uh ... it can't load or even access the master disk or Windows XP!

I am a digital musician (techno, dance, hardcore, electronica, you know).  So I really need to get back at my music production on Windows XP.  I have about 2,000 songs, 10,000 samples, and thousands of dollars worth in virtual studio technology!  So I can't just format and reinstall XP or anything.

I tried downloading the GRUB archive and installing as the instructions prompted to.  I extracted the files and, while logged in as root, tried typing "./configure", "make", and "make install".  It looked like it worked but when I restared, it really didn't.  Same problem.

Here's my configuration:

There's a master disk and a slave disk
Windows XP is installed on the master
The master uses an NTFS file system
Red Hat Linux is installed on the slave
The slave uses an ext3 file system
The boot loader attempted to install to the MBR on the master
The /boot/ directory is on the slave

Some ideas I had:

Making the slave disk the master and vice versa
Popping in the Windows XP install disk/disc and seeing what I can do
Finding some other boot loader of some type

But really, do you think there's a possibility that GRUB will not work on my system?  Do you think my master disk is damaged??

One more thing, at the very very end of the Linux install, right after I clicked "Finish" to complete the installation, it gave me dozens of errors in the DOS-like text, sent out kill signals, and restarted to the defective GRUB loader.  Thats when I started using the boot disk.

Thanks for all the help!!
0
Comment
Question by:orange400
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
9 Comments
 
LVL 2

Expert Comment

by:jimbb
ID: 8035567
While I do prefer GRUB over LILO, judging by what you pasted (the "L_"), I'd say that LILO is in your boot sector and _not_ GRUB.

What OS is this, RHL?  Are you sure you selected the GRUB bootloader during install, and not LILO?
0
 

Expert Comment

by:ManojMathew
ID: 8045367
Hi,
Prior to installing linux did u boot windows xp and have u made any changes in to accomodate linux..
If u have not made any changes and have just installed linux after normally then  try this

Boot using a dos bootable disk
and on the command prompt type


fdisk /mbr
(the bootable disk must also have fdisk in it)
This will clear ur mbr and u will get ur windows loader back from which u can access windows xp...but mind u u will not be able to access linux after that ..u would probably have to load linux again.

judging by what u have written ur linux partition does not have data...
so u can safely re install linux again....
0
 

Expert Comment

by:ManojMathew
ID: 8045372
fdisk /mbr should be done on the master disk
0
Get MySQL database support online, now!

At Percona’s web store you can order your MySQL database support needs in minutes. No hassles, no fuss, just pick and click. Pay online with a credit card.

 

Author Comment

by:orange400
ID: 8046615
I'm running Red Hat 8.0

Yeah, I am using LILO now, but I've tried the GRUB boot loader so many times that I finally tried LILO and it crashes worse (I've installed Linux about 5 times over)!

That fdisk /mbr thing sounds very interesting, I think I'll try that ... will it boot up a NTFS-formatted drive?  Can I take the fdisk program from my other computer running Windows 98 SE?  I'm just going to try it anyways to see what happens ... got nothing to lose right?  Oh!  I just remembered!  My neighbor has XP Professional ... if for some reason it doesn't work I'll just snag it from her and try again ...

I had Windows XP installed way before Linux, and just slapped in Linux in like 15 minutes one night like the computer didn't know what hit it.  So I didn't make any changes, I didn't think I'd have to ... right?

I have this Linux boot disk that'll load Linux every time no matter what the situation ... if the GRUB boot loader doesn't work out but I can load XP, I'll just pop in the boot disk when I want to run Red Hat.

Cool, I'll try this stuff.  Thanks for the quick replies!!  Keep 'em coming!  You guys are like, saving my life, literally, all my years of work is on the master disk.
0
 

Author Comment

by:orange400
ID: 8046911
Well I tried the fdisk thing, but no luck at all.  The computer won't even boot with the disk!  I am certain that it is a valid, working boot disk too.  So weird ... it hangs like hda's boot loader does, only without any text.

I tried installing the GRUB boot loader through the terminal again, but I don't think it worked.  I'll attach a file on my next post with a linux text document of the terminal through the install ... this may be useful if you are still with me on this!
0
 

Author Comment

by:orange400
ID: 8047425
I fixed it!!

It's late so I have to make it short, but the slave disk was not set up in the BIOS - the OSs were supporting it!  So the /boot directory was never found, so there it is, no boot loader.  Now it works like a charm!  I never knew Windows XP and Red Hat could work so smoothly simultaneously.

Thanks for all the support!
0
 

Expert Comment

by:CleanupPing
ID: 9087847
orange400:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
 
LVL 12

Expert Comment

by:paullamhkg
ID: 9260339
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is to:

Be PAQ'd/Points Refunded

Please leave any comments here within the next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

Paul
EE Cleanup Volunteer
0
 
LVL 2

Accepted Solution

by:
Lunchy earned 0 total points
ID: 9333461
PAQed per request/recommendation & Points refunded

Lunchy
Friendly Neighbourhood Community Support Moderator
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Ready to improve network connectivity? Watch this webinar to learn how SD-WANs and a one-click instant connect tool can boost provisions, deployment, and management of your cloud connection.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In my business, I use the LTS (Long Term Support) versions of Linux. My workstations do real work, and so I rarely have the patience to deal with silly problems caused by an upgraded kernel that had experimental software on it to begin with from a r…
The purpose of this article is to demonstrate how we can use conditional statements using Python.
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Suggested Courses
Course of the Month14 days, 20 hours left to enroll

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question