?
Solved

Adding a windows client to swtich

Posted on 2003-02-26
3
Medium Priority
?
212 Views
Last Modified: 2010-04-17
Hello,

I am having trouble adding a windows 2000 client to a small practice network.  

On the windows box I ipconfig /release, then I added:

IP:               172.16.30.4
SUB:              255.255.255.0
DefaultGateway:   172.16.1.1
DHCP Enabled:     No

On the switch the config is:  

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname orion
!
enable secret 5 $1$uDmz$L9mhRl/W8piKub1ArR3w3.
!
!
!
!
!
!
ip subnet-zero
cluster enable MilkyWay 0
!
!
!
 --More--
interface FastEthernet0/1
 duplex full
 switchport access vlan 2
!
interface FastEthernet0/2
 duplex full
!
interface FastEthernet0/3
 description MadduxVLAN
 duplex full
 switchport access vlan 2
!
interface FastEthernet0/4
!
interface FastEthernet0/5
 duplex full
 switchport access vlan 2
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
 duplex full
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
 ip address 172.16.30.1 255.255.255.0
 no ip directed-broadcast
 ip nat outside
 shutdown
!
interface VLAN2
 ip address 172.16.30.1 255.255.255.0
 no ip directed-broadcast
 --More--
ip nat outside
!
ip default-gateway 172.16.1.1
ip nat inside source list 199 interface VLAN2 overload
access-list 1 permit 172.16.30.4
access-list 199 dynamic Cluster-NAT permit ip any any
snmp-server engineID local 00000009020000049AC76680
snmp-server community private RW
snmp-server community public RO
snmp-server community private@es0 RW
snmp-server community public@es0 RO
!
line con 0
 exec-timeout 0 0
 transport input none
 stopbits 1
line vty 0 4
 password dctidcti
 login
line vty 5 15
 password dctidcti
 login
!
 --More--
!
end


I am trying to add the client to int fastethernet 0/5, on VLAN 2.  

On Fastethernet 0/1, 03, I have two routers that I can ping and telnet into.  But when I ping 172.16.30.4
I don't get a response.  

This just a lab that I am putting together and the only reason that I want to do this is use the client as a TFTP server.  

Any help would be appreciated.

Thanks

B
0
Comment
Question by:bgregorcy
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 300 total points
ID: 8030965
G'day bgregorcy

You can't have a default gateway on a different subnet as your interface.  Use 172.16.30.1 as your gateway

Cheers!
0
 
LVL 7

Expert Comment

by:pedrow
ID: 8030986
the tftp server's default gateway is wrong (or the ip address is)

IP:               172.16.30.4
SUB:              255.255.255.0
DefaultGateway:   172.16.1.1 <-------------needs to be on the same network as it's own ip address
DHCP Enabled:     No


So, maybe 172.16.30.1 ?

and it also looks like you've configured vlan1 and vlan2 with the same ip addresses?

Usually you define one ip address on a vlan as a management interface. You need to assign a default route for that ip address, but the other vlans shouldn't have ip addresses...this is a switch, so it's a layer 2 device :)

The devices on Vlan2 should be addressed presumably in the 172.16.30.0/24 range.

Now you may be using separate routers for the different vlans, or you've got a trunk connecting the switch to one of the routers and using dot1q or isl encapsulation(that's another subject).

So, you've got a few things you need to look at. Once you sort out what addresses you want your host on and how you want to route between your lans, then we can go from there :)

0
 

Author Comment

by:bgregorcy
ID: 8038980
Thanks for the replies,


The problem was that i didn't have the default gateway set.  When I set it, it still didn't work which was wierd.  So after I played with it for awhile I tried another windows box, put in the same settings and it worked fine.  So on the box that I had problems with I uninstalled/reinstalled and put the ip, sub, and gateway.  Now I can ping it.  

Again thanks for the help.  
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen some questions on problems with SSH/telnet access to Cisco routers that may occur despite the fact that from a PC connected to your LAN, Internet connectivity is in place and users can access Internet sites without any issues.  There are…
There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question