Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 391
  • Last Modified:

REDHAT 7.3 FIELMANAGER

Is thear any file manager where can i telnet from windows
to linux box.Like "linuxconf"
0
belranjan
Asked:
belranjan
1 Solution
 
GeneriKCommented:
Your question is very vague - do you want to telnet into your Linux box from a networked Windows machine?

LinuxConf is a setup application to configure your RedHat installation.

Please provide some more detail so I can help!
0
 
GnsCommented:
Yes, what _do_ you mean?

Telneting into the linux box can be done with telnet (Start->Run, Enter: telnet <hostname or IP address of linux host>) or if you need a ssh capable client PuTTY (http://www.chiark.greenend.org.uk/~sgtatham/putty/).

Generik covered LinuxConf, so I'll just mention another web-based administration/control tool: Webmin. Which still has very little to do with "filemanagers" and "telnet".

Or is this a dual boot system, where you want to access the ext2/ext3 partitions/filesystems? Then you'd need explore2fs (http://uranus.it.swin.edu.au/~jn/linux/explore2fs.htm) or a similar tool.

Please be as verbose and precise as possible, the quality of advice will rise:-).

-- Glenn
0
 
belranjanAuthor Commented:
What i mean is like terminal server for windos 2000.Like that for example "exceed".The hole desktop of gnome should comes on widows pc .
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
GnsCommented:
What you need is VNC then. It's a bit like pcANYWHERE. You can "share" desktop sessions with more than one viewers.
Look at it/get a windows viewer (and perhaps a server too) from http://www.tightvnc.com (it's OpenSource... the right price:-).

VNC comes default with RedHat, but you might need to install it.
Become root (on a command line prompt) and check if it is installed with
rpm -qi vnc-server<Enter>

If it isn't, you'll have to look for it on the installation CDs (since I don't remember on which one it is:-):
Place the first CD in the drive and
mount /mnt/cdrom<Enter>
ls -l /mnt/cdrom/RedHat/RPMS/vnc-server*<Enter>
If you find it, install it with
rpm -ivh /mnt/cdrom/RedHat/RPMS/vnc-server*<Enter>
else
umount /mnt/cdrom<Enter>
and repeat for the next CD.

If/when it is installed, check the file /etc/sysconfig/vncservers to see if it is configured (if it is installed, you can do "/etc/init.d/vncserver status" to see if it is running). Example for user "glenn" (you should use something more appropriate for your system;)
If the line looks like
# VNCSERVERS="1:myusername"
change it to look like
VNCSERVERS="1:glenn"

If it wasn't configured, you'll have to start a vncserver manually _as the user_ to set up the default vnc configuration files. Continuing the example
su - glenn
vncserver :1<Enter>
<enter and verify the VNC password>

Provided you enter the passwords OK, it will start a VNC server with a default session (probably the one specified in /etc/sysconfig/desktop).
exit<Enter>
back to root and set it up to run upon reboots
chkconfig vncserver on<Enter>
Check it with
chkconfig --list vncserver<Enter>

You can start/stop the server just to see that it works OK from the rc/init-scripts:
/etc/init.d/vncserver restart<Enter>
and check it with
/etc/init.d/vncserver status<Enter>

Now you can either "install" a vncviewer on the windoze machines, or just point your favourite web-browser to http://<name or IP address of your linux machine>:5801 to use the ("installation-free":-) java viewer.

-- Glenn
0
 
GnsCommented:
Gad, cut-n-paste plays tricks sometimes... the very last pat of the previous comment should have read:

http://(name or IP address of your linux machine):5801 to use the ("installation-free":-) java viewer.

-- Glenn
0
 
belranjanAuthor Commented:
The vnc server is installed in redhat7.3.I also startted the vncserver from /etc/init.d vncserver start <enter>
but when i cheak the status it is showing it is stopped.To make it work properly what i have to do.
0
 
belranjanAuthor Commented:
The vnc server is installed in redhat7.3.I also startted the vncserver from /etc/init.d vncserver start <enter>
but when i cheak the status it is showing it is stopped.To make it work properly what i have to do.
0
 
GnsCommented:
Reread my previous message!-)

There are two prerequisites for the init script to work:
1) You have to edit /etc/sysconfig/vncservers (as stated above), so that you will start a server for a user on the system ("glenn" in the above examples is my regular user on a linux-box of mine).

2) You have to set the vncpassword for that user. There are at least two ways of doing so, but the easiest is to log on as the user (su - <username>) and run "vncserver :1"... the first time through it will ask for the password, and provided it isn't too short, or misstyped the second time, it will be saved to a file in $HOME/.vnc directory of that user.

-- Glenn
0
 
CleanupPingCommented:
belranjan:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
 
GnsCommented:
I have covered all bases as far as I can see.

-- Glenn
0
 
Kyle SchroederEndpoint EngineerCommented:
belranjan:
It appears you have asked 17 questions and you have only resolved 1 of them.  Please update these questions or close them by clicking "Accept Comment" button on the comment which helped you.  The points you've used to ask your questions are escrowed anyway, so trying to keep asking more questions without finalizing any of them won't accomplish anything other than irritating Experts who might help you otherwise.

To see a list of your open questions, click here:
http://www.experts-exchange.com/Hardware/viewQuestionHistory.jsp?mid=971389

-dog*
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now