?
Solved

Linux - Windows Networking

Posted on 2003-02-27
13
Medium Priority
?
239 Views
Last Modified: 2013-12-05
I run a mixed network Linux (Xandros) and Win2k. Name resolution: DHCP together withe a rooter. I can get on all Win2K Computers with the Linux computer (Samba), except one. I tried hard, but I can´t see what is the difference between the computers I get access to and the one I do not. Any hint about that?

Peter

0
Comment
Question by:Dr_Thomas
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
  • 2
  • +3
13 Comments
 
LVL 8

Expert Comment

by:heskyttberg
ID: 8033535
Hi!

Just a comment DHCP has not anything to do with name resolution.

DHCP is for automatic IP configuration on clients.

Make sure you know a admin user and password to the failing computer and try this:

mkdir -p /mnt/test
mount -t smbfs -o username=administrator -o password=myPWD //w2k_comp_name/c$ /mnt/test

If that works you have no problem accessing the machine using samba.

It's just something to do with login credentials.

Regards
/Hans - Erik Skytttberg
0
 
LVL 19

Accepted Solution

by:
Gabriel Orozco earned 136 total points
ID: 8034407
Thomas:

did your failing computer sees the samba server, but cannot logon to a drive?
it's telling you something about IPC$ ?
maybe you need the singorseal.reg file which comes in your linux distro inside the samba docs directory. copy to the failing machine and run it. now you will be able to logon.

if it is a different problem, please post some more information so we can help better.
0
 

Author Comment

by:Dr_Thomas
ID: 8041987
Hi heskyttberg,

Thanks for the comment; but the reaction of the Linux machine is the well known one: timeout connecting to 192.168.120.254:139; operation already in progress; smb connection failed. This is the same answer I get when I try smbclient "Win2K-comutername". Obviously port 139 is already used. No connection possible to the Win2K computer 192.168.1.34 (address given by the rooter per DHCP).

regards
Thomas
 
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 

Author Comment

by:Dr_Thomas
ID: 8042013
Hi,

I am sorry, but I cannot find a "singorseal.reg" at all. I have installed the "Xandros" Linux system (Corel).
Can you check if the name is correct? Perhaps mistake by transmission?

tx
Thomas
 
0
 
LVL 8

Expert Comment

by:heskyttberg
ID: 8042140
Hi!

Yes well, thoose two IP won't be able to talk to each other.

If the linux machine has 192.168.120.254
Then the windows server you are trying to connect to must have an IP that is between 192.168.120.1 - 192.168.120.253.

Why not put two nics in Linux computer, hook one up to the cable/dsl router and teh other to the local LAN.

Enable NAT and setup any rules you want in with ipchains.

Set ip on linux computers other NIC to 192.168.120.1.
Run a DHCP server for the internal LAN on the linux server.

This will allows all computer to get onto the internet and also to talk to each other.

Hope this helps

Regards
/Hans - Erik Skyttberg
0
 

Expert Comment

by:ken_330
ID: 8051362
hi DR Thomas,
       perhaps , u can try to use static IPs on all PCs to see if it problems be solved .If not it could be the /etc/resolved not configure to see the nodes.
      If it work, then try back the DHCP and focus on the Master , slave browser setting which i had heard of for giving this problems.

      Me too a newbie..hope u dun mind.
0
 

Author Comment

by:Dr_Thomas
ID: 8051621
Hi,

in the meantime I´ve got to reduce the problem partially. In two of the win2k-comp. there are ISDN cards (IP: 192.168.120.254 !!!). What Samba does is that it locks to that instead of the normal nic (Lan 1),   but again only at the very computer. If I deactivate the card everything is ok. But if the card is active (Lan 3) the problem persists. The question is now: How to tell Samba that only Lan 1 is the correct connection?

regards
Thomas
 
0
 
LVL 8

Assisted Solution

by:heskyttberg
heskyttberg earned 132 total points
ID: 8051646
Hi!

Ok, now I understand your problem this is quite easily fixed, you should also look at following settings in /etc/samba/smb.conf or wherever your smb.conf is:
   hosts allow = x.y.z. 127.
   interfaces = x.y.z.a/24

Where x.y.z. represents the first three digits of IPs used on your internal LAN.

And x.y.z.a is the IP bounded to the NIC on linux box that is connected to the internal LAN.

Hosts allow is so that noone from outside the lan can see or connect to shares on the samba server.

Regards
/Hans - Erik Skyttberg
0
 

Expert Comment

by:ken_330
ID: 8065037
hi Dr Thomas,
          heskyttberg got the right tips , to tell samba to bind to which specified networkcard.Hope u got the problems solved.If not u can removed the hardware which is another easier choice to make.
:-)
0
 
LVL 2

Assisted Solution

by:mjdme
mjdme earned 132 total points
ID: 8580322
make sure smb.conf file is setup correctly
http://us4.samba.org/samba/ftp/docs/htmldocs/Samba-PDC-HOWTO.html

when connecting from your workstation u must use root and root password to auth.

edit your registry
http://www.wlug.org.nz/RequireSignOrSeal 

http://www.oreilly.com/catalog/samba/chapter/book/

also edit host and host allow file in samba and etc dir
0
 

Expert Comment

by:CleanupPing
ID: 9077763
Dr_Thomas:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0

Featured Post

Command Line Tips and Tricks

The command line is a powerful tool at the disposal of every Linux user. Although Linux distros come with beautiful user interfaces, it's worthwhile to learn the command line because it allows you to do a number of things that you otherwise cannot do from the GUI.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Creating a Samba server for a small office. Ubuntu Linux and Samba can breathe new life into a retired PC and save an office money on new hardware/software. Our example server will have two hard disks, one exclusively for storing shared data. …
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Suggested Courses

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question