?
Solved

my 3 button mouse doesn't work!

Posted on 2003-02-27
11
Medium Priority
?
571 Views
Last Modified: 2010-04-20
i can get the third button work...
the mouse!!

i can't scroll up and down...

anyone know how to config it?
0
Comment
Question by:evan_evan
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
11 Comments
 
LVL 2

Expert Comment

by:jimbb
ID: 8039202
I assume you are talking about X?  ("X Windows")

Most likely you need to edit your XF86Config (which should be in /etc/X11/).

Set the Protocol to "IMPS/2" and also add this line to the same mouse section:

        Option      "ZAxisMapping" "4 5"

Note: your OS may come with a tool that does all this for you!  Check the documentation, you may have "mouseconfig" or something similar.

If you still have problems, follow up to this post.
0
 
LVL 5

Expert Comment

by:jdfox
ID: 8042787
What make and model of mouse are you using?  
What version of XFree86 are you running?  
Which version of Linux are you running?

If you're using verion 4 of XFree86 (the X Windows that comes with Linux), then the config file is now /etc/X11/XF86Config-4.

If you're using the older version 3, then it's /etc/X11/XF86Config

Please post up a copy of your config file, whichever one it is, and we should be able to fix the problem.
0
 
LVL 2

Expert Comment

by:jimbb
ID: 8043262
Actually the filename can be either with or without the -4.  The only reason it would "need" to be -4 is if both X3 and X4 are (or were) installed on the same system.

From the XF86Config man page:

       XFree86  uses  a  configuration  file called XF86Config for its initial
       setup.  This configuration file is searched for in the following places
       when the server is started as a normal user:

           /etc/X11/<cmdline>
           /usr/X11R6/etc/X11/<cmdline>
           /etc/X11/$XF86CONFIG
           /usr/X11R6/etc/X11/$XF86CONFIG
           /etc/X11/XF86Config-4
           /etc/X11/XF86Config
           /etc/XF86Config
           /usr/X11R6/etc/X11/XF86Config.<hostname>
           /usr/X11R6/etc/X11/XF86Config-4
           /usr/X11R6/etc/X11/XF86Config
           /usr/X11R6/lib/X11/XF86Config.<hostname>
           /usr/X11R6/lib/X11/XF86Config-4
           /usr/X11R6/lib/X11/XF86Config
0
Learn how to optimize MySQL for your business need

With the increasing importance of apps & networks in both business & personal interconnections, perfor. has become one of the key metrics of successful communication. This ebook is a hands-on business-case-driven guide to understanding MySQL query parameter tuning & database perf

 
LVL 1

Expert Comment

by:allelopath
ID: 8043418
I had the same problem and just to add a data point:
I first made the changes to XF86Config and it did not solve the problem.  I then made the changes to XF86Config-4 and it did solve the problem.

RH 7.3
0
 
LVL 2

Expert Comment

by:jimbb
ID: 8043594
RTFM.  If you have both config files installed, it's going to find the -4 version first.  See above.
0
 

Author Comment

by:evan_evan
ID: 8045213
i am using redhat linux 8, then how to config it?
plz tell me step by step, i am noob :p
0
 
LVL 2

Accepted Solution

by:
jimbb earned 200 total points
ID: 8045307
Run redhat-config-mouse and select the appropriate Wheel Mouse option (USB vs. PS/2).  Do _not_ select "Emulate 3 button click."

Then, log out and back into your X session.

Does it work then?  If not, then you should edit /etc/X11/XF86Config and make the changes I described above.  Are you familiar with any particular text editor?

If you're using a PS/2 mouse, you want your InputDevice section to look like this:

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/psaux"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "no"
EndSection

Or, if it's USB:

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "no"
EndSection


If it still doesn't work after making those changes (remember, you have to log out of your X session and log back in again for it to take effect), then let us know.
0
 

Expert Comment

by:taherscherzay
ID: 8045812
Another quick method to add/reconfigure mouse support is to run built in utility within Linux kernel call "mouseconfig" located at /usr/sbin/mouseconfig. Just run it in a shell and add your mouse - either using the manufacturer or as a generic mouse. This applies to Redhat 7.3/8.0
0
 
LVL 2

Expert Comment

by:jimbb
ID: 8046088
mouseconfig is not in the kernel :) but yes, that should work too (make sure you're root first).
0
 

Author Comment

by:evan_evan
ID: 8054201
it works out

thank you all
0
 
LVL 1

Expert Comment

by:djluff
ID: 8064552
With the mice I have, as soon as I set it to IMPS/2 the wheel works, but the third button stops working. If I set it back to PS/2 I get the third button back, but the wheel goes away.

I havent been able to get the third button and the wheel both working at once.
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

rdate is a Linux command and the network time protocol for immediate date and time setup from another machine. The clocks are synchronized by entering rdate with the -s switch (command without switch just checks the time but does not set anything). …
How many times have you wanted to quickly do the same thing to a list but found yourself typing it again and again? I first figured out a small time saver with the up arrow to recall the last command but that can only get you so far if you have a bi…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Suggested Courses
Course of the Month14 days, 9 hours left to enroll

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question