?
Solved

Name resoultion problem

Posted on 2003-02-28
12
Medium Priority
?
242 Views
Last Modified: 2010-03-18
Hi,

Operating system: SuSE Linux 8.1
I own an 1&1 NetXXL ISDN box (only ID is different from AVM Fritz!X USB). Configured the box with no problem using yast. Dial-in is also ok with no problem. Also i can ping every machine using the IP address.
But the problem still is: it does NOT do any name resolution? I entered the DNS name servers as my provider gave me (tested with Windows, they are ok) using YAST. I also find the servers entries in /etc/resolv.conf.
ut still i have no working name resolution.
Please help!

regards,
R.Pichler
0
Comment
Question by:rpichler
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
  • 2
  • +3
12 Comments
 

Expert Comment

by:cerit
ID: 8041663
Have a look at /etc/nsswitch.conf
The entry for hosts should reference DNS if it doesnt this could be causing your problem.

Ceri
0
 

Expert Comment

by:cerit
ID: 8041875
check /etc/nsswitch.conf
the hosts line should mention DNS.  You might want to put DNS first if it isnt already
eg

hosts:      dns files nisplus

Ceri
0
 
LVL 9

Expert Comment

by:majorwoo
ID: 8047750
are you able to ping your ISP's DNS servers? (Im wondering if by pinging machines you meant your local computers..)

your /etc/nsswitch.conf files looks fine.  If you go to
http://216.239.51.100/   <-- google.com

it works fine?
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
LVL 51

Expert Comment

by:ahoffmann
ID: 8049301
do you run your own named on this system?
0
 
LVL 9

Expert Comment

by:majorwoo
ID: 8049388
your own named shouldnt matter as you see your ISP's DNS server in /etc/resolv.conf (although if you wanted to run your own you would have to add it in here or you would ignore it and ask your ISP for DNS anyway)
0
 

Author Comment

by:rpichler
ID: 8055368
Hi,
thanks for all your help.
After looking at some more log files, i found the problem:
1. uninstalled package bind8 (dont have my own name server).
2. i must do a 'route del default ippp0' before connecting to my provider. Then everything is okay.
However SuSE seems to write an entry into the route.conf file (IP 0.0.0.0). That cannot work...
But i still do not know why it writes this in and how i can make him NOT to write this in?

Regards,
Ralf
0
 
LVL 9

Expert Comment

by:majorwoo
ID: 8057898
I am not sure how to prevent it from happening, but you can set your machine to add it for you

/etc/ppp/ip-up.local

the file may not exist, but if you copy it from /etc/ppp/ip-up  every time you connect to your ISP it will execute that script -> add the route del default line in there and you should be good
0
 

Author Comment

by:rpichler
ID: 8062585
Thanks all for your help.
Yesterday i found the resolvement for this problem:
i commented out the route which entry i see after any connection.
It seems to come from /etc/sysconfig/network/routes (formerly known as rc.config).
Seems to be a default which yast enters...

Now done and it works great!
Again, thanks!

rpichler
0
 
LVL 9

Expert Comment

by:majorwoo
ID: 8064902
post a 0 ptr in community support and ask for a refund
0
 

Expert Comment

by:CleanupPing
ID: 9077753
rpichler:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
 
LVL 1

Accepted Solution

by:
GhostMod earned 0 total points
ID: 11071932
PAQed, with points refunded (500)

GhostMod
Community Support Moderator
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
How to fix incompatible JVM issue while installing Eclipse While installing Eclipse in windows, got one error like above and unable to proceed with the installation. This video describes how to successfully install Eclipse. How to solve incompa…
Suggested Courses

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question