?
Solved

Re-compile Red Hat 8.0

Posted on 2003-02-28
3
Medium Priority
?
208 Views
Last Modified: 2013-12-06
My Red Hat 8.0 has problem with the USB. I can't start the computer if there 's something pluged in the USB port (Webcam ...), the start process stop at "Initalizing USB controller", when I unplug all USB connections, Red Hat works properly. I 'd like to remove the USB component from my kernel so that I don't have to unplug the USB connections each time I want to work in Linux, but I don't know exactly how to do it. I've read the instructions about re-compiling the kernel, but they are all complicated. Could somebody give me some simple instructions? Thanks.
0
Comment
Question by:tanhnhi
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 2

Accepted Solution

by:
jimbb earned 300 total points
ID: 8046791
You could re-build the kernel as you've said.

But you also could choose not to load the driver module for your USB controller.

If there's any line for it in /etc/modules.conf, comment it out (with a '#').  And in order for it to not be detected at each boot, disable the 'kudzu' service (use the "Server Settings/Services" in the menu, or run 'ntsysv' from a shell).

Note that that will also disable detecting any other hardware changes to the machine.  If you just want to disable USB I believe putting "nousb" on the kernel command line (in grub.conf, if you need help with this let me know) will work, although I am not positive.
0
 
LVL 5

Expert Comment

by:jdfox
ID: 8046801
A quick fix is to comment out the USB line from /etc/rc.d/rc.sysinit.

What model of PC are you using, and what version of kernel?
uname -a will tell you this.

I've heard of this happening on some IBM & Toshiba laptops.
0
 
LVL 2

Expert Comment

by:jimbb
ID: 8046826
If you edit that file, you'll need to be concerned about what might happen should an update to the the "initscripts" package be installed.

But you do raise a good point; looking in that file you can see where it greps '/proc/cmdline' for "nousb"; /proc/cmdline contains the kernel command line options passed to it by the bootloader.  So adding that option to the kernel command line should be the easiest and cleanest solution (other than fixing the problem, if there is a fix).
0

Featured Post

How To Reduce Deployment Times With Pre-Baked AMIs

Even if we can't include all the files in the base image, we can sometimes include some of the larger files that we would otherwise have to download, and we can also sometimes remove the most time-consuming steps. This can help a lot with reducing deployment times.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
Fine Tune your automatic Updates for Ubuntu / Debian
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
Suggested Courses
Course of the Month8 days, 21 hours left to enroll

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question