Problem with SAMBA Authentication

I have a Linux 8.0 box running Samba that I am trying to access from a Windows 2000 Pro workstation.  If I set Samba security to Share, I am able to access the share without a problem.  If I set Samba security to User, I am prompted for a username and password.  I attempt to access the share using the root username and password but I am denied.  I've also tried using two other user accounts on the Linux box but I am also denied. All accounts that I have tried have read/write access to the shares.  Only the root account is listed in the smbuser file.  Do I need to add another account to the smbuser file and, if so, how is this done. Any help is greatly appreciated.

jl4k3Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

majorwooCommented:
did you add a samba account for the root user using? (And yes you should add another user, never use root unless you have to (to join a domain or something) )

smbpasswd -a username
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Cyclops3590Commented:
I believe you can also switch which password file samba uses for authentication to the system password file.  However, I have never tried to see if it works flawlessly for the reason majorwoo gave.  Then any account on the system (including root) can be used to get to a share, and that should never be.
0
ljeffries_linuxCommented:
***1st rule of thumb - windows username and password must match the username and password in the linux server...kinda.  

If you connect with just the workgroup option, the username must  exist on the linux server. <useradd>.  You should have made the smbpasswd file <cat /etc/passwd | /usr/bin/mksmbpasswd.sh > /etc/samba/smbpasswd> (not using the first < and last >).  This transfers all of you listed linux users to samba.  Then for each user <smbpasswd username>.  You should be promted with "New SMB password:"  Type in the same password that matches the winx machine and the basic linux user password. (this just simplifies the process).  Retype the password and your done.

I also use the "USER" security level but have not been able to get any win2k or xp machine to logon (like a windows domain).  I can easily join the workgroup.  Also I'm not sure but I think "SHARE" access doesn't even require you to be part of the called workgroup.  "USER" access does.

Under windows (2K/XP) right click on My Computer, then properties, then the Computer Name tab , then change.  The windows machine should already have a name, click on workgroup and match the name listed in your smb.conf. file for the workgroup entry.  You should be rewarded with "Welcome to the whatever workgroup.  The you should be promted to reboot.

Make sure the usual problems like your firewall are set correctly to allow the win machine to access through.  Same in the /etc/host (192.xxx.xxx.x  Hostname).  I assume that you already have the smb script running.  If not, post back.

This is a great sight:
http://www.ibiblio.org/mdw/HOWTO/HOWTO-INDEX/howtos.html
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

BabuPrasannaCommented:
If you want to access samba in user mode, u need to create an account in the SAMBA server! for that i believe the command is smbadduser or sambaadduser.. please check it in the bin directory of the samba server!You will be prompted to map the samba-user name to your root account by specifying like, <samba-username>:<linux user name> as the command line arguement. You also need to supply the password! Create and account and try again! it worked for me!

good luck!
0
jl4k3Author Commented:
Thank you.  I ran smbpasswd -a <username> and I am now able to access the shares with User security.  Thought you should know that I have two books on Linux, each in excess of 800 pages.  Both books contain info on setting up Samba and recommend using User security (the default).  However, neither book mentions running smbpasswd -a in order to create Samba accounts for your users...Unbelievable!  I've also set up a separate account and am not using root.
0
majorwooCommented:
yeah i found that one the hard way too ;-) About 2 years ago I decided to move our 20some machines that dualboot windows/redhat yo a samba PDC .. took almost a week of playing to get it working right ;-)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.