• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 289
  • Last Modified:

Hard drive recognition in Windows XP?

Hi all,

     I just upgraded to a P4 1.8 Windows XP system (well, I
had XP before but realized I needed to upgrade the Celeron
500 I had been using for almost five years... :) ).  I have
two hard drives, one master and one slave (Western Dig. and
Maxtor, respectively).  The previous system, under Windows XP, recognized both drives.  The CURRENT BIOS recognizes both drives, Windows Device Manager recognizes both drives (and with the fully updated drivers)--but in My Computer AND Disk Management, all I can see is the main hard drive (the Western Dig. one), drive C.  How do I see the other drive in My Computer and/or Disk Management, since everything else, even in Windows, CAN see it? Thanks for your help...I really need to backup some files to the other hard drive!

     Greg
0
PhoenixFury
Asked:
PhoenixFury
1 Solution
 
Paul SDesktop Support Manager / Network AdministratorCommented:
has the second drive been partitioned or formated? can you do either from dos?
0
 
PhoenixFuryAuthor Commented:
Hi again,

     The second drive was formatted when it was on the previous computer and using the same OS (Windows XP).  It is not partitioned.  What's odd to me is that the BIOS and Device Manager both recognize the second hard drive and claim it is working correctly--but Disk Management and My Computer do not see it.  Any ideas...?

0
 
ExceterCommented:
>> Windows Device Manager recognizes both drives

As I understand things Windows Device Manager recognizes the motherboard's IDE controllers not the drives themselves.

>> The second drive was formatted when it was on the previous computer and using the same OS (Windows XP).  It is not partitioned.

Was it visible on the other computer after it was formatted?

>> The CURRENT BIOS recognizes both drives

You mean that both drives are found when you run autodetect? If they are found by autodetect that should rule out most hardware problems. I.E. a backwards cable, a partially unplugged cable, incorrect jumper settings, etc.

Exceter
0
[Webinar] Kill tickets & tabs using PowerShell

Are you tired of cycling through the same browser tabs everyday to close the same repetitive tickets? In this webinar JumpCloud will show how you can leverage RESTful APIs to build your own PowerShell modules to kill tickets & tabs using the PowerShell command Invoke-RestMethod.

 
Kent OlsenData Warehouse Architect / DBACommented:

Maxtor uas a product called EZBios that they ship with most hard drives.  It allows old machines to use hard drives that are too big for the older BIOS.

You should probably have an EZBios diskette or CD that came with the hard drive.  Boot from it and remove EZBios from the hard drive.

Kdo
0
 
jmiller47Commented:
-You don't want to install EZBIOS unless you have to. It places many additional restrictions on you. There will be no need to install EZBIOS if Device Manager in Windows XP is seeing the drive. EZBIOS is used to allow the OS to see the drive's full capacity when the BIOS cannot.

"The second drive was formatted when it was on the previous computer and using the same OS (Windows XP).  It is not partitioned."
-A drive cannot be formatted if it is not partitioned. It may be one large partition, but it must be partitioned.

"As I understand things Windows Device Manager recognizes the motherboard's IDE controllers not the drives themselves."
-Windows XP does allow you to see the actual drives themselves in Device Manager. I believe that Windows 2000 did not though.

I suggest downloading and using Maxtor Powermax to diagnose the drive thoroughly. It has many utilities to us that will find out exactly what you want to know.

http://www.maxtor.com/en/support/downloads/powermax.htm
0
 
PhoenixFuryAuthor Commented:
Hi all,

     Thanks for the continued help!  Windows Device Manager IS recognizing the drive itself, not simply the IDE controllers.  The drive I currently can't see in Disk Management and in My Computer is a.  not the main drive, which reads fine in all areas and b. WAS visible in the old computer, which again was also running Windows XP.  Finally, BIOS is using autodetect  and is recognizing the second drive just fine.  So to recap:  Device Manager sees the drive fine, BIOS sees the drive fine; My Computer, Disk Management and Norton System Works do not.  Any ideas?

       
0
 
arcascompCommented:
As has already been commented, the BIOS and device manager are seeing your drive so it's not directly a hardware issue. Just to eliminate any oddities in the whole Slave/Master - Primary/Secondary setup have you tried disconnecting all IDE devices except the two HD's?

This will at least get you a chance to backup the files if it gets things running.

Do you still have the same Primary/Secondary, Master/Slave setup as the previous board? I've occasionally found odd IDE devices that don't really like being on the same wire with each other.

Is there are messages in the event logs from boot up time to suggest that there is a failure somewhere?

0
 
taiskCommented:
Can you tell me what file system was on this Maxtor drive?  NTFS, FAT32, etc.  If it was NTFS before upgrade, you may not be able to "see" it after a reinstallation of WinXP.  You can recover the data using the bootable WinXP CD.
0
 
PhoenixFuryAuthor Commented:
Heh--okay, I'm within about an hour of giving up and throwing the Maxtor out the window.  The update is as follows:

     I spent two hours on the phone with Microsoft support.  The tech said he had "never encountered anything like this before."  Registry checks confirm that the IDE controllers are working fine, and booting in safe mode accomplished nothing.  After basically not getting anything from tech support (not his fault, he just had no idea), I moved heaven and earth and figured how to remove the drive overlay that been used when the hard drives were still on the old system, EZ-Bios.  No effect.  I then spent an hour reconfiguring my system so that I could get my hard drives on separate IDE channels--I set it up so that my main, bootable drive (the Western Digital) was by itself on the first IDE controller, and my second drive (the Maxtor, the one I have been unable to see in Windows) was on the second controller as the master, with the CD drive attached to it as the slave.  Again, no effect.  So, to review this entire sordid affair:

Each hard drive is on a separate IDE channel, each acting as a master.  Previously, in my old system powered by Windows XP, both hard drives were recognized and were fine.  Now, in the new system still powered by Windows XP, Device Manager recognizes both hard drives as existing.  BIOS recognizes both hard drives as existing.  My Computer and Disk Management do not recognize the second hard drive (the Maxtor).  

     Please help!  Thanks for all your suggestions so far, but as of yet nothing has worked--and in another hour I'm just going to pull the Maxtor out and forget about it (last time I ever buy a piece of garbage like that in any case)

     
 
0
 
trojaCommented:
Just in case: In Disk Management try to re-read all hard drives (context menu of diskmanagement). Any Changes? Probably not..

Have you tried to access your Harddrive using a Disk Tool like Partition Magic etc.? You should do it by using the "emergency diskettes" (or boot disks), so you're not operating from within the windows environment. It would be interesting if this prog would see all drives and partitions. Make a check of them.

Then, if it happens to work, reformat the drive.

But I have to admit that I have the feeling there might be an error with the disk. If not, you should get your disk to work by doing what I suggested.

If it doesn't help, pull out the disk. :-)

Hope I could help a little,
Viktor
0
 
PhoenixFuryAuthor Commented:
Tried checking Disk Management--still no luck.  I am able to access the hardware while outside of Windows (at least based on using a program like Maxblast or Data Lifeguard).  I finally decided to reformat.  Still can't see it in My Computer or Disk Management.

     Any takers...?  :)


 
0
 
PhoenixFuryAuthor Commented:
Well, I offically gave up.  I will just have to get another hard drive at some point so as to back up critical data (will just have to use CD/RWs in the meantime.  Thanks everyone so much for your help--great to know that there are people willing to help!  I am awarding the points to JMiller, since his/her suggestions came closest to the mark (at least I was able to get rid of EZ-Bios and confirm my MAIN drive was okay!)  The moral of the story:  DON'T GET MAXTORS.  EVER.  :)

     Thanks again to everyone!
0
 
Paul SDesktop Support Manager / Network AdministratorCommented:
when you switched from old pc to new did you intall xp on the same drive or another?
you may have had a conflict between two partitions being set to primary and active
at the same time
0

Featured Post

Take Control of Web Hosting For Your Clients

As a web developer or IT admin, successfully managing multiple client accounts can be challenging. In this webinar we will look at the tools provided by Media Temple and Plesk to make managing your clients’ hosting easier.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now