?
Solved

Windows will not start with slave present

Posted on 2003-03-01
12
Medium Priority
?
695 Views
Last Modified: 2010-04-03
Problem:-
Friend of mine has built a new computer for himself.
Elite K7S6A Motherboard
AMD XP2100+ Chip
80gb IBM Deskstar
512mb pc2100 ram
CD Writer
DVD Rom
etc...
He wanted to copy some files from my drive,but when we connected my drive to his computer it would not boot past the the screen where the green line runs along the screen.
We tried all different combinations of jumper settings and IDE's none of which make any difference.
He has a 6.4gb drive out of his old computer and that is recognised ok.
When started in safe mode my drive (seagate) seemed to be seen as a cd drive!!
Have looked at bootlog and the first driver it does not load is "ACPI UNIPROCESSOR PC"
But the one that seems to be causing most problems is afd.sys (says did not load over and over again)
Any ideas please??
0
Comment
Question by:truckermilo
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
12 Comments
 
LVL 5

Expert Comment

by:msa2003
ID: 8047908
Just try to unplug CD Writer and DVD Rom and plug your HDD to the separate channel.

If the OS your friend has is Win 98/Me, the reason may be the following. When your friend's system is installed to non-primary partition (logical drive) and it is Win 98/Me it wouldn't start because your disk will become drive D: and other drive letters will be shifted.
0
 
LVL 2

Expert Comment

by:jehob
ID: 8048354
msa2003 is right...your drive should be set as the secondary master rather than the primary slave.  Verify that your jumpers are correct on both drives and then boot into the BIOS and use the autodetect feature (if his BIOS has this feature) to detect the drive configuration.  If the BIOS doesn't detect both drives then you'll need to check your jumpers.  
0
 
LVL 45

Expert Comment

by:patrickab
ID: 8049272
The chances are that your drive was seen as a CDROM drive most probably because you removed a CDROM drive and put your hdd in its place. If that is what you did then you only need to ensure two things to make the hdd work (with one condition which I'll tackle in a moment). First your hdd should be jumpered the same as the CDROM that was removed. In the bios the information for where the CDROM was should be changed to 'hdd' and 'autodetect'. After that save the bios settings and allow the machine to boot normally. You will only be able to access your old hdd if the file system you have on your hdd is 'readable' by the OS/file system on the host machine.

===============
As a broad guide the following is a summary of possibilities (Apologies if you know all of this and have done it already):

If you have added the new hdd to the middle of the same ribbon cable (RC) as the older hdd then the drive should be jumpered as 'slave' and the Primary Slave in the bios set to hdd and autodetect.

If you have attached the new hdd to the end of the other RC then jumper it as 'master' and the Secondary Master in the bios should be set to hdd and autodetect.

If you have attached the new hdd to the middle of the other RC then the drive (if there is another drive attached to the end of the RC) should be jumpered to 'slave and the Secondary Slave in the bios set to hdd and autodetect.

You can access the bios during bootup by pressing DEL (or F8 or F10) or whatever is correct for your machine. There appears to be no industry standard for which button to press to access the bios during bootup.

The jumpers are a set of small pins at the back of the drives. Two of the pins are connected with a small block. Which two pins are connected determines how the drive is seen by the bios. You may well need a pair of tweezers to get hold of the small block. The drive casings are marked with 'master', 'slave' and 'cs'.
===================

Do please let us know how you get on.
0
Why Off-Site Backups Are The Only Way To Go

You are probably backing up your data—but how and where? Ransomware is on the rise and there are variants that specifically target backups. Read on to discover why off-site is the way to go.

 

Author Comment

by:truckermilo
ID: 8049769
OK Thanks for posts so far:)
To clarify, we have His hdd as primary master.We have removed cd writer and dvd and tried my hdd in every other plug on both ribbon cables(except pri master)and tried all jumper settings i.e. master, slave and cable select in appropriate place.His OS is XP Pro and both drives are NTFS, although his old 6.4 gb hdd is FAT 32 and the system boots ok with that in place:(
The bios does not have auto detect.
But when the computer starts the boot process the hdd is recognised.
I look forward to any follow ups!!
0
 

Expert Comment

by:HiTmAN
ID: 8051440
Are you sure you have the IDE cables plugged in right? There is also a possiblity that the motherboard is slightly faulty (i have had similar problems with the K7S5A). The BIOS is another place to go, make sure the drive boot order is correct. And, as said above, mke sure the jumpers are correctly placed (consult manuals for configurative positions). Good luck!
0
 

Author Comment

by:truckermilo
ID: 8052171
Jumpers are set correctly.IDE cables are plugged in ok.Boot order is IDE 0,Cdrom, Floppy.I don't think there is anything wrong with motherboard because as said before 6.4gb hdd (FAT32) works ok:)This is an extract from the bootlog where it all seems to go wrong:(
Loaded driver Ntfs.sys
Loaded driver NDIS.sys
Loaded driver sisagp.sys
Loaded driver Mup.sys
Did not load driver ACPI Uniprocessor PC
Did not load driver Audio Codecs
Did not load driver Legacy Audio Drivers
Did not load driver Media Control Devices
Did not load driver Legacy Video Capture Devices
Did not load driver Video Codecs
Did not load driver WAN Miniport (L2TP)
Did not load driver WAN Miniport (IP)
Did not load driver WAN Miniport (PPPOE)
Did not load driver WAN Miniport (PPTP)
0
 
LVL 5

Expert Comment

by:msa2003
ID: 8052311
Check if you plugged new drive using 80-wire ATA66/100 cable. If the cable was old, 40-wire it could lead the following: CD and DVD uses PIO4 and UDMA/33 modes. Your friend's HDD is old enough and also to use UDMA/33 mode. Your drive is UDMA/66/100/133 compliant so even if it is working in UDMA/33 mode it uses less timeouts for some configuration steps so that it leads to signal interference and data loss. This also could lead IDE controller to hardware fault, but after that it had to recognize drives.
0
 

Author Comment

by:truckermilo
ID: 8053225
OK msa2003 i understand what you are saying. But should i connect drive with 80 strand cable or 40 strand cable?? Because this being all new system i presume you are saying connect with 80 strand.I will hopefully try it tomorrow night (monday) if my friend is not away working abroad. Please be patient for feedback as he has to go away sometimes for a week at a time.I appreciate all of your assistance in this matter:)I also just built a system last week with identical hardware except it was a seagate hdd, and when i tried same slave on that system there were no problems!
Thank you all again.
0
 
LVL 1

Expert Comment

by:migit03
ID: 8098250
Perhaps you should update your BIOS if nothing else seems to be working. OPther wise the problem must be a faulty device perhaps do to ESD. Especially if your friend has the same equpiment and is fine. MSA2003 might be on to somthing though try it out.
0
 

Author Comment

by:truckermilo
ID: 8132506
I am not sure what to do now, the problem is half fixed!But, none of the answers on here really fixed it.I again connected drive as pri slave,computer started this time but did not recognise drive in windows. I had to go into disk management and import it. Once i had done this everything was ok.However after importing drive i thought it may now work on the slave channel, but no:( when on slave channel the computer once again hangs when it gets to the XP Pro splash screen.Consequently i now do not know what to do about awarding points, or not!! Any thoughts and guidance on this matter would be appreciated.
Also thank you to everyone that responded:)
Regards.
Phil.
0
 
LVL 32

Expert Comment

by:LucF
ID: 10122177
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:

PAQ/refund

Please leave any comments here within the next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

LucF
EE Cleanup Volunteer
0
 

Accepted Solution

by:
SpazMODic earned 0 total points
ID: 10178799
PAQed, with points refunded (75)

SpazMODic
EE Moderator
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is an update and follow-up of my previous article:   Storage 101: common concepts in the IT enterprise storage This time, I expand on more frequently used storage concepts.
Concerto Cloud Services, a provider of fully managed private, public and hybrid cloud solutions, announced today it was named to the 20 Coolest Cloud Infrastructure Vendors Of The 2017 Cloud  (http://www.concertocloud.com/about/in-the-news/2017/02/0…
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…

801 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question