Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium


Problems installing samba

Posted on 2003-03-01
Medium Priority
Last Modified: 2010-03-17
I am using the following guide to try and install samba on my linux machine:


All the files install fine but when I try and run this command:

# sh makerpms.sh

I get messages saying no such files or directories. I have no clue what to do when i get this error. I really need help with this I'm new to linux and samba so if I should be using a different guide let me know, thanks.
Question by:gabulish
  • 6
  • 4
  • 2
  • +1
LVL 22

Expert Comment

ID: 8051206
OK - 2 things:

a.  Try:

/bin/sh makerpms.sh

If that doesn't work - try:

b. Get a ready made rpm for you distribution. At a guess, there will be one on your install discs. Then start at the rpm -ivh ....... line in the document.

Hope that helps:)


Expert Comment

ID: 8051295
hi there,
      i have no problems with the Samba ..even those as early as REDHAT 5.2 package come with. U can go www.redhat.com to download RPM packages...which i always like to do ..the easier way then tar.
     As for verison 1.9..xxx its easier ....while the version 2.06 ...u dont have smb.conf file until u edited from the samba Webmin called SWAT.

     you had to use netscape browser to key in the IP address of your PC like : http:// IPs :901   meaning port 901 to get into SWAT. U need the root n root passwd to go into SWAT.

     tell u honestly , u need to prepare to sacrific hours to get familir with LINUX n SAMBa .....Orielly books i recommends. As a newbie ,try the RPMS comes with the books...if not ....REDHAT ..version comes with ready packages ..just select it to get it installed.
     At the LINUX command shell key in : setup
 u would be promptwith a choice...select which service to be start up with...remember to tick smb....which stands for samba...
    Problems..refer to the books ..to work with....soon u would find ...it easier....
     Hope its helps !...



Expert Comment

ID: 8051313
oh! ...i fogot a little.
      U need to go to root , then linux X gui (which is easier ) select linux conf...then go to service tab...select SWAT indicated by : [] u need to tick it with a mouse click : [X] indicated selected ..then exit linux config n back to the command shell n type :
samba status ....to see if samba running?
samba retart .....
 u would sees .....
smb shutdown.....
nmb shutdown....
smb restart...
nmb restart..
then u check samba status......u would sees ...
smb running with pid .xxx
nmb running with pid .xxx
Congratulation your samba is running.
next go to X gui.......doubleclick Netscape Explorer..key in  the http:// ips...:901   hit enter
your would be prompt with a passwd logon , if not ..your swat is not started yet even though u had enable your swat in linuxconfig.. Strange, sometimes this happens...which i also dun know why....usually i reboot it ..n its works.

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.


Author Comment

ID: 8051969
Ken_330 I dont have a service tab for swat what should I do?

Expert Comment

ID: 8058797
hallo gabulish,
First you must login as ROOT ,the start click gnome on the bottom left panel , pull up to System ,move right down to LinuxConf and click.
     Now u in GNOME -Linuxconf panel  
 go down to +Basic serives , expand it n u see Servers,click it and u would be shown a list with []nestat
use your mouse to click at the swat [X] box with a X to enable it.
then click Quit tab on the left hand linuxconf and u would be prompt for a Act/changes , click it to activate changes and then Quit tab at below it.

U need to check if the daemond is running by reentering into GNOME -Linuxconf and go down to Control service activity by click it , u would be shown with a list of daemons Running or Automatic or Manual

Enjoy !

Author Comment

ID: 8061875
Hi ken_330,
    I am running redhat 7.2. After I go into the system panel under gnome there is not a LinuxConf tab. Are you reffering to the Service Configuration, if so I do not have any options you have specified. Is LinuxConf the exact name of the panel choice? Any suggestions?

Expert Comment

ID: 8064927
hi gabulish,
          In redhat 7.2 , yeap u are on the right track , go to gnome(startbutton)>Program > System > Service Configuration with a click , u would be prompt with a window tab list of all service which is running or not running,select it by clicking it (it would toggle on or off )pay attention to the tick box ticked meants selected,now play with the other option button to restart all services.
          The previous one i mentioned is for redhat 6.2 and below.
        You can called up linuxconf by typing in a command shell : linuxconf           Hit ENTER , a cool linuxconf window would appears ! browse n play with it !

Author Comment

ID: 8064989
Right I was in the service configuration last night. There were a bunch of options that you could place a tick by. The only problem I didnt see any of the options that you mentioned. What do you think?

Expert Comment

ID: 8065139
   If u scroll thru all the service to see n cannot find the smb , that meants your smb is not installed.
   go get the RPM packager to add samba

Author Comment

ID: 8065299
I think I already have done that. Is there a specific directory you have to install it in? When I try install it via RPM it says I am missing these weird files. They have an ending of .so or something. I have searched for them but i can't find them on the redhat site. I also have tried to use the command:

rpm --redhatprovides filename

to find out what package this file resides in  but also get an error saying I am missing a file? I'm clueless.

Expert Comment

ID: 8072208
hi  ,
    I think u may need to reinstall your redhat7.2 once again but selecting a Custom mode and browse thru the choice of packages u which U need not have to worry about any dependencies problems , if u happens to encounter one,
u would be automatically prompt with.
    If you are trying the previous step via rpm , the .so is in the libary directory if i m not wrong.
    Put your CDRom 1st disk inside the cdrom and mount it
,go to the directory mount/cdrom > Redhat/RPMS ;then browse thru the RPMS directory , u would be able to find things u need.U need to scroll thru patiencely , otherwise like what i had said Reinstall everything over again by selecting custom choice , tick the wanted choice package.

good luck this time !

Expert Comment

ID: 8580309
get mandrake 9.1.  Its much easier, and better help

or get www.webmin.com

Accepted Solution

mjdme earned 900 total points
ID: 8580318

To install:
   rpm -ivh pkgname
To uninstall:
   rpm -e pkgname
To update:
   rpm -Uvh pkgname
To freshen (similar to update, but only installs if previous version exists):
   rpm -Fvh pkgname
Package Already Installed
If the package of the same version is already installed, you will see:
# rpm -ivh foo-1.0-1.i386.rpm
foo                     package foo-1.0-1 is already installed
If you want to install the package anyway and the same version you are trying to install is already installed, you can use the --replacepkgs option, which tells RPM to ignore the error:
# rpm -ivh --replacepkgs foo-1.0-1.i386.rpm
foo                       ####################################
This option is helpful if files installed from the RPM were deleted or if you want the original configuration files from the RPM to be installed.
Conflicting Files
If you attempt to install a package that contains a file which has already been installed by another package or an earlier version of the same package, you'll see:
# rpm -ivh foo-1.0-1.i386.rpm
foo           /usr/bin/foo conflicts with file from bar-1.0-1
To make RPM ignore this error, use the --replacefiles option:
# rpm -ivh --replacefiles foo-1.0-1.i386.rpm
foo                       ####################################
Unresolved Dependency
RPM packages can "depend" on other packages, which means that they require other packages to be installed in order to run properly. If you try to install a package which has an unresolved dependency, you'll see:
# rpm -ivh foo-1.0-1.i386.rpm
failed dependencies:
        bar is needed by foo-1.0-1
To handle this error you should install the requested packages. If you want to force the installation anyway (a bad idea since the package probably will not run correctly), use the --nodeps option.
Uninstalling a package is just as simple as installing one. Type the following command at a shell prompt:
# rpm -e foo

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Loops Section Overview
Suggested Courses

564 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question