• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 198
  • Last Modified:

Internet connection sharing

I have a XP-computer which has two LAN adapters and one of them is connected to the internet. The other adapter is connected to a hub that has also another computer (Windows 2000) connected to it. I'd like to enable internet connection sharing on the XP-machine, so that the second machine could connect to the internet through it. I had the whole setup working already, but then I had some other problems and had to remove network adapters and the system went totally nuts. Now I try to set up the internet connection sharing again, but when I enable it on the adapter that is connected to internet, XP-machine can't connect to internet anymore through it... and neither can the Win2000 machine, of course.

What I did was this: I checked the "enable users to connect to internet through this machine" on the advanced tab of the properties window of the network connection for the adapter (what a sentence!) and XP set up the properties for the other connection automatically (IP: 192.168.0.1 and so on...) then I manually changed on the Win2000 machine the properties of the network connection to: IP: 192.168.0.254, gateway and dns: 192.168.0.1. This is right, right?

So what more can I do except install Windows XP again???

-Marko-
0
mmikkone
Asked:
mmikkone
  • 2
1 Solution
 
stevenlewisCommented:
What I did was this: I checked the "enable users to connect to internet through this machine
make sure you have chosen the correct adapter
http://www.annoyances.org/exec/show/ics_xp
from a prompt on the host type
ipconfig /all |more
make note of the ip assigned by your isp
then on the client
from a dos prompt
type
ping 127.0.0.1
ping 192.168.0.x Where x is the ip of the client)
ping 192.168.0.1
ping the isp assigned ip of the host
ping 206.169.61.185
ping www.experts-exchange.com
please post the results here
to get to the prompt on XP go to start -->run and type cmd




in device manager, go to view, show hidden devices
then see if you have multiple adapters listed, and if so remove them reoboot and reinstall the adapters
0
 
mmikkoneAuthor Commented:
Ok, thank you. This is where I went wrong. I had selected the wrong adapter (I remembered wrong - had to open the machine to check which adapter it was that was connecting to the internet. Just changing cables jammed the computer :D). The "enable users to connect to internet through this machine" -checkbox wasn't even visible on the connection it should have been, so this also distracted me. I used instead the network setup wizard - which I had to use twice before it worked.

-Marko-
0
 
stevenlewisCommented:
Glad you're up and running
Steve
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now