?
Solved

Cant see SCSI Hdd in XP Pro

Posted on 2003-03-02
10
Medium Priority
?
426 Views
Last Modified: 2011-09-20
I have recently aquired a Adaptec AHA-2940U2W SCSI PCI Host card and 2 Seagate ST39103LC harddrives. I installed the SCSI Host card and fired up XP. Sure enough, XP detected and installed the drivers needed. No trouble there.

I proceeded to power down the system and installed the 2 harddrives. I used a 2 port 50pin cable connecting to 2 SCA-to-50pin converters (one for each drive). I've earlier set the harddisk ID jumpers to 0 and 1 respectively.

SCSI Bios detected the 2 harddrives fine but XP doesnt show any additional storage areas. Checking the device manager, I found two entries under "Disk Drives" named "S".  Device is stated to be "working properly".

Question is, what gives? I've tested the drives before this on a system with native SCSI support (same exact setup as above) and they worked like a charm.

Any form of help is much appreciated.
0
Comment
Question by:doggammit
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
10 Comments
 
LVL 41

Expert Comment

by:stevenlewis
ID: 8052051
go to control panel, admin tools, computer management, disk manager, and partition and format the drives
0
 

Author Comment

by:doggammit
ID: 8052263
stevenlewis

thanks for the tip. I've tried that but it isnt listed there. The drives are already formatted (NTFS) on another system.
0
 
LVL 1

Expert Comment

by:zzconsumer
ID: 8052786
If you boot using a DOS Bootdisk, does fdisk find the drives?
As far as I know, the host adapter has a 50-pin connector itself. You should try to find out if the system still behaves that strange with that configuration.
0
Ransomware: The New Cyber Threat & How to Stop It

This infographic explains ransomware, type of malware that blocks access to your files or your systems and holds them hostage until a ransom is paid. It also examines the different types of ransomware and explains what you can do to thwart this sinister online threat.  

 

Author Comment

by:doggammit
ID: 8054867
zzconsumer

thanks for your comment.
I've not tried the fdisk (I should though) but I thought the following is similar.

I tried installing XP direct to the SCSI drives. I disconnected all IDE devices and autoboot-ed from a SCSI DVD ROM drive. It shows that there are two storage devices but states that it "not read/write able" (something to that effect, I dont remember the exact message). Also, it states that the drives are 0MB in size.

I've tried adjusting the SCSI Bios to no workable outcome.

Oh yes, the drives are connected to the 50pin connector on the card.
0
 

Author Comment

by:doggammit
ID: 8054912
Update

After much frustration, I tried removing the harddrives from the SCA connector in realtime (i.e after XP boots up). Interesting point is that when I reinserted them in realtime, XP detects it and everything seems to be working!

I've a set of new queries relating to this.

1) I don't understand whats wrong....any one with any experience on this care to enlighten ?

2) If I boot-up without the harddisk in place (just the convertors connected to the 50pin ribbon cable) will there be issues with termination?

3) Is there a way that I can make the drives as fixed disks (and not removable disks)? I've set the SCSI IDs to the drives to be Non-removalbe in the SCSI Bios, still no go.

0
 
LVL 6

Expert Comment

by:CowboyJeeper
ID: 8057549
Is the cable you have self terminating?  Are either of the drives set to terminate the SCSI bus?  I have seen many detection problems due to improper termination of a cable/bus.

Any other devices besides the two HDDs and the card on that bus?  IE a SCSI CDrom?  Whats its ID?  Is the last device on the bus the one that its terminated?

I have also seen problems when ID 1 is put on a cable before ID 0, and 0 is the terminator.  Not sure if this is a requirement but my habits have always been to put the lowest IDs closest to the card and terminate the highest ID if the cable itself does not have a built on terminator.  (Dont double terminate by the way, cable and device thats caused problems for people in the past as well.)
0
 
LVL 1

Accepted Solution

by:
zzconsumer earned 400 total points
ID: 8058316
Have you tried using another SCSI cable? In addition, mind the specified maximum length. Too long cable may cause problems especially with faster and/or more devices.

Did you try switching off wide negotiation for ID 0 and 1 and lower the maximum transfer rate in the SCSI controller's BIOS?

In addition to CowboyJeeper's comment, I would suggest turning off any device termination and using an active terminator right at the end of the cable, if the cable is not self-terminated.

Concerning the fact that hot-plugging your drives works, I think of the Windows driver have a better initiallization routine than the controller's BIOS.

As you boot from IDE anyway, maybe you can simply turn off the SCSI BIOS and see what happens.
0
 

Author Comment

by:doggammit
ID: 8073633
Dear zzconsumer and CowboyJeeper

Appreciate your comments.

I have tried a few of your recommendations.

Following the mentioned tips, the setup now is as such :  1 Seagate Harddrive (ID 0) and 1 SCSI DVDROM drive (ID 1) connected to the SCSI bus. The DVDROM has termination turned on.

I kept the settings to as per before and tested it. Same observation, no hdd detected, DVDROM works.

I've tried zz's recommendation of turning off the SCSI bios. It worked to some extent but after a few restarts, the same problem arises. Again, no problems with DVD drive.

As the ribbon cable is only 2 port, is an external active terminator still be needed? I dont see where it could be connected with two devices already on the cable. Yes, very amaturish question but just wanted to be sure. :)

0
 
LVL 1

Expert Comment

by:zzconsumer
ID: 8073945
An active terminator is always a good, maybe the most sufficient way of terminating a SCSI bus. As an additional "device", the terminator of course needs its own port. The termination, independently from the way you terminate the bus, MUST be the last device on both ends of the bus (one end in most cases is the controller itself). So you need a cable with at least one more port.

By the way, what are your termination settings in the controller's BIOS?
0
 
LVL 32

Expert Comment

by:LucF
ID: 10122353
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:

PAQ/No Refund

Please leave any comments here within the next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

LucF
EE Cleanup Volunteer
0

Featured Post

Does Your Cloud Backup Use Blockchain Technology?

Blockchain technology has already revolutionized finance thanks to Bitcoin. Now it's disrupting other areas, including the realm of data protection. Learn how blockchain is now being used to authenticate backup files and keep them safe from hackers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is an update and follow-up of my previous article:   Storage 101: common concepts in the IT enterprise storage This time, I expand on more frequently used storage concepts.
Each year, investment in cloud platforms grows more than 20% (https://www.immun.io/hubfs/Immunio_2016/Content/Marketing/Cloud-Security-Report-2016.pdf?submissionGuid=a8d80a00-6fee-4b85-81db-a4e28f681762) as an increasing number of companies begin to…
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question