• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 265
  • Last Modified:

problems after successful telnet

there are few things i cannot do after successful connectivity between two computers through telnet.
1- i cannot enter by using root login and password.
2- there are few commands like "init" and "shutdown" i cannot use.
tell me can i do these things and what are the reasons i cannot do these things.
 
0
sumsam
Asked:
sumsam
1 Solution
 
sumsamAuthor Commented:
its a nice effort to make easy for people to gain knowledge
0
 
gbaughmaCommented:
Correct.  Linux, by default, won't let you log on as root if you telnet in.  There's a couple of ways to fix this.

1) Log on as yourself, then do a su    (superuser) then the root password.  You will essentially switch to root at that point.

2) Add your terminal (like pts/0) to /etc/securetty

THIS IS NOT RECOMMENDED, because you're saying that any incoming telnet connection is a secure one that root can log in with.  I use su instead.

Once you are root, init and shutdown will work.

--Greg
0
 
jimbbCommented:
Depending on which Linux OS you use, you may still appear to be unable to run 'init' and 'shutdown' even after you 'su'.  The reason for this (if it happens) is that those commands will not be in your $PATH variable.

Instead of 'su', use 'su -' if you run into that problem.

Furthermore, it is highly recommended to bury telnet and use SSH instead; telnet sends username/password info over the wire in plain text.  SSH encrypts these.
0
 
ken_330Commented:
hi sumsam,
       gbaughma is right,just follow his step,i have tried that , it the same that u need to logg in as a user first, then su - root with root passwd
       by then u be in the Superuser mode , u can do anything from that
       Furtherthat,first u need to be in the server to set the Linuxconf to enable remote access if u want to shutdown from any window client or unix client.Being called as a Server,after setting for remote access is configured , u dun have to install monitor or keyboard , all u have to do is enable the webmin port 98 in the redhat verison (for other flavours . u needto checkout).
      Enjoy ! ..if u still face problem .referto manual from th LIBRARY...its free .      
0
 
CleanupPingCommented:
sumsam:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0

Featured Post

Become an Android App Developer

Ready to kick start your career in 2018? Learn how to build an Android app in January’s Course of the Month and open the door to new opportunities.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now