Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 216
  • Last Modified:

Internet Sharing only works partially

Background:
Have 1 tower running XP, 256 megs ram etc.
     1 laptop running 98SE, 256 megs ram, etc.

Initially the two were networked peer-to-peer and shared a dialup Internet account.  Everything worked FINE with the Internet sharing (except slowly).

So -

DSL became available.

Got DSL, got a hub, and networked the two together.  Now everything is not fine.
On the desktop with XP everything is as should be.  The problem is with the laptop or how the host computer interfaces with it.  I can access the host computer and all of its files.  However, when accessing the Internet I can only access some web sites.  For instance I cannot get to www.weather.com or www.military.com and many others.  I can get to most of the sites that I want to but not all.  If I access the web directly through the hub and not through internet sharing everything works as it should.  I have the firewall on the XP unit turned off.  This is driving me crazy.  Any help is appreciated.
Shelley
0
ShelCarp
Asked:
ShelCarp
  • 2
1 Solution
 
stevenlewisCommented:
chances are the MTU settings on the client
http://www.annoyances.org/exec/show/article04-107
change MTU on client
use drtcp to change the MTU settings
drtcp (free)
http://www.dslreports.com/front/drtcp.html
0
 
vxlilCommented:
hi Shel,
As per your discriptio.... you are going round about the way my friend. Just follow some simple steps..
1. Remove all the Internet sharing options / disable them on your XP tower
2. Reconfigure your both Lan Cards of XP and Win98Se for tower and Laptop enter following address
     
     *settings for XP tower*

machine name-- any thing your like
ipaddress------192.168.0.1
subnetmask-----255.255.255.0
default gatway-***.***.***.*** (as I am not having any clerity from your probleam as your are using permanent ip address or temperary ipaddress DSL connection... if you are using permanent one then put that ip address in "Default Gatway" otherwise keep it empty along with ipaddresses)
Primary DNS address----***.***.***.***(you have to enter ip-address of DNS of your ISP,i.e., Internet Service Provider.)
Secondary DNS--***.***.***.***(if you have secondary DNS ip address from your ISP then plz put it here)

Now try to browse internet on this tower... if you are sucessfull then proceed for settings of Lap.
If you are not able to access it then please check out the connection option of Internet Explorer/or prepherence of Netscape Navigator and put address (ip-address) of your Default gatway.

Now download Winproxy utility from Download.com and install it on XP tower. Configure internal ip-address i.e., 192.168.0.1 as sharing address and keep all the settings default.
( while installing Winproxy you have to specify wether you are using Dial-up connection or dedicated one...... as i already mentioned that there are two types of connections of DSL.... if you have dial-up then you are having temperary ip-address.... and if you have dedicated one then you most probably having permanent ip-address)


     *settings for win98se Lap*

machine name-- any thing your like
ipaddress------192.168.0.2
subnetmask-----255.255.255.0
default gatway-192.168.0.1
Primary DNS----***.***.***.***(same as above)
Secondary DNS--***.***.***.***(same as above)
Now go to the Connection option of of your IE/prephrences of your NN and enter the ip address of your XP tower as proxy and enter the port 80.
Then take 10 long breths and check out the net connection here itself...
best luck
bye
vxlil
0
 
ShelCarpAuthor Commented:
You are a genius!  Thanks so much.  Drtcp is great.  After months and months of messing with this and asing other "experts" you managed to fix my problem in 5 minutes.  I worship the ground you walk on!
Thank you.
0
 
stevenlewisCommented:
ShelCarp Glad I could help. I have seen this issue a few times, and in fact had it myself (I discovered the fix two days after I bought a router to fix it LOL)
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now