Apache 2.0.40 appears to be caching requests

I have a Perl/CGI script where users enter a few details such as hostname, username etc and it FTP's files to the specified server.

This was running fine with Apache 1.3.x

What happens now is when the form is submitted, there is about 10 lines of output and then nothing else.  The script still runs in the background as I can see the activity with tcpdump.  The script essentially outputs data everytime a file is uploaded.

I use the Net::FTP module and have debugging turned on.  Looking in the web server logs, there are no entries while it FTP's the files and when it finishes, the webserver log is filled with all the debug output.  This all leads me to believe that Apache is caching the output, however I can not see any obvious configuration option to change this.

The Perl script has Perl's buffering turned off with $|=1;


Suggestions please.
LVL 48
TintinAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TintinAuthor Commented:
Will also add that I have no caching or proxy options enabled.
0
TintinAuthor Commented:
Another thing.  If I run the script from the command line, the output is continuous, ie: no buffering or caching.
0
TintinAuthor Commented:
I know I'm doing a lot of replies to myself, but I've managed to get the script to output correctly if I turn off debugging in Net::FTP

However, I'd still like to know why????
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

TintinAuthor Commented:
I've read through the PAQ's you listed, but they all relating to caching and not the problem I had.

I probably should have used the term buffering rather than caching, as that is a more acurate description of the problem I was having.
0
samriCommented:
Tintin,

Yes I do agree with you on the buffering problem.  Somehow, it might be happening to how apache might be caching the output (in memory maybe).  I do not have much technical knowledge to explain, but some people said that adding a custome header to the request may solve the problem.

<IfModule mod_headers.c>
Header set Pragma: no-cache
Header set Cache-control: "max-age=0, must-revalidate"
Header set Expires: "Sat 02 Apr 1977 17:15:00 GMT"
</IfModule>

Perhaps you might want to give it a shot first (Apology if you'd already did try that).

cheers.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TintinAuthor Commented:
I'd forgotten about this question, but I didn't eventually find a solution (although I can't remember what I actually did).

I appreciate the effort, so I'm awarding the points anyway.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apache Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.