?
Solved

Prob getting online with new suse 8.1 installation

Posted on 2003-03-03
6
Medium Priority
?
200 Views
Last Modified: 2010-03-18
i am a newbie to linux, and have limited understanding of networking and how the various protocols work, so i'll throw as much info up here as i can.

***problem***
i can't get to the net...when i start kinternet, i get a "can't connect to local server" error.  i've tried ping'ing names and ip's...nothing.
************

***Setup***
2 onboard ethernet (asus)
suse 8.1 / win xp (these are on separate physical drives)
linksys wirelss ap + router + switch (this box is plugged into the switch)
************

***other info***
during the boot process, i get failure messages for both ethernet devices: "could not get a valid interface name".  however, in the yast2 screens, it says both are configured properly.  also, there is something about "lo" that does seem to load.

what's strange (to me) is that after installation, the system defaulted the ip address to 127.0.0.1 and the netmask to 255.0.0.0 for one of the "cards" - i think it was eth0.

initially, resolv.conf contained only the entry "domain local".  i changed this to "nameserver 192.168.1.1"  (i got this from another windows machine on my network using ipconfig...this was the value for DHCP server)

modules.conf has the following under the aliases section:
alias eth0   off
alias eth1   off

btw, i have tried booting with the cable in each eth port.

arg!  thanks for any suggestions...
0
Comment
Question by:gbonnett
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
6 Comments
 
LVL 8

Expert Comment

by:heskyttberg
ID: 8060137
Hi!

In the modules.conf it should look something like this instead.

alias eth0 3c59x
alias eth1 sundance

The second columns tells linux what NIC driver to load.

If it dosen't suse wasn't able to figure out what ethernet driver to use for you NICs.

Try to run kudzu if you installed it to see if it can find your NICs, if you didn't install it it's kind of like Windows plug'n'play auto find new units and load the drivers into your system.

Regards
/Hans - Erik Skyttberg
0
 
LVL 8

Expert Comment

by:heskyttberg
ID: 8060140
Hi!

As a side note:lo is loop back device and is set to 127.0.0.1w for network.

Regards
/Hans - Erik Skyttberg
0
 

Author Comment

by:gbonnett
ID: 8060796
Thank you for your response...

I don't seem to have access to kudzu...this is suse, not rh.

any other way that i can tell what value should go in the second column?

also, do the values that i stored in resolv.conf seem correct?

gb
0
Tutorial: Introduction to Managing a Linux Server

In this tutorial on systemd, we will explore:
-OS/Distro Adoption
-chkconfig and Other Legacy Commands
-Summary and Key Commands

 
LVL 8

Expert Comment

by:heskyttberg
ID: 8060896
Hi!

No it dosen't quite seem correct.
You should look for values for NameServers not DHCP.

The values that should be in modules.conf dpepends on what NICs are included and how much ASUS changed the chipset behaviour.

Best bet is to look on asus homepage for Linux NIC drivers or read the manual to try and figure out chipset and module of NIC.

Then you can go here and do as follows:
cd /lib/modules/
cd x.x.x-x.x.x or somthing else representiung your currently running kernel.
cd kernel/drivers/net

In here you will find all network drivers.
If you are a daredevil you can do this.

for i in `/bin/ls *.o` ; do modprobe $i ; done

Be warned the computer might hang on anyone of theese drivers.

You could also manually try them one by one by doing:
modprobe filename.o

If none of them work, then you are out of luck.

Regards
/Hans - Erik Skyttberg
0
 

Author Comment

by:gbonnett
ID: 8067419
well, i'm accessing this page through my linux box...weeeeee!

sorry i've taken a while to post this comment, but it's been a wild ride:

after much searching, i discovered three things:

1) that most people using my motherboard aren't able to get the 3com ethernet working.
2) "working" drivers for 3com is included on the cd that came  with the mb.  it took some looking to find it, but they're there.
3) the fact that the source code they provide won't even compile suggests that 1) above is accurate.


the 2nd ethernet port is nvidia.  i downloaded the unified linux driver from their site and installed it with yast2.  i had to uncomment some things in modules.conf and comment some others. (this step was, of course, absent from the instruction readme.)  when i rebooted, the machine seemed to hang.  tried 3 times, then the last time let it sit and while i did something else.  after about 5-10 MINUTES!!! the desktop appeared and guess what, i'm online.

thanks for your help.  i'm new to this, so now what to i do about the points.

george
0
 
LVL 8

Accepted Solution

by:
heskyttberg earned 120 total points
ID: 8068124
Hi!

Do whatever you want with them, :)

Well you could accept one answer and give a grade according to how much it helped or fi it helped at all.

If you don't think anyone of us really helped you, you can go to community support ask a 0 point question and ask for this one to be deleted, then you get your points back.

You can also share points if you wish.

Regards
/Hans - Erik Skyttberg
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…
Suggested Courses

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question