?
Solved

Can't delete alias eth0:1

Posted on 2003-03-03
5
Medium Priority
?
3,586 Views
Last Modified: 2008-03-04
Somehow I've configured an alias for my eth0 device.  If I do ifconfig, I see eth0 and eth0:1.  I can do a ifconfig eth0:1 del xx.xx.xx.xx and it goes away.  However, if I do a 'ifdown eth0' and then 'ifup eth0', it's back out there.  When both are active, I notice a continual slowdown of network access.  Websites take several minutes to display, and pings just don't happen.  I use linuxconf to configure the devices, but there are not aliases configured in there.  Is there some way to permanently disable this device?  Could this cause the slowdown on my machine?

Thanks

Ben
Mandrake 9.0
Sony VAIO - 933 Mhz
0
Comment
Question by:bbressler
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 8

Expert Comment

by:heskyttberg
ID: 8060114
Hi!

eth0 and eth0:1 is the same interface.

So delteing or removing eth0 will kill your LAN/Internet connection to the Linux box.

If you do ifconfig eth0 and ifconfig eth0:1 you'll notice that the hardware address, HWaddr XX:XX:XX:XX:XX:XX, is the same for both devices.

eth0:1, eth0:2 ..... eth0:n

They are used so you can multiple IP numbers to a NIC.
I don't know what max number of IPs you can have, but I think it's enough for most people.

Regards
/Hans - Erik Skyttberg
0
 

Author Comment

by:bbressler
ID: 8060131
Right...but I want to get rid of the eth0:1 - for good.  Since they are on different subnets, I think it is slowing the connection way down.  When I remove it, the machine functions properly and has quick network speed.  With it enabled, it slows to a crawl quite quickly.  Thanks
0
 
LVL 8

Accepted Solution

by:
heskyttberg earned 100 total points
ID: 8060618
Hi!

I'm sorry I missed the ifdown, ifup first time!

Go here:

/etc/sysconfig/network-scripts

You should have a file called ifcfg-eth0

Edit that file and remove the offending lines.

Regards
/Hans - Erik Skyttberg
0
 
LVL 8

Expert Comment

by:heskyttberg
ID: 8060623
Hi!

That is the place for redhat, but you should be able to find something similiar if you use another distro.

Regards
/Hans - Erik Skyttberg
0
 

Author Comment

by:bbressler
ID: 8060680
Great job... Thanks
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.
Suggested Courses

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question