• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 801
  • Last Modified:

ORA 12560 : TNS protocol Adaptater Error on 8i Win2K



Hello

I have a problem with the instalation of the database on Oracle 8i (Win2000) . According o the I have set up the ORACLE_SID <myInstance> parameter in the oracleHome registry key ,
configured ORAPWD ,configured a listener with TCP/IP on port 1521 as protocol and started it up but there is no way to  create the database instance by Oracle Database Assistant and nor by SVRMGRL and a database script , both of them raise this error .Further ,I've tried to use ORADIM for creating the service but It did not help anyway .I don't think  about a protocol trouble , because i've tried to connect to another server instance (9i) using his service.name and it worked fine so I can use his database normally , but in local i cannot .
Another Question ..Where is OEM on Oracle 8i , i've installed the whole package but i can't Find OEM ...


Thanks for helping .
0
tascepan
Asked:
tascepan
1 Solution
 
wamoncskCommented:
Your TNSNAMES appears to be working fine.  The problem area appears to be in the LISTENER.

What are the protocols that are being listened on.  Windows appears to like to have both the external proc and the GIOP areas in the listener and SID section.

Another area may be that there is a localhost in the listener section and this gets Oracle confused about where to listen.

Look into using the dot addressing instead of the host name in the TCP seciton of listening.  Sometimes if the hosts file is not set up for your machine, you may have trouble with DNS address translation.

These are some thoughts,

Warren
0
 
BobMcCommented:
ORA-12560 is a very generic error.

 Here are some more possible causes:

1. Database OS processes haven't been created (equivalent to a startup nomount)
ORADIM -new -sid=<myinstance> will create the registry keys and the Windows service. You can start this service which will create the OS processes/threads for Oracle

use ORADIM -startup or start the service from control panel

2. When creating the database, you have to connect via bequeath (IPC). You will need to set the environment variable ORACLE_SID=<myinstance> before starting server manager.

3. If you are connecting to your W2K server via terminal services, beware that there are problems with bequeath connections and Oracle 8i and Win2K - ie it doesn't work properly. Install RemoteCommand service and connect via that instead.

4. Something else...I hope you don't get this far...

I don't think the problem will be with your SqlNet setup as you will bypass all this using bequeath adapter. If all else fails, enable client and server tracing (at least level 12) in your sqlnet.ora, and trawl through the output. It normally gives at some pointers, and at the very least will enable you to remove some of the possibles from your investigations.

HTH
Bob

0
 
tascepanAuthor Commented:
Thanks for helping

En reality I connected to the remote host by terminal server and it seems to be the cause of the problem .
As explained i had already tried to use the oradmin tool
and my instance path and SID variables were corrects .
No problems from the listener, but thank you for yours suggestions .
 

Thank a lot for yours helpfull comments .
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now