?
Solved

Add Sunblade with Solaris 9 to windows DHCP network

Posted on 2003-03-03
6
Medium Priority
?
513 Views
Last Modified: 2013-12-27
I have a Sunblade 2000 running Solaris 9 that was originally set up as a "stand-alone" computer.  It now needs to be added to a WinNT network that is using DHCP.  Is there an easy way for me to accomplish this?
0
Comment
Question by:nukevet
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 5

Expert Comment

by:Nisus091197
ID: 8061427
Hi,

The /etc/rcS.d/S30network.sh startup script tells us that the system will attempt to obtain an IP address via DHCP if there are no /etc/hostname.* files.

Simplest solution therefore is the rename your /etc/hostname.* files.

More info is available in the dhcp man page.

Regards, Nisus
http://www.omnimodo.com
0
 
LVL 1

Accepted Solution

by:
russgm earned 400 total points
ID: 8062162
you can also run "sys-unconfig"

This must be ran as root and once it is complete your machine will question you on reboot for your new setup information.  I do this all the time so I can move my machine between dev / test / production nets at work.
--russ
0
 
LVL 1

Expert Comment

by:guerriero33t
ID: 8063411
Delete the contents of the hostname.* files or delete the file and then recreate an empty one.

example.

rm -rf /etc/hostname.hme0
touch /etc/hostname.hme0
touch /etc/dhcp.hme0

You will want to create a script in /etc/rc1.d or rc2.d that resets the hostname to the original hostname.

echo "hostname [whatever your hostname is]" > /etc/rc2.d/S70sethostname

chmod 555 /etc/rc2.d/S70sethostname

reboot, and you will have dhcp enabled on your hme0 interface. If you want to allow network neighborhood style shares then you can install Samba.

Hope this helps.
0
Get real performance insights from real users

Key features:
- Total Pages Views and Load times
- Top Pages Viewed and Load Times
- Real Time Site Page Build Performance
- Users’ Browser and Platform Performance
- Geographic User Breakdown
- And more

 

Author Comment

by:nukevet
ID: 8066637
I tried both techniques suggested, first editing the hostname.hme0 file, and then running sys-unconfig.  So far, no luck.  Now I am getting a message during reboot that hostname.hme0 either does not exist, or cannot be managed by DHCP.  When I look in /etc/ I see the following interfaces:

dhcp.hme0 and dhcp.eri0

also, there is a

hostname.hme0 (created by me, and empty)
hostname.eri0 and hostname6.eri0

ALL of these files are empty.

Do I need to configure DNS information when configuring the system to use the NT DHCP server?  I know that I don't for and NT box running DHCP, but not sure about Solaris (I tried configuring both ways, and neither worked).

Sorry for asking what must be very basic questions.  It's tough being in the medical field and wanting to add a Solaris box to a hospital LAN that only supports NT.  But the 3D modeling software only runs in Solaris, and I have to have access to the Dicom images from the different imaging sections of the hospital.

Thanks for everyone's time.

Neal

0
 
LVL 5

Expert Comment

by:Nisus091197
ID: 8067096
Hi Neal,

I think you should rename the /etc/hostname.hme0 and the /etc/hostname.eri0 file so they don't begin with 'hostname'.

Are you sure that there is a DHCP server on the subnet that the SunBlade is connect to?  The default subnet mask is 255.255.255.0 and is configured in /etc/netmask.

You may want to consider installing Samba on the SunBlade so that you can share the images directory.  That way it looks just like a Windows folder.  More info. from http://www.samba.org

let us know how you get on,

Regards, Nisus
http://www.omnimodo.com
0
 

Author Comment

by:nukevet
ID: 8068001
Nisus,


Thanks for the reply.  I will try renaming all files that begin with "hostname" in /etc and see how I get on.

If I use ifconfig, it sees the eri0 interface, tells me it is multichannel, using DHCP, etc.  If I ping the DNS server, the box will see it.  However, ifconfig does not "see" the hme0 interface.  

On re-reading your first post, I see I misunderstood the point.  You are saying if there are no files named /etc/hostname.*, then the machine will, by default, try and connect using DHCP.

Thanks again,

Neal
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

FreeBSD on EC2 FreeBSD (https://www.freebsd.org) is a robust Unix-like operating system that has been around for many years. FreeBSD is available on Amazon EC2 through Amazon Machine Images (AMIs) provided by FreeBSD developer and security office…
Every server (virtual or physical) needs a console: and the console can be provided through hardware directly connected, software for remote connections, local connections, through a KVM, etc. This document explains the different types of consol…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Suggested Courses

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question