Remote Desktop WEB CONNECTION and Drive Redirection

When I use Remote Desktop with "Drive Redirection" turned on (options > Local Resources > Local Devices), I can see all the drives of the client computer. No problem here.

However, if I connection thru' Remote Desktop WEB CONNECTION I can't see the drives of the client computer. All I can see are the drives of the host computer. According to MS and many others "Drive Redirection" is ENabled by default for Remote Desktop WEB CONNECTION. So how come I can't see the local drives on the client computer?

According to one article I've found I should able to configure the Web Connection dialog box just as I would with the "regular" Remote Desktop Connection dialog box. But the "Options" tab there only hide/unhide the "Shutdown" button and lacks all the other options.

"Audio Redirection" and Clipboard Redirection" still work by default though.

I did find one page on the web which, IN CONTRAST TO WHAT MS SAYS, states that "Drive Redirection" is not supported via Remote Desktop WEB CONNECTION.

So who is right and what's the deal?

falcon2000Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jasborCommented:
Something to check:

In the user setup (right click my computer/manage)
Choose Local User/Groups
Pick a user. Under the terminal services tabs (and I think there are 2 or 3 of them) There are 3 check boxes. I think one is to reverse map the driver, printers, and I cant remember the other. I would check to see if you have these checked. From a local lan when you connect, these check boxes are put of the RDP (or ICA if using Citrix) client setup. If you are not using local users on the terminal server, you might have to check the user profile on the PDC or AD (active directory) servers.
Hope this helps.
0
falcon2000Author Commented:
Thanks for answer but I've just got the solution from a users at the MS Newsgroup.

It turns out that in contrast to the MS documents that I have seen "Drive Redirection" is NOT enabled by default for WEB CONNECTION.

When Web Connection is installed, Windows put a default.htm in C:\. This is the page you a remote user will use to log on the XP host. To enable "Drive Redirection" I need to enable "Drive Redirection' by editing the following in the default.htm:

MsRdpClient.AdvancedSettings2.RedirectDrives     = FALSE
change FALSE to TRUE.

I'm new here (2nd posting) so I don't know how to close this thread now the problem is solved. Plus, do I still grade the reply? And how about my points?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
paullamhkgCommented:
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is to:

Be PAQ'd/Points Refunded

Please leave any comments here within the next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

Paul
EE Cleanup Volunteer
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.