Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

VMWare on Slackware

Posted on 2003-03-04
5
Medium Priority
?
1,244 Views
Last Modified: 2013-12-15
Hi there,

I've checked everywhere for an answer before posting it here.  I've followed the directions of this website: http://www.cs.ucr.edu/~jbyrne/vmware.htm to install vmware(3.2) on slackware(8.1).  

I've partitioned my laptop so that I have Slackware and XP running.  I've installed vmware on windows to get a feel for Linux.  Now im ready to go the other way:  Install vmware on Slackware so that I minimally use windows.  

The errors occur after I input the command ./vmware-configure.pl --compile.  

------------------------------------------
What is the location of the directory of C header files that match your running kernel? [/usr/src/linux/include]

(I would type in the suggested folder and this is my error)

The kernel defined by this directory header files is multiprocessor, while your running kernel is uniprocessor.

(It then asks me the same question)

What is the location of the directory of C header files that match your running kernel? [/usr/src/linux/include]

---------------------
I've tried /usr/src/linux-2.4.18/include and it would still give me the same error.  

Any suggestions?

Foxy
0
Comment
Question by:foxypeaches
  • 3
  • 2
5 Comments
 
LVL 6

Accepted Solution

by:
mbarbos earned 400 total points
ID: 8076025
Save the .config file from  the kernel directory somplace else, run
make mrproper
make menuconfig (and save without changing options :)
make dep

and try again now.

Check though that you ARE running that kernel (uname -a)
0
 

Author Comment

by:foxypeaches
ID: 8088445
That fixed it.  But now when I configure my VM; going through the custom configuration, I get the same error.  I've even gone up to VMware 4.0 and its still the same error:  selecting XP as the guest OS, then Using a physical hard disk, everytime I select /dev/hda (use individual partitions)

Failed to laod partitions for device /dev/hda: DISKLIERR_INVALIDDEVICE

Any suggestions?
0
 

Author Comment

by:foxypeaches
ID: 8088513
NM.. I found the error.  I needed a driver for it.  Thanks for your help.

0
 
LVL 6

Expert Comment

by:mbarbos
ID: 8088536
Do you have a partitioned /dev/hda ?
0
 
LVL 6

Expert Comment

by:mbarbos
ID: 8088546
Ok, glad that it works
0

Featured Post

Become an Android App Developer

Ready to kick start your career in 2018? Learn how to build an Android app in January’s Course of the Month and open the door to new opportunities.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In my business, I use the LTS (Long Term Support) versions of Linux. My workstations do real work, and so I rarely have the patience to deal with silly problems caused by an upgraded kernel that had experimental software on it to begin with from a r…
I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension . This reminded me of questions that come up here at EE along the lines of, "How can I tell the type of file from its cont…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
Suggested Courses
Course of the Month10 days, 22 hours left to enroll

571 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question