?
Solved

Assigning a IP from a DCHP DSL connection

Posted on 2003-03-04
17
Medium Priority
?
526 Views
Last Modified: 2012-06-27
Hello,

I have a pppoe DSL connection, connected to a DLink
DI-614+ Wireless router/switch through the Wan port,
I then have a PC connected to port 1 ( 192.168.0.100 )
( which works fine ).

The Dlink is giving DCHP IP's of 192.168.0.100 - .199/24

I have two 2524 routers and another server.

Router2 - S1 - ip 192.168.5.34/27
Router1 - S1 - ip 192.168.5.33/27 - E0 ip 192.168.5.65/27
SVR1    - E0 - ip 192.168.5.67/27

The Router 2 and Router 1 are connected through a ser cable ( which works fine )Using Rip - Net 192.168.5.0
& 192.168.0.0

I assigned Router 2 a E0 ip of 192.168.0.199/24
and can see the PC ( 192.168.0.100 ) and the Wireless router ( 192.168.0.1 ).

When I telnet from SVR1 to Router1 I cant ping 192.168.0.199

Is there a way to bypass everything and connect the pppoe
DSL connection straight into Router2 and SVR1 be able to hit the internet.

Thanks,
Chris
0
Comment
Question by:CMILLER
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 8
17 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 800 total points
ID: 8066255
Use a different IP subnet between the two serial interfaces.
R1S1=192.168.15.1 255.255.255.0
R2S1=192.168.15.2 255.255.255.0
R2 default route = ip route 0.0.0.0 0.0.0.0 192.168.15.1
R1 default route = ip route 0.0.0.0 0.0.0.0 192.168.0.1
R1 static route = 192.168.5.0 255.255.255.240 192.168.15.2

done
0
 

Author Comment

by:CMILLER
ID: 8084740
Lrmoore,

on the
R1 static route = 192.168.5.0 255.255.255.240 192.168.15.2
should that be 255.255.255.224 its a /27.

I have tried this and connot get it to work.

Should I be able to ping
Router 2, E0 ip of 192.168.0.199/24

If so , I cant

I cant ping 192.168.0.1 either
( which is the wireless router )

Here is a look at R1
interface Ethernet0
 ip address 192.168.5.65 255.255.255.224
 no ip directed-broadcast
!
interface Serial1
 ip address 192.168.15.1 255.255.255.0
 no ip directed-broadcast
!
router rip
 network 192.168.0.0
 network 192.168.5.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.0.1
ip route 192.168.5.0 255.255.255.224 192.168.15.2

Here is a look at R2
interface Ethernet0
 ip address 192.168.0.199 255.255.255.0
 no ip directed-broadcast
!
interface Serial1
 ip address 192.168.15.2 255.255.255.0
 no ip directed-broadcast
 clockrate 64000
!
router rip
 network 192.168.0.0
 network 192.168.5.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.15.1

On the RIP, is it ok to just use 192.168.0.0

Thanks,
Chris
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8085198
on both routers, add
router rip
network 192.168.15.0

rip only works on classful boundaries, no, cidr

/27 = 255.255.255.224 my bad

post results of
sho cdp neigh
sho ip route
sho ip int brief

0
Optimum High-Definition Video Viewing and Control

The ATEN VM0404HA 4x4 4K HDMI Matrix Switch supports 4K resolutions of UHD (3840 x 2160) and DCI (4096 x 2160) with refresh rates of 30 Hz (4:4:4) and 60 Hz (4:2:0). It is ideal for applications where the routing of 4K digital signals is required.

 

Author Comment

by:CMILLER
ID: 8089866
Router1#show cdp neigh
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
FWBEACHRouter2      Ser 1          177           R        2524      Ser 1
LabSwitch1          Eth 0          136          T S       WS-C2924M-Fas 0/19

Router1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

C    192.168.15.0/24 is directly connected, Serial1
     192.168.5.0/27 is subnetted, 2 subnets
C       192.168.5.64 is directly connected, Ethernet0
S       192.168.5.0 [1/0] via 192.168.15.2

Router1#show ip int brief
Interface              IP-Address      OK? Method Status                Protocol

BRI0                   unassigned      YES unset  administratively down down

BRI0:1                 unassigned      YES unset  administratively down down

BRI0:2                 unassigned      YES unset  administratively down down

Ethernet0              192.168.5.65    YES NVRAM  up                    up

Serial0                unassigned      YES unset  administratively down down

Serial1                192.168.15.1    YES manual up                    up


---------------------------------------------------------

Router2#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
ARHOTSRouter1       Ser 1          160           R        2524      Ser 1
LabSwitch1          Eth 0          137          T S       WS-C2924M-Fas 0/20

Router2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 192.168.15.1 to network 0.0.0.0

C    192.168.15.0/24 is directly connected, Serial1
C    192.168.0.0/24 is directly connected, Ethernet0
S*   0.0.0.0/0 [1/0] via 192.168.15.1

Router2#show ip int brief
Interface              IP-Address      OK? Method Status                Protocol

BRI0                   unassigned      YES unset  administratively down down

BRI0:1                 unassigned      YES unset  administratively down down

BRI0:2                 unassigned      YES unset  administratively down down

Ethernet0              192.168.0.199   YES manual up                    up

Serial0                unassigned      YES unset  administratively down down

Serial1                192.168.15.2    YES manual up                    up
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8089894
It does not look like they are actually seeing each other over the serial interface even though it is up/up
Not even cdp is getting accross.

Can you ping the serial interfaces either of them? from anywhere?
Is the DCE cable connected to R2?
0
 

Author Comment

by:CMILLER
ID: 8090351
Yes, DCE is on R2

On R2
can ping
15.1
15.2
5.65
5.67 SVR1
0.199

On R1
can ping
15.1
15.2
5.65
5.67 SVR1
cant ping
0.199 ( E0 - R2 )
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8090389
Do you have "ip subnet zero" on R2?
0
 

Author Comment

by:CMILLER
ID: 8090452
Yes, On both R1 & R2
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8090565
Try an extended ping from R2 to R1/E0, using source address of 192.168.0.199

Try changing to Rip v2 or EIGRP

R1
router eigrp 101
 network 192.168.5.0
 network 192.168.15.0
 no auto-summary

R2
router eigrp 101
 network 192.168.0.0
 network 192.168.15.0
 no auto-summary

0
 

Author Comment

by:CMILLER
ID: 8091208
Tried a extended, no luck
Tried RipV2, no Luck

I changed to EIGRP

I can ping 192.168.0.199 from router1,
which is a good thing, but I get a constant
error on both routers

R1-
neighbor 192.168.0.199 not on common subnet for eth0

R2-
neighbor 192.168.5.65 not on common subnet for eth0
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8091272
Both Ethernet ports are plugged into the same switch? VLAN the switch, or use two different ones.
0
 

Author Comment

by:CMILLER
ID: 8091327
I have never configured VLAN, How would I set it up
in this config.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8091379
What kind of switch?
0
 

Author Comment

by:CMILLER
ID: 8091405
2900XL, I just got the VSM ( Web config ) working.
0
 

Author Comment

by:CMILLER
ID: 8091463
Thanks,
You have been a big help, does it matter which comment
I accept as a Answer
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8091474
Pick one, any one...

Glad to help!
0

Featured Post

On Demand Webinar - Networking for the Cloud Era

This webinar discusses:
-Common barriers companies experience when moving to the cloud
-How SD-WAN changes the way we look at networks
-Best practices customers should employ moving forward with cloud migration
-What happens behind the scenes of SteelConnect’s one-click button

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen some questions on problems with SSH/telnet access to Cisco routers that may occur despite the fact that from a PC connected to your LAN, Internet connectivity is in place and users can access Internet sites without any issues.  There are…
How to set-up an On Demand, IPSec, Site to SIte, VPN from a Draytek Vigor Router to a Cyberoam UTM Appliance. A concise guide to the settings required on both devices
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question