?
Solved

Exchange problems continue, I need Kidego again. Please!

Posted on 2003-03-04
27
Medium Priority
?
595 Views
Last Modified: 2010-05-19
I tried to make the connection to the X400 and during that time everything flew out the window. Right now i am only able to startup the system attendent. Nothing else. I have tried running isinteg -patch but no help. I will give you the event log errors when you respond.

Thanks Greg
0
Comment
Question by:comeaug
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 16
  • 11
27 Comments
 
LVL 24

Expert Comment

by:David Wilhoit
ID: 8073112
Cool. Something is very weird dude, if the DS and the IS started cleanly before, then it should start again. what x.400 connection are you referring to? Post the errors for the services failing from the applog, not the syslog.

D
0
 

Author Comment

by:comeaug
ID: 8073590
The Microsoft Exchange Internet Mail Service, version 5.5.1960.3, is starting.
An error was returned from the messaging software the Internet Mail Service uses to process messages on the Microsoft Exchange Server. It is possible that the piece of mail being processed at the time will be returned to the sender as a failed delivery instead of being delivered. The message will be moved to the "BAD" folder, if possible, and the error is not a temporary error. Otherwise it will be retried when the service is restarted. Use the appropriate utilities found in the SUPPORT directory of your Exchange CD to view and manipulate messages that have been moved to the "BAD" folder.
Unable to start the Internet Mail Service because MAPI could not be initialized.
MSExchangeDS (686) Unable to create the log. The drive may be read-only, out of disk space, misconfigured, or corrupted. Error -1811.
(Its not out of space 60GB free)Good luck! Dude...
0
 

Author Comment

by:comeaug
ID: 8073617
here are some more..
The description for Event ID ( 8 ) in Source ( LME ) could not be found. It contains the following insertion string(s): LinkAge NOTES Proxy Address Generator Initialized With Rule: NOTES:&d/FPWPPR/NF@Exchange.
The description for Event ID ( 8 ) in Source ( LME ) could not be found. It contains the following insertion string(s): LinkAge PROFS Proxy Address Generator Initialized With Rule: PROFS:FPWPPR(&M).
The description for Event ID ( 8 ) in Source ( LME ) could not be found. It contains the following insertion string(s): LinkAge SNADS Proxy Address Generator Initialized With Rule: SNADS:FPWPPR(&M).
The Microsoft Exchange DX is stopping.
MSExchangeDX (711) The database engine stopped.
Here is the X400 error..Service closedown complete, version 5.5 (build 1960.3). [BASE IL MAIN BASE 29 490] (16)

After that POP3 stopped, IMAP,IS,NNTP etc.
0
Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 
LVL 24

Expert Comment

by:David Wilhoit
ID: 8073654
You haven't reapplied the service pack. Weren't you on SP4 for Exchange? Whatever it was, reapply the SP, and reboot. Let me know...

d
0
 
LVL 24

Expert Comment

by:David Wilhoit
ID: 8073672
From your previous issue, I can see you were on SP4 for Exchange 5.5. Reapply, you should be fine.


"As for the events log they are as follows
-MS ExchangeIS (684) the database engine 05.2653..0011 started.
-Information Store with unlimited storage capacity enabled."
0
 

Author Comment

by:comeaug
ID: 8073803
Ok I will reapply SP4. Do you know where the free points surveys are on this site?
0
 
LVL 24

Expert Comment

by:David Wilhoit
ID: 8073895
Probably under "Community Support" link.

D
0
 

Author Comment

by:comeaug
ID: 8074777
Ok so I applied sp6 (current level)and rebooted. Here are the events
Microsoft Exchange System Attendant is starting. Microsoft Exchange Server System Attendant, service startup complete, version 5.5 (build 1960.5).
The description for Event ID ( 0 ) in Source ( NMSSvc ) could not be found. It contains the following insertion string(s): Service started.
The description for Event ID ( 0 ) in Source ( NSCTOP ) could not be found. It contains the following insertion string(s): Service started..
MSExchangeDS (627) The database engine 05.2653.0011 started.
MSExchangeDS (627) The database engine is initiating recovery steps.
MSExchangeDS (627) The database engine is replaying log file C:\exchsrvr\DSADATA\edb00007.log.
MSExchangeDS (627) -515
Error -515 has occurred (internal ID 2030148). Contact Microsoft Technical Support for assistance.
The Microsoft Exchange Server database (EDB) could not be initialized and returned error -515.  Unrecoverable error, the directory can't continue.
The directory was shut down successfully.
Unexpected error <<0xc0040000 - Network problems are preventing connection to the Microsoft Exchange Server computer. Contact your system administrator if this condition persists. MAPI was unable to load the information service emsabp.dll. Be sure the service is correctly installed and configured. Microsoft Exchange Address Book ID no: 00040380-0000-00000000>> occurred.
good luck!
0
 
LVL 24

Expert Comment

by:David Wilhoit
ID: 8075515
No, I didn't say NT service pack, I said Exchange service pack. You still haven't applied the EXCHANGE service pack, as evidenced by the build 1960.5. Hopefully when you apply that now it will start up.

D
0
 

Author Comment

by:comeaug
ID: 8079239
Sorry, I shall find it and apply.

:(
0
 

Author Comment

by:comeaug
ID: 8079339
Ok so I have about 8 different SP's to choose from , I am downloading SP4_5501.exe the description says it is a Core server netsetup.


0
 

Author Comment

by:comeaug
ID: 8079580
So I ran SP4_5001.exe and ran into some errors, they said Directory Service,The service did not respond to the start control request in a timely fasion ID No: 0xc002041d

And then the directory service could not be started. If you continue some important setup checks will not be possible. If the directory has been corrupted you will to remove your MS Exchange Server and reinstall it. Do you wish to continue? I chose cancel.
:(

Any ideas?
0
 
LVL 24

Expert Comment

by:David Wilhoit
ID: 8080619
Save the databases, dir, priv and pub.edb. Copy them to  a separate location in case we have to rebuild Exchange altogether.

Is this the only Exchange 5.5 server? If so, document the settings, so you can reproduce them. The deal is, it sounds like something changed from the previous installed server, or something corrupted your dir.edb. Did you change the service account for Exchange, from the last time? I know you changed the password, but the services restarted after you made that change, right?

Post the exact errors from the event log. Start the Exchange services in this order:

SA
DS
IS

Then post the errors you get, and you can take out the server name from the Events if you want.

D
0
 

Author Comment

by:comeaug
ID: 8081039
Ok so I am backing up all files from c:\exchsrvr\mdbdata and D:\exchsrvr\mdbdata. Yes this is the only exchange server. I know this is a numb question but document the Exchange 5.5 settings? The only thing that was changed was back in 2001. The existing NT4 server was named wppr_server , now the new one is named that. The old one is serverb. Yes the services started after I made the changes to the password.

These are just the error description as they appeared from the services I just tried to start in order:
Error1 0 ESE97 Logging /Recovery Description -MSExchangeDS (717) -515
 
Error2 1002 MSExchangeDS Internal processing- The Microsoft Exchange Server database (EDB) could not be initialized and returned error -515.  Unrecoverable error, the directory can't continue.

Error3 ESE97 Logging/Recovery- MSExchangeDS (724) -515

Error4 1002 MSExchangeDS Internal processing-The Microsoft Exchange Server database (EDB) could not be initialized and returned error -515.  Unrecoverable error, the directory can't continue.

Error5 1005 MSExchangeSA Monitoring-Unexpected error <<0xc0040000 - Network problems are preventing connection to the Microsoft Exchange Server computer. Contact your system administrator if this condition persists. MAPI was unable to load the information service emsabp.dll. Be sure the service is correctly installed and configured. Microsoft Exchange Address Book ID no: 00040380-0000-00000000>> occurred.
0
 
LVL 24

Expert Comment

by:David Wilhoit
ID: 8081597
OK bro, what happened in the DS? you've got logfiles in there that don't match. Tell me what happened, and how. Do you have AV software scanning ANY OF the \EXCHSRVR directories? If so, it may have quarantined one of the logs, and took everything down. do you have a copy of the \DSADATA folder from before, or at least have an online backup of the Directory service? If you have that offline copy from before (dir.edb), then you can use that again to start the DS. Remember, when you do this, that any objects deleted since you copied that file, will be back in your org, and you'll have to remove them again. if the DS starts, you'll have to go thru the process of isinteg -patch again. Try to start the IS BEFORE you run isinteg. that's important. Also, when you use the old dir.edb, remove all files from any DSADATA folder you have, C: or D:. Any questions?

D
0
 

Author Comment

by:comeaug
ID: 8082163
OK,I use Norton Corp edition it scans C:\$ and D:\$. I just set that scan last week. For future you are saying not to scan any files in EXCHSRVR folders? Also
I think I have a good backup of the \DSADATA.
I will do a restore from what seems to be a good backup of the dsadata. I will move the current DSADATA to another folder and do my restore.
0
 

Author Comment

by:comeaug
ID: 8082590
Hey D how big a job would it be to reinstall Exchange?
Like does it mean bringing the server down completely?

G
0
 
LVL 24

Expert Comment

by:David Wilhoit
ID: 8082671
"OK,I use Norton Corp edition it scans C:\$ and D:\$. I just set that scan last week. For future you are saying not to scan any files in EXCHSRVR folders? "

Yes. Logfiles can be eaten by the AV software. you might actually find your logs in the quarantine folder in the NAV interface, and you could try to put them back, whether or not it will work, can't say. 50/50.

Reinstalling Exchange would mean at least bringing down the Exchange server, if not formatting the whole thing. I don't recommend the latter, unless there's a solid reason, it's unnecessary work.

When you say reinstall, are you planning on removing EXchange completely,and then reinstall, or just run reinstall over what you already have? Totally different scenario. Let me know...
0
 

Author Comment

by:comeaug
ID: 8082753
I looked in the NAV interface. Nothing at all. However there was a new file that was created found in the \EXCHSRVR\dsadata folder it is called hierarch.dat It was created the same time all the screws came loose on Feb 28. Maybe it means nothing. It wasn't in there during my backup of the 27th. As far as the question to install or reinstall? I think you are the man that would know more about which one to do. Or should we continue as we are. I wish I could call you... :(
0
 
LVL 24

Accepted Solution

by:
David Wilhoit earned 400 total points
ID: 8082805
Don't worry about the heirarch.dat, that's auto-magic. Try the restore of the dsadata folders, and remember to clean out BOTH of them, you may also have one on the D: drive. I don't think you need a reinstall at all, that should be a last resort. relax, you could be up in 5 minutes, if you replace the dir.edb  cleanly. :)

D
0
 

Author Comment

by:comeaug
ID: 8083180
Ok ok we are getting somewhere now. DS just started. I was a little confused about the other files in the DSADATA folder. I didn't realize they re-wrote themselves as the service was attempting to start. So no I have SA and DS but IS returned an error, so I ran the ISTENG -patch. IS started.

Did I hear the church bells ringing!!
0
 

Author Comment

by:comeaug
ID: 8083296
Kidego "D" you are a genius. I still need to make my connection with X400. That will be done tomorrow. That puts our exchange server on the global address list within our corporation.
You have great patience working with me.
0
 

Author Comment

by:comeaug
ID: 8104272
Everything connected well.


Thanks dude!
0
 
LVL 24

Expert Comment

by:David Wilhoit
ID: 8105234
You're welcome, glad to help!

David
0
 

Author Comment

by:comeaug
ID: 8118923
Why is it that you have only received 10 points for my first 2 questions? I am positive I gave you more. Are you awarded only a % of the points? Let me know because I will give you more points.

Greg
0
 
LVL 24

Expert Comment

by:David Wilhoit
ID: 8119399
I don't really know, Greg. I think it gave me 200 each question, I don't know the formula for calculating the points. But your attitude and honesty are appreciated! If you feel like throwing a few more points my way, that's cool, truthfully, I just like working with Exchange. I'm always glad to see I helped someone resolve the issue at hand, and it keeps my skills sharp on a daily basis :)

Post anytime, later!

David
0
 

Author Comment

by:comeaug
ID: 8119576
Hey no problem.... are you aware of my new problem. I know you are a able to fix me AGAIN.

Please reply soon as you can. You are a GREAT HELP!

Greg
0

Featured Post

Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you troubleshoot Outlook for clients, you may want to know a bit more about the OST file before doing your next job. IMAP can cause a lot of drama if removed in the accounts without backing up.
Check out this step-by-step guide for using the newly updated Experts Exchange mobile app—released on May 30.
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question