?
Solved

GNOME and Sawfish in Redhat 8.0

Posted on 2003-03-04
12
Medium Priority
?
695 Views
Last Modified: 2013-12-27
Does anyone know how to change GNOME's window manager in Redhat 8.0?  I would like to use sawfish, which GNOME in Redhat 8.0 does not use as default.  I have downloaded the Sawfish rpm package and installed it, and I can start an X session directly into Sawfish, but I can't seem to figure out how to make GNOME use Sawfish as its window manager. My Redhat 7.3 machines have a "window-manager" switching program, but I can't find its 8.0 equivilent.
One thing I tried that did not work was starting a Sawfish X session and then issuing the "gnome-session" command from a terminal in the Sawfish session, with the hopes of them being able to save the session settings.  It gave an error saying that there was already a window manager open.
Any ideas??
0
Comment
Question by:cdollar
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 2
  • +2
12 Comments
 
LVL 17

Expert Comment

by:dorward
ID: 8068509
I'm not certain, but I think this should do the trick:

Run "gconf-editor"
In the tree to the left go to: "/desktop/gnome/applications/window_manager"
In the window to the top double click on "default"
Enter the path to the window manager you want.
0
 

Author Comment

by:cdollar
ID: 8068692
I can change the values for the key successfully (even as root) but when I log back in it changes the value back to /usr/bin/metacity.
0
 

Author Comment

by:cdollar
ID: 8069361
I can change the values for the key successfully (even as root) but when I log back in it changes the value back to /usr/bin/metacity.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
LVL 17

Expert Comment

by:dorward
ID: 8070117
I'm guessing that it is saving the result when you exit gnome. Try changing your desktop to something else (or just using a plain WM - maybe even don't bother with a WM and just use gconf-editor) and then making the change. Then log out, set your WM as gnome again and log and back in.

NB: This is done on a per user basis, running as root will just set it up for root.
0
 
LVL 20

Expert Comment

by:Gns
ID: 8070675
What is wrong with using "The Hat"->Settings->Control Panel->Extra Programs->Sessions"? You should be able to remove metacity from "this session", and add sawfish (with prio 20) in the "Start command" tab, logging out and saving the session, then logging in...?
I haven't tested this heavily, but it should Just Work:-).

The strings in the above might be different, I wouldn't know the exact english labels etc since I'm in a swedish locale.

-- Glenn
0
 

Author Comment

by:cdollar
ID: 8072073
I tried the changes to gconf with another window manager, but it still didn't like the settings.  And under "sessions" when I would remove metacity from the session it would lose the gnome menu and all windows.

But I think I have it figured out.  

From what I can tell, Gnome doesn't want to run without an active window manager, so killing metacity only results in metacity restarting once Gnome realizes that it doesn't have a window manager. To get arount this, I used the gnome-system-monitor to find metacity's process id, went to a terminal and issued the command 'kill 0000; /usr/bin/sawfish &' (where 0000 is the pid number).  This killed metacity and immediately started sawfish before metacity could be restarted by Gnome.  Then I issued 'gnome-session-save' to save the settings with sawfish.  When I closed the terminal window that I had issued all the commands from, it also killed sawfish, and I was fordced to do a reboot.  But this time the settings saved, and I now have sawfish working correctly.

0
 
LVL 20

Accepted Solution

by:
Gns earned 225 total points
ID: 8073061
Hm, I just verified a slight variation on that. gnome-session-properties, remove metacity, start /usr/bin/sawfish from a terminal (it shows up in the current session), then gnome-session-save...
Talk about cumbersome.
Of course one should be able to just edit the xml file and <Ctrl>-<Alt>-<Backspace>, but that feels even more backwards.

-- Glenn
0
 

Author Comment

by:cdollar
ID: 8073166
Yes, that seems to do the job too.  There has to be a better way, though.  
For instance, when I made it back in my office and got to a "fast" computer, it took me multiple tries before I could get sawfish to start before Gnome tried to start metacity again.  I did get it to work, but it took killing the process 3 times before it worked.  I know there has to be a better way... or mabye Redhat left the window-manager changer out for some reason I don't know about.

Thanks to everyone that gave suggestions... I never could have come to this solution without them.
0
 
LVL 20

Expert Comment

by:Gns
ID: 8073194
If you set metacity to "Normal" first (and "apply" it) it shouldn't keep on restarting it.
Might be worth a try.

-- Glenn
0
 

Author Comment

by:cdollar
ID: 8073227
Yes, that seems to do the job too.  There has to be a better way, though.  
For instance, when I made it back in my office and got to a "fast" computer, it took me multiple tries before I could get sawfish to start before Gnome tried to start metacity again.  I did get it to work, but it took killing the process 3 times before it worked.  I know there has to be a better way... or mabye Redhat left the window-manager changer out for some reason I don't know about.

Thanks to everyone that gave suggestions... I never could have come to this solution without them.
0
 

Expert Comment

by:lantolin
ID: 8401703
Why so complicated?

Make sure you have installed sawfish-2.0-4.rpm from RedHat,
and then add this line in $HOME/.bash_profile

export WINDOW_MANAGER="sawfish";

Log off, log in and: Hop!, like a charm  :)

The line can be in any of your init scripts, as long as this
is executed before a WM is chosen. Same applies if you want
to make it system-wide available.


     /Lantolin


0
 

Expert Comment

by:CleanupPing
ID: 9089966
cdollar:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you do backups in the Solaris Operating System, the file system must be inactive. Otherwise, the output may be inconsistent. A file system is inactive when it's unmounted or it's write-locked by the operating system. Although the fssnap utility…
A metadevice consists of one or more devices (slices). It can be expanded by adding slices. Then, it can be grown to fill a larger space while the file system is in use. However, not all UNIX file systems (UFS) can be expanded this way. The conca…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.
Suggested Courses

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question