[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 580
  • Last Modified:

Setting up FTP server (port 21) with a Netgear RT311 Router

Ive been searching all night and i have upgraded my firmware version to allow port forwarding..

i even got to the point where people on my network can join the ftp but noone outside can get onto my server

what am i to do? i went into the SUA/NAT option in the Netgear browser configuration and even set the second box to port 21 and ip to my computer server (192.168.0.2) BUT noone can get in...

what do i need to do next?

thanks
0
chriss_co
Asked:
chriss_co
1 Solution
 
Dave HoweSoftware and Hardware EngineerCommented:
ftp is a complex protocol

basically, inbound ftp initiates on port 21 - the "control channel" but actual data such as directory listings and file transfers are made on "ad hoc" connections.

for "active" ftp, those connections will be made to ports on the client machine from port 20 on the server - the ports on the client being chosen by the client software

for "passive" ftp, your server is supposed to volunteer ports on its range which will then be connected to by the client. if you wish to support "passive" ftp, you have to configure your ftp server to use a predetermined range of port addresses (I use 10000-10029) and forward those ports to your server too in the netgear router.

ftp is a complex protocol to start out on support for though - have you already set up http and/or ssh?
0
 
allrCommented:
For example, Zyxel routers have configured in the "filter set configuration", the access on port 21, 80,... is denied. maybe by netgear it is the same...
0
 
smallbeeCommented:
three solutions:

1) get a router that can setup a range of ports to be opened, like linksys router does),  u might want to open a port range but not a good choice for security.

2) open the PASV port on FTP server setting
u can fix this by setting up a port range (say, 2100-2100, so just one single port) for PASV in ur Ftp server software (like Serv-U FTP )", open 2100 port on router. Done!

Also check on this: http://www.jsifaq.com/SUBJ/tip4700/rh4753.htm

3) tell ur users to use browser to connect ur FTP server: http://username:password@domain.com, or tell ur user to  disable PASV mode setting on FTP clients




0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
chriss_coAuthor Commented:
Thanks for the responses..

I changed my FTP port to 4020 and a client was able to connect.. but he doesn't see any files

im wondering if this is because of my ftp server program or is it still a problem with my router?
0
 
smallbeeCommented:
did u put any files in the specify folder

and allow the FTP server setting that to read/write, broswe, delete, etc.

try with a administrator account of the FTP server... and if u see the files... then it must be the rights of the users

0
 
chriss_coAuthor Commented:
yes.. there are files in the folder.. and yes the user has all privileges..

i even tried a different ftp server program and the same result

i also tried giving the client an admin account

also for whatever reason "\" is still listed as my current directory.... (even though its not supposed to be)
0
 
chriss_coAuthor Commented:
yes.. there are files in the folder.. and yes the user has all privileges..

i even tried a different ftp server program and the same result

i also tried giving the client an admin account

also for whatever reason "\" is still listed as my current directory.... (even though its not supposed to be)
0
 
chriss_coAuthor Commented:
ok.. heres what ive found out so far

my friend who can connect but cant see files also has a router..

another friend of mine without a router can connect and can see files..

so this double router thing may be the cause
0
 
smallbeeCommented:
i had that issue b4.. but it should not be double router problem... have u tried to restart the FTP services or restart ur computer. may be the cache, try to clean it up

try it... also try to login like this \domain\username as the username for ftp login
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now