Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Apache and IIS on the same machine

Posted on 2003-03-05
5
Medium Priority
?
282 Views
Last Modified: 2010-04-20
Hi,

I am trying to run Apache and IIS on my home PC, so I can use Apache to run my PHP scripts and IIS to run my ASP scripts. This purely for my own development use.

I installed IIS first and then Apache. They are both using the same port 80. They seem to work ok-ish, but ive noticed a problem that when I have stopped IIS and started Apache as a service, then i load IE and type in http://localhost it says "Forbidden, Permission denied" but when i enter in a filename with the .php extension it runs that file fine. it just doesnt accept the http://localhost url.

With IIS running, I type in http://localhost into IE and it displays the correct Microsoft IIS info. Now I know from previous experience that with Apache running when localhost is typed in it should display the Apache server info page - this is not the case.

Now Im not sure if this will cause me problems in the future which is why I want to ask if anyone has both IIS and Apache successfully set-up on their machines!?

Hope someone can help
Thanks
Laura
0
Comment
Question by:janevok
2 Comments
 
LVL 2

Accepted Solution

by:
hawkers earned 120 total points
ID: 8071396
Hi janevok

Regarding the problems you have with IIS and Apache, I think it is all because you are using the same port number for both services. I recommend that use 80 for 1 webserver and 81, or 8080 or something else for the other web server.

You can change this in the IIS admin console or editting the httpd.conf file in the your APACHEINSTALLDIR/conf/httpd.conf and find the Port Number configuration parameter.

You will have to restart each web server, or even reboot your machine to ensure that your web apps work correctly.

Regarding the localhost problem, this refers to the loopback IP address which is fixed to 120.0.0.7 so if you use the same port number for web server and you are accessing the web server on your via the browser, you will sure to have confliction issues.

So when you change your port number you can access your webapp as follows

http://120.0.0.7:80/youraspwebapp or http://localhost:80/youraspwebapp (for IIS)

http://120.0.0.7:81/yourphpwebappor http://localhost:81/youraspwebapp  (8080)(for Apache)

Or visa-versa depending on how you want to configure your web servers.

I hope this helps

hawkers
0
 
LVL 3

Expert Comment

by:jayrod
ID: 8153243
apache also has a configuration to allow directory browsing.. search the httpd.conf file for it
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction This article explores the design of a cache system that can improve the performance of a web site or web application.  The assumption is that the web site has many more “read” operations than “write” operations (this is commonly the ca…
When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
Screencast - Getting to Know the Pipeline
Is your OST file inaccessible, Need to transfer OST file from one computer to another? Want to convert OST file to PST? If the answer to any of the above question is yes, then look no further. With the help of Stellar OST to PST Converter, you can e…
Suggested Courses
Course of the Month11 days, 6 hours left to enroll

572 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question