?
Solved

Doing ssh-keygen -e id_dsa_2048_a imposes carriage return

Posted on 2003-03-05
8
Medium Priority
?
573 Views
Last Modified: 2012-06-27
Hi,

This seems to be an oddball problem which I cannot seem to find a solution for.

I'm currently running:
ssh: SSH Secure Shell 3.2.3 on i686-pc-linux-gnu
on
Linux hostname 2.4.18-14 #1 Wed Sep 4 13:35:50 EDT 2002 i686 i686 i386 GNU/Linux (Redhat 8.0 fresh install)

Problem is that after having created an ssh pub/private key and setting the passphrase, I'd like to change the passphrase.

I enter command "ssh-keygen -e id_dsa_2048_a" and enter my passphrase, but the system seems like it adds an additional carriage return!  So I can't even answer the question "...edit key..." and therefore can't change my passphrase!  Works on Solaris however.

Passphrase needed for key "2048-bit dsa, user@hostname, Wed Mar 052003 10:34:10 -0800".
Passphrase :
Do you want to edit key "2048-bit dsa, user@hostname, Wed Mar 052003 10:34:10 -0800" (yes or no)?
Aborted by userKey unedited and unsaved.


0
Comment
Question by:blee73
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 
LVL 20

Expert Comment

by:Gns
ID: 8078701
Ehm, have you installed the commercial ssh product?
The ssh-keygen you'd tend to get on a vanilla RH8 is part of OpenSSH_3.4p1, and that has a completely different meaning for the options to ssh-keygen (-e converts the keyring to SECSH format:-).

Might explain the resounding lack of response:-).

If it is the commercial ssh, I'd suggest you make a formal bug-report to them.

-- Glenn

0
 

Author Comment

by:blee73
ID: 8082298
Yes, forgot to mention it is commercial SSH product.  I thought it may be something with the term setting that can cause this, but I doubt it.
0
 
LVL 20

Expert Comment

by:Gns
ID: 8087030
If so, it would be in how the application turns off/on echo and/or cooked/uncooked/semicooked mode, most likely.

But more likely this is a genuine bug, where the first <Enter> is interpreted once to many:-).

The "Aborted..." bit looks a bit ... funny.
I think I have a demo ex of commercial SSH around somewhere.
If you like, I can try recreating your problem. It would have to wait till after the weekend though.

-- Glenn
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
LVL 20

Expert Comment

by:Gns
ID: 8087076
Hmmm, two things

Shouldn't "ssh-keygen ...." actually be "ssh-keygen2 ...."

What happens if you specify the passphrase with the -p "your phrase" option? Less secure, but well, do it at runlevel 1 then;-).

-- Glenn
0
 

Author Comment

by:blee73
ID: 8100512
Yes, have tried both ways prior to your suggestion.  The answer is no, it does not work.  ssh-keygen2 and ssh-keygen results in the same.  I was thinking along the lines where it may have been a stty setting, but now I'm pretty sure its a bug.
0
 
LVL 20

Accepted Solution

by:
Gns earned 800 total points
ID: 8101369
With the proliferation of OpenSSH in the linux world, they might get less than good coverage/testing.

So even if you specify the -p "passphrase", it "skips past" the next interraction?

Sound like a bug... You should report it:-).

-- Glenn
0
 

Expert Comment

by:CleanupPing
ID: 9087784
blee73:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
 
LVL 2

Expert Comment

by:TheWeakestLink
ID: 9286886
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:
Accept comments from Gns as answer
Please leave any comments here within the next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

TheWeakestLink
EE Cleanup Volunteer
0

Featured Post

Use Case: Protecting a Hybrid Cloud Infrastructure

Microsoft Azure is rapidly becoming the norm in dynamic IT environments. This document describes the challenges that organizations face when protecting data in a hybrid cloud IT environment and presents a use case to demonstrate how Acronis Backup protects all data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The purpose of this article is to demonstrate how we can upgrade Python from version 2.7.6 to Python 2.7.10 on the Linux Mint operating system. I am using an Oracle Virtual Box where I have installed Linux Mint operating system version 17.2. Once yo…
In the first part of this tutorial we will cover the prerequisites for installing SQL Server vNext on Linux.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Suggested Courses
Course of the Month10 days, 1 hour left to enroll

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question