?
Solved

Set up RIP w/ Cisco 2500, serial interfaces

Posted on 2003-03-05
34
Medium Priority
?
580 Views
Last Modified: 2008-03-17
Hi all

I have 3 Cisco 2500 connected as follow
-------
Router1
serial0 DTE
192.168.1.1
-------
|
-------
192.168.1.2
Serial0 DCE
Router2
Serial1 DTE
192.168.2.1
-------
|
------
192.168.2.2
Serial0 DCE
Router3

I'm setting these up for a class project and trying to make them send RIP updates. I'm having problem with line encapsulation protocol.

I start out using HDLC but keep on getting "Serial0 is up, line protocol is down"

I tried to switch to Frame-Relay, but only got one of them to send updates. Below is my config for the serial0.

interface Serial0
 ip address 192.168.1.1 255.255.255.0
 ip rip send version 1
 encapsulation frame-relay IETF
 loopback
 autodetect encapsulation ppp
 no fair-queue
 frame-relay map ip 192.168.1.1 100 broadcast
 frame-relay interface-dlci 100


I'm guessing my problem lies somewhere in the DTE, DCE business. This is my first time touching Cisco routers so please go slow on your comments =).
0
Comment
Question by:1ce
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 17
  • 9
  • 7
  • +1
34 Comments
 
LVL 5

Expert Comment

by:rrhunt28
ID: 8074429
Did you set the clock rate on the serial interfaces?

router(config)#int s0
router(config-if)#clockrate 56000

It is a good practice to set the clock rate on all serial interfaces, however only the DCE will actully take them.  
0
 
LVL 3

Author Comment

by:1ce
ID: 8074567
k, i set the clock rate, but still the same =(, here is the debug on the one that die, hope it help


%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up
RIP: sending v2 update to 224.0.0.9 via Serial0 (192.168.1.2)
     192.168.1.0/24 -> 0.0.0.0, metric 1, tag 0
%FR-5-DLCICHANGE: Interface Serial0 - DLCI 100 state changed to INACTIVE
%FR-5-DLCICHANGE: Interface Serial0 - DLCI 100 state changed to DELETED
----------------------------------
config:
interface Serial0
 ip address 192.168.1.2 255.255.255.0
 encapsulation frame-relay IETF
 loopback
 no fair-queue
 clockrate 56000
 frame-relay map ip 192.168.1.2 100
 frame-relay interface-dlci 100

I have no idea why it sending v2 rip to 224.0.0.9??

0
 
LVL 5

Expert Comment

by:rrhunt28
ID: 8074666
On these routers are you actully running frame relay and stuff over them or are they just for lab work?  
and you set your rip and your networks?

router(config)#router rip
router(config-router)#network xxx.xxx.xxx.0
you set one network number for each network attached using its broadcast number.
0
Building an interactive eFuture classroom

Watch and learn how ATEN provided a total control system solution including seamless switching matrix switch, HDBaseT extenders, PDU, lighting control to build an interactive eFuture classroom.

 
LVL 3

Author Comment

by:1ce
ID: 8075123
rrhunt28, this is purely for playing around, not for real network, and yes i already setup the routing stuff

router rip
 version 2
 redistribute connected
 network 192.168.1.0
!
0
 
LVL 5

Expert Comment

by:rrhunt28
ID: 8075175
maybe it would help me, and others who know more about it than me, if you posted your running config.  Just take out passwords and Ip's.
0
 
LVL 3

Author Comment

by:1ce
ID: 8075456
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Modesto
!
!
ip subnet-zero
!
!
bridge irb
!
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 ip address 192.168.1.1 255.255.255.0
 ip rip send version 1
 encapsulation frame-relay IETF
 autodetect encapsulation ppp
 no fair-queue
 frame-relay map ip 192.168.1.1 100 broadcast
 frame-relay interface-dlci 100
!
interface Serial1
 no ip address
 shutdown
!
router rip
 version 2
 redistribute connected
 network 192.168.1.0
!
ip classless
ip route 192.168.1.0 255.255.255.0 192.168.1.2
ip route 192.168.2.0 255.255.255.0 192.168.1.2
ip http server
ip pim bidir-enable
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
cdp timer 5
route-map map permit 1
!
snmp-server community public RO
!
line con 0
line aux 0
line vty 0 4

 login
!
end
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 1440 total points
ID: 8075485
If you want to keep the frame-relay encapsulation on the interface, you can force them up by turning off lmi. To turn off the lmi keepalives:
!
Interface serial 0/0
no keepalive
!

You're sending out a RIP update as soon as the line comes up, but as soon as it misses the keepalives, it drops again. Turning off the keepalives should keep them open. Use the same DLCI number at both sides

> have no idea why it sending v2 rip to 224.0.0.9??
RIPv2 uses Multicast instead of broadcast


0
 
LVL 3

Author Comment

by:1ce
ID: 8075493
I think i found the problem but i'm not quite sure how to fix it, it seem like they both on DTE???

---------------------------------
Modesto#sh frame-relay pvc

PVC Statistics for interface Serial0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          0            0            1            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = DELETED, INTERFACE = Serial0

  input pkts 0             output pkts 0            in bytes 0
  out bytes 0              dropped pkts 0           in FECN pkts 0
  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0
  in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0
  pvc create time 03:40:20, last time pvc status changed 00:05:34
----------------------------------------
Fresno#show frame-relay pvc

PVC Statistics for interface Serial0 (Frame Relay DTE)

DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = DELETED, INTERFACE = Serial0

  input pkts 0             output pkts 0            in bytes 0
  out bytes 0              dropped pkts 0           in FECN pkts 0
  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0
  in DE pkts 0             out DE pkts 0
  out bcast pkts 0          out bcast bytes 0
  pvc create time 03:35:43, last time pvc status changed 00:07:27
Fresno#
0
 
LVL 5

Expert Comment

by:rrhunt28
ID: 8075519
It looks like with the ip route commands you create a static entry.  I am not sure, but that might be your problem.  You are getting into stuff I have not delt with.  I am sure someone else will be along soon to help, Irmore or whatever is good with this stuff.
0
 
LVL 5

Expert Comment

by:rrhunt28
ID: 8075530
LMAO, as soon as I add an update he shows up and puts in a post.  
0
 
LVL 3

Author Comment

by:1ce
ID: 8075584
Irmoore, it seems that the keep alive thing was it. The routers are happyly ripping. Does that fact that they both on PVC DTE matter?
0
 
LVL 5

Expert Comment

by:rrhunt28
ID: 8075609
Told ya he was good.
0
 
LVL 5

Expert Comment

by:rrhunt28
ID: 8075619
Told ya he was good.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8075686
Frame relay is always DTE, is is a logical thing that does not have to do with the physical interface being DTE or DCE.
0
 
LVL 5

Expert Comment

by:rrhunt28
ID: 8075715
Well, I personaly never quite understood the whole DTE v. DCE lecture.  I just said ok, set the clock rates and go....
LOL
0
 
LVL 3

Author Comment

by:1ce
ID: 8075745
another newbies question why i'm at it. I put in a few static route, how do i delete them ?
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8075771
just use 'no' in front of it.

i.e.
If you have this route:
ip route 192.168.1.0 255.255.255.0 192.168.5.1
then:
router#no ip route 192.168.1.0 255.255.255.0 192.168.5.1
router#

0
 
LVL 5

Expert Comment

by:rrhunt28
ID: 8075772
no ip route xxx i think
generally on a cisco to undo something you just put a no infront of what you did.  
0
 
LVL 3

Author Comment

by:1ce
ID: 8075966
my connection between the first pair is working fine, how ever the second pair of connection doesn't see each other at all, they definitely connected because when i bring one down the other went down, they would send rip and cdp to each other but would not receive? the config files are as follow

version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname Fresno
!
!
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 ip address 192.168.1.2 255.255.255.0
 encapsulation frame-relay IETF
 loopback
 no keepalive
 no fair-queue
 clockrate 56000
 cdp enable
 frame-relay map ip 192.168.1.2 100 broadcast
 frame-relay interface-dlci 100
!
interface Serial1
 ip address 192.168.2.1 255.255.255.0
 encapsulation frame-relay IETF
 no keepalive
 cdp enable
 frame-relay map ip 192.168.2.1 200 broadcast
 frame-relay interface-dlci 200
!
interface BRI0
 no ip address
 shutdown
!
router rip
 version 1
 network 192.168.1.0
 network 192.168.2.0
!
no ip classless
cdp timer 30
!
line con 0
line aux 0
line vty 0 4
 login
!
end

Fresno#

----------------------------------------
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Turlock
!
!
ip subnet-zero
!
!
!
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 ip address 192.168.2.2 255.255.255.0
 encapsulation frame-relay IETF
 no keepalive
 no fair-queue
 cdp enable
 frame-relay map ip 192.168.2.2 200 broadcast
 frame-relay interface-dlci 200
!
interface Serial1
 no ip address
 shutdown
!
router rip
 redistribute connected
 network 192.168.2.0
!
ip classless
ip http server
ip pim bidir-enable
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
no cdp advertise-v2
cdp timer 30
!
line con 0
line aux 0
line vty 0 4
 login
!
end
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8076657
Does fresno or modesto have the dce cable on it? Neither one is providing clocking
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8084272
Are you working yet?
0
 
LVL 3

Author Comment

by:1ce
ID: 8084744
Hi Irmoore, the router are as follow

router 1: modesto
serial 0: DTE

router 2: fresno
serial 0: DCE ---->serial0 on modesto
serial 1: DTE ----->serial 0 on turlock

router 3: turlock
serial 0:DCE
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8085224
same comment - neither fresno nor turlock is providing clocking on their connection
if turlock is dce, add clockrate xxxx
0
 
LVL 3

Author Comment

by:1ce
ID: 8086197
cool, right on the dot, i add 5 more point for another newbies question if you don't mind, so now they all route and see each other in CDP, how come I ping the one from another, i try debug arp but nothing show up?
0
 
LVL 7

Expert Comment

by:pedrow
ID: 8086509
the routers won't arp if there's already an arp entry in the arp cache.

start by turning on debug arp, clear the arp cache and try pinging again. see if you see different results.
0
 
LVL 3

Author Comment

by:1ce
ID: 8090350
pedrow, there is nothing in the arp cache and it still not sending out arp
0
 
LVL 3

Author Comment

by:1ce
ID: 8090443
pedrow, there is nothing in the arp cache and it still not sending out arp
0
 
LVL 3

Author Comment

by:1ce
ID: 8090487
pedrow, there is nothing in the arp cache and it still not sending out arp
0
 
LVL 3

Author Comment

by:1ce
ID: 8090495
ooops triple post, darn refresh button
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8090537
bad 1ce!

Do you have
no ip proxy arp on the Eth interfaces?

0
 
LVL 3

Author Comment

by:1ce
ID: 8090961
i dont have that, but i have ip classless, does that matter?
0
 
LVL 3

Author Comment

by:1ce
ID: 8106459
nm, i got it figured out
0
 
LVL 3

Author Comment

by:1ce
ID: 8106460
nm, i got it figured out
0
 
LVL 3

Author Comment

by:1ce
ID: 8106461
nm, i got it figured out
0

Featured Post

Supports up to 4K resolution!

The VS192 2-Port 4K DisplayPort Splitter is perfect for anyone who needs to send one source of DisplayPort high definition video to two or four DisplayPort displays. The VS192 can split and also expand DisplayPort audio/video signal on two or four DisplayPort monitors.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question