Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 603
  • Last Modified:

Trying to configure Cisco 1605 between cable modem and a Hub with 2 PC's

I am a beginer to the Cisco world and I'm trying to configure a 1605 so I can share internet access between 2 PC's.  Right now I have the Hub Uplink connected to Eth0 and the Cable modem connected to Eth1.

I've set the IP that the cable modem gave to me to the Eth1 port and I am able to ping that port but nothing past it.  I've also set the Eth0 port to 192.168.1.1/24.

Can you please help me get connected to the internet via the computers connected to the Hub.

Thanks
0
avfc88
Asked:
avfc88
  • 4
  • 3
  • 2
  • +2
1 Solution
 
sw1tch_n1njaCommented:
You have to setup nat on the e1 interface....since your new i recommend you download cisco config maker...
0
 
velimirmkdCommented:
You will have to NAT the traffic from yuor internal network to the Internet since the adresses you use internaly are not legal routable adresses on the Internet.  To do that firs define nat inside and nat outside interfaces.  The commands are "ip nat inside" and "ip nat outside".  Put your ethernet interface to the cable as outside, and your ethernet interface towards the lan as inside.  The only two more commands that you need in global config mode are:
default route 0.0.0.0 0.0.0.0 interface"the_one_to_cable" and ip nat inside source interface"the_one_to_LAN" overlaod

That is all you need.  Anyway about the cisco config maker.  It is a usefull tool, but if you want to learn how to configure cisco routers than you will have to do it from the command line :-)

Hope this helps
Velimir
0
 
avfc88Author Commented:
Velimir,
I've input the two NAT commands, thank you. But it does not like the other two commands;
default route 0.0.0.0 0.0.0.0 interface eth1
**it wants default route-map or router not route 0.0....

and
ip nat inside source interface eth0 overlaod
**it wants after source, list or route map or static not the interface
0
What Kind of Coding Program is Right for You?

There are many ways to learn to code these days. From coding bootcamps like Flatiron School to online courses to totally free beginner resources. The best way to learn to code depends on many factors, but the most important one is you. See what course is best for you.

 
velimirmkdCommented:
Sorry about that I should have done it more clearly. the commands are part descriptive part commands, my bad, here are the commands
ip route 0.0.0.0 0.0.0.0 "the_interface_to_cablemodem"
access-list 1 permit any
ip nat inside source list 1 interface "the_interface_to_LAN" overload

!!!The last two rows are one command

Hope this helps
Velimir
0
 
avfc88Author Commented:
Those worked, but still nothing to the internet.  The link lights are both green and on the front of the router green lights flashing on both ports.

I've tried pinging various gateways and nothing.  Is there an ipconfig/renew command  for the router?  This is what I have to do everytime I plug the cable modem into a different computer.

Not sure what to try now?
0
 
phatgreenbuds67Commented:
Are you set up with your provider with DHCP or do you have static IP's? You will need static if you want this NAT to work.  Also the default route statment needs to be the default gateway address of your providers network not your cable modem.  UNLESS this is a cable modem like a linksys or netgear that you have bought yourself.  If that is the case then this changes the picture completely.

0
 
velimirmkdCommented:
Hi,

I will have to disagree with phatgreenbuds67 on the DHCP, NAT issue.  You dont need a static IP to be able to NAT, that is why you specify your WAN interface.  That way whichever address you get assigned no matter by which DHCP is used as source address for the packets exiting the router.  I agree with the statement about the default gateway address, but it works just fine when you specify your default route throough your interface that is connected to the external network (in your case your ISP).  
avfc88, here is what you shoutd debug next.
First of all there is no ipconfig comand on the Cisco. So you will have to log on the router and try pinging from there both you internal network and internet.  That will give you an idea of where the packets get stuck.  Also you can issue the following command:
sh ip nat trans
That command will show you if your nat is working properly.
The last thing to do is to get on any of the PC's behind the router and try pinging first the internal interface of your router, then external (the one that is connected to the cable provider).  This should help you as well.

Well that is for now, hope I helped
Velimir
0
 
avfc88Author Commented:
The cable internet provider is set up with DHCP.  When I plug my different PC's into the cable modem they each grab a different ip address and a different default gateway. This is why I would imagine that the router would also grab a different ip and gateway ip and I'm not sure how to figure out what the ip is that would be set to the router after I power cycle the cable modem because the two ip's that are on the dif pc's are not working. (should i be setting the ip address on the outside int to the ip adddress from the cable modem and the default gateway from the cable modem to the defualt ip?)  
0
 
velimirmkdCommented:
avfc88,

You don't need to know the IP that is assigned to your router by the cable provider, and it can be different and changed every interval or whenever you power your router.  What you need to do is to set up a static private address on the ethernet interface that is connected to your LAN, for example 10.0.0.1/24.  Then since you have only two pc on the LAN set them up with static IPs too from the same range 10.0.0.X/24 and set them go default gateway 10.0.0.1.  Also set the DNS to be the DNS of your Cable provider, you may have to ask them for the IP, or you can find it out from the router.  Next set a NAT translation as explained before.  Set the default route as explained before, and the access list.  That is all you need to get routing and to get connected, nothing more.

Velimir
0
 
phatgreenbuds67Commented:
velimirmkd is absolutely correct. I have done this in the past but I had very flaky success with it. Often the router simply would not pick up the DHCP address unless I forced it by downing the interface or rebooting all together...granted I did not put a great deal of effort into making it work because 2 days later I had my static IP's assigned and had no use for this method. Nevertheless he is right in what he is telling you.
0
 
CleanupPingCommented:
avfc88:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 4
  • 3
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now