?
Solved

New to Cisco 1710 DSL Config

Posted on 2003-03-05
7
Medium Priority
?
801 Views
Last Modified: 2012-05-04
I've done lots of configs on 2600 and 1600 series routers that are using serial interfaces and leased lines but I'm new to setting up a DSL connection on a 1710 router. Have an ADSL connection through a Westell 2100 DualEthernet Modem that is in Bridging mode. The Westell's WAN IP address from the ISP was 66.54.x.x previous to switching to bridging mode and the LAN address is 192.168.1.254, which connects to the Cisco E0.
Cisco E0 is set to an IP of 192.168.1.1 and FE0 is set to 192.168.10.1.
What I don't get is setting up the connection. I know I have to set up a dialer1 group and set the 1710 as a PPPoE client. Should you not assign an IP to E0 and use a default route of 0.0.0.0 0.0.0.0 dialer1? Any help would be appreciated to get me started on this as my CCO login is screwed up and I can't see any configs to break 'em down and see what I'm needing to do. An entire config would be superb.
0
Comment
Question by:emeadows
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
7 Comments
 
LVL 7

Expert Comment

by:pedrow
ID: 8077531
It sounds as if you're just getting an ethernet feed to your e0.

I'm not familiar with the Westell, but is the Westell already doing your pppoe for you?

Why do you think you need a dialer interface?

Instead of:
ip route 0.0.0.0 0.0.0.0 dialer1

what happens if you do this:
ip route 0.0.0.0 0.0.0.0 192.168.1.254
?
0
 

Author Comment

by:emeadows
ID: 8079526
The IP route that you listed is the one I was currently trying to no avail. The Westell was creating the PPPoE connection for me before the 1710 was installed. According to Bellsouth, however, the Westell needed to be switched to bridging mode where I'm not sure that it does anymore and the Bellsouth guy didn't have the answer either.
0
 

Author Comment

by:emeadows
ID: 8083266
Here is a diagram of the setup as best I can do in text

LAN - 192.168.10.1(FE0)Cisco1710(E0)66.x.x.10 - 192.168.1.254 Westell Modem - 66.x.x.9(Gateway Address at Bellsouth)

Supposedly the 192.168.1.254 on the Westell should not matter to the connection as it should just be bridging past it. I do have to handle the PPPoE authentication myself. The config I have up to now is below. What am I missing here?

version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Raitech
!
no logging buffered
!
memory-size iomem 25
ip subnet-zero
!
!
ip name-server 205.152.37.254
ip name-server 205.152.144.235
ip dhcp excluded-address 192.168.10.1 192.168.10.10
!
ip dhcp pool raitech_dhcp
   network 192.168.10.0 255.255.255.0
   default-router 192.168.10.1
   dns-server 205.152.37.254 205.152.144.235
   lease 7
!
ip audit po max-events 100
ip ssh time-out 120
ip ssh authentication-retries 3
!
!
!
!
interface Ethernet0
 description DSL Interface on Router
 ip address 66.x.x.10 255.255.255.248
 half-duplex
 pppoe enable
 pppoe-client dial-pool-number 1
!
interface FastEthernet0
 ip address 192.168.10.1 255.255.255.0
 ip nat inside
 speed auto
!
interface Dialer1
 ip mtu 1492
 ip nat outside
 encapsulation ppp
 dialer pool 1
 ppp authentication pap callin
 ppp chap hostname inc5354@bellsouth.net
 ppp chap password 7 1541595554737874
 ppp pap sent-username xxxxxxx%bellsouth.net password 7 08721E1759405647
!
ip nat inside source list 1 interface Ethernet0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
ip pim bidir-enable
!
!
dialer-list 1 protocol ip permit
!
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end
0
The Ideal Solution for Multi-Display Applications

Check out ATEN’s VS1912 12-Port DP Video Wall Media Player at InfoComm 2017. Kerri describes how easy it is to design creative video walls in asymmetric layouts and schedule detailed playlists ahead of time with its advanced scheduling feature.

 
LVL 7

Accepted Solution

by:
pedrow earned 200 total points
ID: 8084709
You need to re-address your e0 to the same inside network as the westell...i.e. let the westell continue to do the pppoe for you. Either that or you'll have to basically get a new config for the westell so that all it's doing is terminating the dsl and let the cisco do the ppoe.

But right now, I'd leave the westell alone and try re-configuring the e0 interface thusly:

interface Ethernet0
description DSL Interface on Router
ip address 192.168.1.1 255.255.255.0
half-duplex

ip route 0.0.0.0 0.0.0.0 192.168.1.254

If the westell has already been re-configured as a bridge, it won't have any ip addresses...it merely acts as a termination device. In which case, you probably don't need to define a default route because the pppoe client probably will configure it by itself.

additionally, you probably in that case shouldn't have an ip address on the e0 interface at all...

and it would look thusly:

interface Ethernet0
description DSL Interface on Router
no ip address
half-duplex
pppoe enable
pppoe-client dial-pool-number 1

0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8442637
G'day, emeadows
It has been 57 days since you posted this question.
Do you still need help? Have you received enough information?
Can you close out this question?
Ways to close questions: http://www.apollois.com/EE/Help/Closing_Questions.htm
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8637106
emeadows,
No comment has been added lately (33 days), so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area for this question:

RECOMMENDATION: Award points to pedrow

Please leave any comments here within 7 days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

Thanks,

lrmoore
EE Cleanup Volunteer
---------------------
If you feel that your question was not properly addressed, or that none of the comments received were appropriate answers, please post a request in Community support (with a link to this page) to refund your points. http://www.experts-exchange.com/Community_Support/
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We've been using the Cisco/Linksys RV042 for years as: - an internet Gateway - a site-to-site VPN device - a leased line site-to-site subnet-to-subnet interface (And, here I'm assuming that any RV0xx behaves the same way as an RV042.  So that's …
Problem Description:   Couple of months ago we upgraded the ADSL line at our branch office from Home to Business line. The purpose of transforming the service to have static public IP’s. We were in need for public IP’s to publish our web resour…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question