File sharing problem between Windows 2000 and Windows XP

Hello,

I have the following network configuration

- ADSL modem IP 192.168.1.1
- 5 port switch
- 1 pc (Windows XP Home Edition) IP 192.168.1.2
- 1 laptop (Windows 2000 Prof)   IP 192.168.1.4

Installed protocols : TCP/IP (only protocol) on both PC's

I can access the internet from both PC's and I can ping both PC's. I have some shared folders on both PC's.

I can access my windows 2000 PC from my XP PC(go into IE; \\192.168.1.4 and I then have a login screen)

But I cannot access my XP PC from my windows 2000 PC (go into IE; \\192.168.1.2 and I then receive an error message : there is no logon server available ...). I have disabled the firewall (Zone Alarm) on my XP and there is no firewall on my Windows 2000.

Both PC's are configured as workstations and there is no domain server. Both PC's are not configured on the same domaine ("company name" for Windows 2000, "Workgroup" for XP). It does not seem to be an issue, as I can logon to my windows 2000 with my Windows XP)

There is also a web server running on XP and I can access it from Windows 2000 (http://192.168.1.2), works fine.

I have read several articles and FAQ on networking issues between 2000 and XP Home Edition, but my problem seems to be unique.

I cannot (should not) change the network setting on my Windows 2000, as I could have problems to connect to the network of my company afterwards.

Can anybody help me ?

Marcel
MFreyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dan_blagutCommented:
Hello
Try to use same user name and same password on both computers.
0
night_monkeyCommented:
try using the network setup wizard that came with the xp cd, if you haven't already.

here's a micrsoft link with the instructions:

http://www.microsoft.com/windowsxp/home/using/productdoc/en/default.asp?url=/windowsxp/home/using/productdoc/en/hnw_setupP.asp
0
ViTaMiNCommented:
have U installed file and printer sharing on both pc's ?
0
How do you know if your security is working?

Protecting your business doesn’t have to mean sifting through endless alerts and notifications. With WatchGuard Total Security Suite, you can feel confident that your business is secure, meaning you can get back to the things that have been sitting on your to-do list.

JivkoCommented:
Enable Guest Account on both PCs. Enable NetBIOS over TCP/IP.

Regards
0
acheltenhamCommented:
To the best of my knowledge the reason why you cant see the files on the XP systems cause it is how the operating system is setup you would have to be running an XP enviroment network ...or upgrade to XP Proffessional ..I had came across it on Microsoft website when it had first released XP home ..you would be able to ping and also perform other services like internet sharing but you wont be able to view the files on the system from the Y2k system trust me i tried....so upgrading to XP pro is your best bet
0
lrmooreCommented:
I think Jivko has the answer. Check the Win2k system and see if the Guest account is enabled. The XP will be disabled by default.
Netbios over TCP/IP is disabled by default on XP, enabled by default on Win2K.

Some more information:
--------------------
First and formost, make sure there is no firewall software running! XP has built in PFW.Turn off the Internet Connection Firewall ICF in the advanced settings for the Lan Connection. Check for Norton Internet Security AV/Firewall, BlackIce, ZoneAlarm, et al.
-------------
Next, check your XP networking setup:
http://support.chartermi.net/support/pipeline/windows/winxp_network.html
Although this link says to set netbios over tcp/ip to "default", follow the instructions below...
-------------
Turn on "Simple file sharing" on the XP machine. Open explorer, click tools, click folder options, click the view tab and scroll down until you see "Use simple file sharing" then check the box..
----------------
For the duration of testing, enable the Guest account on XP. If all works, you can deal with that issue later (username/passwords for everyone on every PC)
----------------
Client for Microsoft Networks needs to be the primary network logon for all other machines

http://www.wown.com/j_helmig/wxpwin9x.htm
----------------
All machines are in the same workgroup
----------------

Enable NetBios over TCP/IP in WIndows XP
Step 1: Turn On NetBIOS over TCP/IP
Click Start, click Control Panel, and then click Network and Internet Connections.
Click Network Connections.
Right-click Local Area Connection, and then click Properties.
Click Internet Protocol (TCP/IP), and then click Properties.
Click the General tab, and then click Advanced.
Click the WINS tab.
Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.
Click Close to close the Local Area Connection Properties dialog box.
Close the Network Connections window.

Step 2: Start the Computer Browser Service
Click Start, right-click My Computer, and then click Manage.
In the console tree, expand Services and Applications.
Click Services.
In the right details pane, verify that the Computer Browser service is started, right-click Computer Browser, and then click Start.
Close the Computer Management window.

References:
http://support.microsoft.com/default.aspx?scid=kb;en-us;318030
http://support.microsoft.com/default.aspx?scid=kb;en-us;314366
http://support.microsoft.com/default.aspx?scid=kb;en-us;315267
http://www.practicallynetworked.com/sharing/troubleshoot/slowbrowse02.htm
http://www.michna.com/kb/WxNetwork.htm

-----------------------------------------------------
BONUS TIP#1:

Speed up your browsing of Windows 2000 & XP machines AND Speed up viewing shared files across a network

Here's a great tip to speed up your browsing of Windows 2000 & XP machines.
Its actually a fix to a bug installed as default in Windows 2000 that scans shared files for Scheduled Tasks.
And it turns out that you can experience a delay as long as 30 seconds when you try to view shared files across a network because
Windows 2000 is using the extra time to search the remote computer for any Scheduled Tasks.
Note that though the fix is originally intended for only those affected, Windows 2000 users will experience
that the actual browsing speed of both the Internet & Windows Explorers improve significantly after applying it
since it doesn't search for Scheduled Tasks anymore.
Here's how :

Open up the Registry and go to :

HKEY_LOCAL_MACHINE/Software/Microsoft/Windows/CurrentVersion/Explorer/RemoteComputer/NameSpace

Under that branch, select the key :{D6277990-4C6A-11CF-8D87-00AA0060F5BF} and delete it.

This is key that instructs Windows to search for Scheduled Tasks.
If you like you may want to export the exact branch so that you can restore the key if necessary.

This fix is so effective that it doesn't require a reboot and you can almost immediately determine yourself how much it speeds up your browsing processes.

If you like you may want to export the exact branch so that you can restore the key if necessary.
This fix is so effective that it doesn't require a reboot and you can almost immediately determine
yourself how much it speeds up your browsing processes.


-----------------------------------------------------
BONUS TIP#2
http://is-it-true.org/nt/xp/atips/atips23.shtml
-----------------------------------------------------


0
MFreyAuthor Commented:
Thanks for your help, I updated my configuration (enaled netbios...) and the guest account on XP but it did still not work.

I tried another approach and created a mapping of a shared directory of XP on my windows 2000 (and specified the XP user and password) and it works. Does this make sense ?

Another problem is that my guest account is disabled on my Windows 2000 laptop (work laptop, cannot create new users) and Windows 2000 is in English and XP in French.

A new problem appeared, as I can no longer print from my Windows 2000 with the printer that is linked to the XP computer via USB. I worked before I tried to change some setting, any ideas ?





0
CleanupPingCommented:
MFrey:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
SpazMODicCommented:
PAQed, with points refunded (200)

SpazMODic
EE Moderator
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software Firewalls

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.