?
Solved

SAMBA CONFIGURING

Posted on 2003-03-06
9
Medium Priority
?
339 Views
Last Modified: 2010-03-18

Hi,

I have insatalled RedHat 8.0 on my machine. I have set up
SAMBA on my machine. It has got configured well withuot any problem. But hen I go to any windows machine and access there it asks for password. But I have not set any password.Pls any body help me .Wheather is it a problem in smb.conf or what else.The other OS is WINME
0
Comment
Question by:anilmpg
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
9 Comments
 

Expert Comment

by:eishv
ID: 8079281
on the samba server do -
useradd 'username'
passwd 'username'
enter and re-enter your chosen password
smbpasswd -a 'username'
enter and re-enter your chosen password

I had loads of problems with rh8. you may want to try trustix instead...

0
 
LVL 3

Accepted Solution

by:
naccad earned 100 total points
ID: 8083944
I am not 100% sure, but I know that on windows 95 and windows 98, you have to patch the registry to allow it to connect
to a samba machine.

another thing to consider, how did u set the share you
are trying to connect to, if u want everyone to access it
it should have a line that says

guest ok = yes
read only = no

tc
-nick

p.s. there is nothing wrong with RedHat, it's a great distribution, and changing your distribution is not a solution. and rmmbr that RedHat does not make Samba, they
only provide it, samba is made by the Samba Team at samba.org
who are not in any way related to RedHat Inc.
0
 

Assisted Solution

by:ken_330
ken_330 earned 100 total points
ID: 8087214
hi ,
 you encounter isnt a problem , it is just that the windows PC dont have an account with the Linux box.
Just go to the Linux Box , add an account using the file manager which is the simpliest way.Add the password when prompt , remember the password must be the same as the Windows PC which u want it to be logg in.Being done that,
u have created a unix user account similiar to one of your Window box.
  At the commnad line :
            smbadduer NameofWindowBox:NameofWindowBox
then , you would be prompt to give passwd
remember the password must be the same as the account you had just created ( also the same as the Windowbox Pc that u want it to be the client to logg in )

being done so,
            testparm at the command line to view whether samba is being successfully configured?

Now go to pico editor or gedit the file ( /etc/smb.conf )
remove the # sign in front of the # encrypted passwd
to enable it accepts encrypt passwd.Save on it ..
now u restart the samba by : samba restart  (at the command line )

Hope all well with this stage ! goodluck
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Expert Comment

by:erazo
ID: 8091351
Every Windows OS is slightly different. Read this excellent tutorial which worked for me:

http://www-1.ibm.com/servers/esdd/tutorials/samba/index.html
0
 

Expert Comment

by:illumnis
ID: 8092779
1. You need to configure the win me machine to login to your samba machine as a network client with a username and password when you boot up.

2. you need to configure your samba machune to add the user and password.(use the steps EISHV reffered to in one of the previous comments)

3. You may need to edit the following registry setting on your Win ME machine:

go under HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\VNETSUP and set DWORD EnablePlainTextPassword  1

And thats that!
0
 
LVL 2

Expert Comment

by:mjdme
ID: 8581064
make sure smb.conf file is setup correctly
http://us4.samba.org/samba/ftp/docs/htmldocs/Samba-PDC-HOWTO.html

edit your registry
http://www.wlug.org.nz/RequireSignOrSeal 

http://www.oreilly.com/catalog/samba/chapter/book/

also edit host and host allow file in samba and etc dir
0
 

Expert Comment

by:CleanupPing
ID: 9077725
anilmpg:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…
Suggested Courses

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question