Fading text problem!!

Hi, everyone:
    Can anybody help me with this problem? I can see the text fade during the design. But when I test the movie or export the movie as a .swf file, then I can no longer see the fading effect. However, if I export the movie as .AVI format then I can see the effect again.
    Can anyone help me with this problem please?! Thank you very much!!
s003hxyAsked:
Who is Participating?
 
henrywwConnect With a Mentor Commented:
that's could have something to do with the player ...
check if u have the latest from MM ...

see here
http://www.smartclever.net/example/flash/news_fader/news_fader.swf
http://www.smartclever.net/example/flash/news_fader/news_fader.fla


this is a news fader i did sometime ago for someone here ... i can see the text fading no problem, see if u can see it ... if not try updating ur player to 6.0.65 i think that's the latest

cheer
0
 
henrywwCommented:
hi s003hxy,

post ur code here so we know what happen exactly.

check if u have the fonts embeded if it is a dynamic or input box. is the textbox is under a mask?

what version of flash are u using?
MX or 5

give us more info then someone will come up with an answer real soon ... :)

cheers
0
 
s003hxyAuthor Commented:
I didn't use any code, since I am kind of new at this. I am using Flash MX. I converted the text box into a symbol, then change the alpha setting the motion tweening as it was shown in the tutorial. I didn't use any mask. The strange thing is everything looks great when I run it in the design view, but in the test movie and export movie of .swf format, I can still see all the movement of the text, but not the fading effect.

can anyone help me with this?
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
InnerChildCommented:
did you want somebody to look at your .fla and tell you what the problem is?

if so duane_jay@hotmail.com

and put in the subject Expert Exchange

LAter
0
 
henrywwCommented:
huh? ....
no ... thanks anyway InnerChild ... ha ha ha

u don't reading do u?

cheers
0
 
henrywwCommented:
oh sorry InnerChild ... i thought u were talking to me ... and of course not ... i didn't ask this question ... !!

LOL .. sorry ...

s003hxy please do so if u like :)
0
 
InnerChildCommented:
lol no worries

LAter
0
 
s003hxyAuthor Commented:
Hi, henryww:
     Thanks for the file. I could see the fading text in the .swf file, but I can't see the text at all when I use the test movie option to try to see the file. Do you know anything about this problem? Thanks for your time.
0
 
InnerChildCommented:
hmmm give you a list.  Some will be pretty obvious but hey.

1) The text and stage are the same colour
2) You might have some action that "fell" to the beginning of the script that won't let it work. or try this step by step

Write text on stage.
select text and convert to symbol (F8).
click on key frame 1 and in the properties menu select motion tween in drop down menu.
Click on text and choose color alpha and make it 0.
Click keyframe 15 and right click and choose insert key frame.
Click back on text and change alpha to 100

Thats it(Did it step by step myself).  It will loop unless you put a stop action at the last frame.  

Problem with flash sometimes if you don't know how to ask a question cause your not familiar with it, then we have just as hard as a time trying to figure the answer without a .fla or code.

Hope that helps

LAter
0
 
henrywwCommented:
u mean when u view the swf in the above link it is ok.
but when u download the fla then u can see it on stage??
0
 
InnerChildCommented:
I can verify that.  If you test it on stage it compalins that it can't find Error opening URL "news.txt" and if you create the file it comes up black with a invisible button on it.

LAter
0
 
s003hxyAuthor Commented:
Yes, I had the same problem with the news_fader.fla. Well, my problem is really actually very simple. Well, at least I feel it should be. The problem is this, when I create the fading effect on the stage, I can see the effect. However, when I use either control->test movie option or file->export movie, I don't see the fading effect anymore. I did try to update my flash play to the latest version, but the problem is still there. Any suggestions? Thanks a million.
0
 
henrywwCommented:
as for the example link u need the text file so it will work ... sorry .. i forgot about that ...
http://www.smartclever.net/example/flash/news_fader/news.txt
it is just like that.

download (copy & paste) the txt file and do it again.


ok . .there is no script ...
u have tween the movieclip to fade ...

on stage u can see it, u mean u move the play head manually ...

when play (export or in flash) it is invisible? or it doesn't fade?

click on the textbox and select dynamic, click embed font all characters and see what happen ...
0
 
henrywwCommented:
just a very very simple fade text here ...
http://www.smartclever.net/example/flash/fadeText/fadeText.zip

tell me what happen with this one ... @_@!
0
 
InnerChildCommented:
no problem.  Both the .fla would play and the .swf....maybe a longshot but if your publishing in flash MX you'll need the plug-in....MX should have installed it for you but maybe try that....  Are there other things you have tried to make and can't see?

LAter
0
 
henrywwCommented:
errr ... me???

... i am ok ... for me,
everything works

s003hxy  might have ...
0
 
InnerChildCommented:
oops now its my fault for not remembering who posted lol

LAter
0
 
henrywwCommented:
;)
0
All Courses

From novice to tech pro — start learning today.