?
Solved

linux network bridge/router

Posted on 2003-03-06
2
Medium Priority
?
249 Views
Last Modified: 2010-03-18
im trying to get my linux box to act as a website host and a bridge to my wireless network, i got the hardware to do it, just need help on configuring everything right. running redhat8
0
Comment
Question by:JTWolfman
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 8

Accepted Solution

by:
heskyttberg earned 60 total points
ID: 8087069
Hi!

Make sure iptables start at boot.
Create the file /etc/sysconfig/iptables
Which should conatin the following:
*nat
:PREROUTING ACCEPT [25196:1898884]
:POSTROUTING ACCEPT [14998:1131452]
:OUTPUT ACCEPT [43648:2908137]
-A POSTROUTING -o eth0 -j MASQUERADE
COMMIT
*filter
:INPUT ACCEPT [523751:223511834]
:FORWARD ACCEPT [49970:22849700]
:OUTPUT ACCEPT [585526:308231978]
COMMIT

This is if eth0 is your outside interface, change it for whatever net interface you use for outside.

Setup eth0 and eth1 as you like either by netconfig, linuxconf or manually, your choice.

If you're not using DHCP on your eth0 interface configure DNS servers and everything.

Setup a caching DNS on your linux box.
This is done by simple rpm -ivh named-x.x.x.i386.rpm, if you don't allready have done that.
Also install rpm -ivh dhcp*
So you get both dhcp client and server.
Edit /etc/dhcpd.conf:
ddns-update-style ad-hoc;
subnet 192.168.10.0 netmask 255.255.255.0 {
# --- default gateway
        option routers                  192.168.10.1;
        option subnet-mask              255.255.255.0;

        option domain-name-servers      192.168.10.1;

        option time-offset              -18000; # Eastern Standard Time

        range dynamic-bootp 192.168.10.100 192.168.10.200;

        default-lease-time 21600;
        max-lease-time 43200;

        # Fixes address for windows domain/file server
        host mysrv {
                next-server dragonsrv;
                hardware ethernet 00:00:00:AA:AA:AA;
                fixed-address 192.168.10.20;
        }
}

This is only an example how you can set it up, change ip and range to anything you want.

Now on all server on your inside interface just go and click use DHCP.

Hope this helps.

Regards
/Hans - Erik Skyttberg
0
 

Author Comment

by:JTWolfman
ID: 8324331
thanks for the help man
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…
Suggested Courses

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question