?
Solved

Detecting Primary Master: --none

Posted on 2003-03-06
16
Medium Priority
?
3,639 Views
Last Modified: 2007-12-19
Upon startup, the boot screen indicates no Primary or Secondary Master hard drives detected. I use auto detect in the BIOS. (My primary is a WD 100 GB and Secondary a Maxtor 60 GB. I then cycle power and on the second or third try, it boots as normal. It does this maybe every third startup.  The system runs W2k and its an Asus A7M266 motherboard with 1.33GHz Athlon uP and 512 MB of DDR.  I have not dicked with any of BIOS settings or voltages and do not overclock.
Any ideas??
0
Comment
Question by:CubicalQuad
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
  • 3
  • +5
16 Comments
 
LVL 1

Expert Comment

by:Baddog
ID: 8084032
Cubical,,,
     You may have to go into your BIOS and if quick POST is enabled, disable it.  POST will do a long memory check and it will give your hard drives the time needed to synchronize prior to being auto detected. Try this and let me know what happens.

BDog
0
 
LVL 16

Accepted Solution

by:
Kyle Schroeder earned 200 total points
ID: 8084052
I seem to recall reading some reports of conflicts between certain Maxtor and WD drives, but not recently...Are you using the 80wire cables on the drives (for ATA66/100/133 speeds) and if so, have you tried a different cable?  I assume you're not using Cable Select mode on the drives...?  Have you updated your BIOS?  Also, check your BIOS for an option "Wait for IDE HDD Seconds" (or something to that effect) and increase the number by 1 or 2; this makes the system pause a few seconds while starting so that the IDE drives can get fully spun up.  Have you tried connecting either drive as Master on the secondary IDE channel?

If none of that seems to help, I might suspect your mobo is failing or possibly even a power supply issue if the drives aren't getting enough power from your power supply.

-dog*
0
 
LVL 1

Expert Comment

by:lekan
ID: 8084713
Cehec if Yr drives have jumpers which determine master/slave function. For the speed reason, i do connect each drive as a master on separate  ide channel, and slave positons are used for cdr/dvds. The factory setup on HDD is normaly as the master, so if You connect both drives on the same channel/ cable there is high probability of the confilict between hdds and Y'll get proper detection only if the primary positoned master starts before the wrong hdd. I beleive that Y'll correct the problem using both hdds as masters but on two different IDE channels as I described above

lekan
0
Bringing Advanced Authentication to the SMB Market

WatchGuard announces the acquisition of advanced authentication provider, Datablink, with one mission – to bring secure authentication to SMB, mid-market, and distributed enterprises with a cloud-based solution, ideal for resale via their established channel & MSSP community.

 
LVL 1

Expert Comment

by:lekan
ID: 8084726
P.S. Have You installed large HDDS drivers in accordance with the factory instructions ?
0
 
LVL 10

Expert Comment

by:kiranghag
ID: 8085634
>>>P.S. Have You installed large HDDS drivers in accordance with the factory instructions ?
this would not change the bios behaviour at startup...
0
 

Expert Comment

by:ethang5
ID: 8089259
Cubical,
  There is a pin setting on your HD that controls delayed start. (Usually the 4th set on the 5 pin set. Your bios is polling the HD while it's disks are still motionless-before it has gotten the command to start. The HD cannot get the disks up to operating rev speed in time.
It works after the 3rd or 4th try because by then the HD disks are still turning when you turn the unit on again and it takes less time to get up to speed then.
Answer 1; disable the delay feature on your master HD by removing the pin. If this feature is default, you will have to place a pin. Find out from your manufacturer which pin it is.
Answer2; Increase the POST time. Just disable the "Fast Post" option in your bios.
Good Luck!
0
 
LVL 45

Expert Comment

by:patrickab
ID: 8089505
If the bios is only allowing the m/c to boot up the second or third time of trying I suggest that cmos battery is retaining just enough charge after several goes at starting but not long enough between each time the m/c is switched on to work first time. Try replacing the cmos battery - costs about USD3. If after that your m/c boots up OK then you won't need to up-date your bios but if not then you will need to specify in it how your machine is configured.



0
 

Author Comment

by:CubicalQuad
ID: 8094710
Sorry for delay getting back....
I can state what it is NOT...
it is not cable select, it is not cmos battery,
it is not the HD since my original C drive was the 60GB Maxtor (by itself) and I thought it was failing, which is why I got the 100 GB WD ($89 @ BestBuy). Both HD's are not found in autodetect mode when it happens.  Based on a sampling of one cold boot, the disabled fast POST worked, but I don't like it because I must esc. memory check and then select which device to boot from....very klutzy.  

Haven't tried ethang5's suggestion of disabling delayed start.  

..jury is still out.
0
 
LVL 1

Expert Comment

by:Jimbo99
ID: 8098775
Seen this before.  Just ensure that the jumpers on the drives show one as master and the other as slave.

Best bet is to move one of the drives to a different channel.  If you have a burner on  your 2nd channel put it to master and the hd to slave.
0
 
LVL 1

Expert Comment

by:lekan
ID: 8101358
I cannot see if You tried to connect HDDS on two cables as master drives. As I suggested earlier. Have U tried to work with a single HDD, and do U have the same detecting problem ?


lekan
0
 

Author Comment

by:CubicalQuad
ID: 8102831
I think Dogztar has gotten it, but want to try one more day on a cold start.  The solution was simple....I flashed an update on my BIOS from Asus.  
0
 
LVL 16

Expert Comment

by:Kyle Schroeder
ID: 8103195
Just let us know...

-dog*
0
 

Author Comment

by:CubicalQuad
ID: 8111357
Updating the BIOS was the answer...I didn't consider it because the system was stable for over a year, but don't knock success.
0
 
LVL 16

Expert Comment

by:Kyle Schroeder
ID: 8111688
So that fixed your problem...why the C grade???

-dog*
0
 

Author Comment

by:CubicalQuad
ID: 8113398
Thanks for the help, and I don't want to seem ungrateful, but you offered 7 possible solutions, of which 6 were N/A or already ruled out by myself. Updating the BIOS isn't rocket science, but I DID overlook it, so thus the "Average" grade.  
0
 
LVL 16

Expert Comment

by:Kyle Schroeder
ID: 8114246
Hmm, well sorry for providing more than one option.  Next time I'll just propose one wrong answer at a time and suggest a new one after it is ruled out.

-dog*
0

Featured Post

Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Monitor input from a computer is usually nothing special.  In this instance it prevented anyone from using the computer.  This was a preconfiguration that didn't work.
If you're a modern-day technology professional, you may be wondering if certifications are really necessary. They are. Here's why.
Sometimes it takes a new vantage point, apart from our everyday security practices, to truly see our Active Directory (AD) vulnerabilities. We get used to implementing the same techniques and checking the same areas for a breach. This pattern can re…
In this video, Percona Solutions Engineer Barrett Chambers discusses some of the basic syntax differences between MySQL and MongoDB. To learn more check out our webinar on MongoDB administration for MySQL DBA: https://www.percona.com/resources/we…

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question