?
Solved

smaba config+smaba receive

Posted on 2003-03-06
14
Medium Priority
?
810 Views
Last Modified: 2008-02-01
i have configured samba in my redhat8.0 .now my computer is visible from the winxp's network neighbourhood but i can't open it.it gives error like specified computer not found or something like u maynot have the permission .i even tried giving my ipaddress in the addressbar.still it not works.
     another problem i can net send to other computer but can't recieve the same from others .i am using linpopup .
how can i  fix it ..any suggestions ...


below is my smb.conf file
****************************
[global]

   workgroup = MSHOME
   netbios name = tangent

   server string = arindam's samba

   message command =/usr/bin/LinPopUp  "%f" "%m" %s; rm %s

   log file = /var/log/samba/log.%m

   max log size = 50
   
   security = user
   
   socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
   
   name resolve order = host wins lmhosts bcast
   
   wins server = 172.31.1.11
   
   dns proxy = yes
   
   
[share]
   comment = arindam'samba server
   path = /home/arindam/rpms
   public = yes
   writable = no
   write list = @staff

[uploads]
   path = /home/arindam/uploads
   public = yes
   only guest = yes
   writable = yes
   printable = no


                            arindam
0
Comment
Question by:Arindam_Biswas
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
  • 2
  • +4
14 Comments
 
LVL 6

Expert Comment

by:mbarbos
ID: 8084381
take out the wins server and dns proxy first and see how it goes. (Do you really have awins serve at that IP ?)
Do you have a PDC in the domain ?
0
 
LVL 17

Expert Comment

by:psimation
ID: 8086498
Have you configured samba users on the Linux box?
You need to create a /etc/samba/smbpasswd file and then give passwords to samba users.

Do this:

cat /etc/passwd | mksmbpasswd.sh > /etc/samba/smbpasswd

Now do
smbpasswd xxx

where xxx is one of the Linux system users that was already on the system.

Now restart samba

service smb restart

Once you did that, you can go back to the Windows box and click on the Linux box. It should come up with the login box asking for username and password. Give the username and password as we discussed above.
It should take you to that user's home folder on the Linux box.

If that works, you can add more users and more shares to smb.conf and restart smb
0
 

Expert Comment

by:sixsixeight
ID: 8086660
Moments ago, literally, I just solved the exact same problem you are having on my own network. In the 3 books on Linux I've read previously, I was unable to find the exact steps to correct the exact problem I was having, which is, coincidentally, the exact same problem *you* are having.  I was able to find these directions in the actual Red Hat manuals.  They come with Red Hat 8.0 Professional and are also available online (and, in the "docs" ISO, downloadable with your distribution).  The solution provided by psimation is correct, but, a more thorough explanation can be found in the aforementioned Red Hat manuals, specifically, "The Official Red Hat Customization Guide", chapter 16 (Samba), the section entitled "Configuring Samba."  The actual page can be found at http://www.redhat.com/docs/manuals/linux/RHL-8.0-Manual/custom-guide/s1-samba-configuring.html.
I hope that documentation provides a solution for you.  

To whom it may concern:  This is my first post at Experts Exchange.  If I have violated any proper procedures/etiquitte by linking/referring to an outside source or by elaborating on an answer provided by someone else, please let me know.  
0
Tutorials alone can't teach real engineering

So we built better training tools.

-Hands-on Labs
-Instructor Mentoring
-Scenario-Based Tests
-Dedicated Cloud Servers

All at your fingertips. What are you waiting for?

 
LVL 17

Expert Comment

by:psimation
ID: 8086983
sixsixeight
I think I speak for many others if I say: " You are by far the most considerate and well educated in netiquette 'newbie' to EE that I have ever come accross".

To my knowledge, you certainly have not violated ANY procedures etc with your comment, actually, you have done exactly what you should.
It is certainly not considered "rude" or "offensive" to elaborate on other comments or to link to other sites/resources, not even if your comment differs from previous comments.

The whole idea is to provide the owner of the question with as much information as possible in order for them to come to a solution, and it is and should be left to the owner of the question to decide which comment(s) helped him most to solve his/her problem.

EE can sure use with more users such as yourself. Welcome here, and hope we can help many more people with a collaboration of our knowledge.
0
 

Expert Comment

by:ken_330
ID: 8087157
hi
  psimation is correct about that , but may be too difficult for a newbie to understand that if he never undergo any information about setting smbpasswd.
  To make it simple , just follows these

  Logg in as Root in your Linux system.
At the command prompts, adduser Test   (example)
                        passwd Test    (example)

Being done so , meaning u have created a new user called Test .

 Then , now at the command line type: smbadduser Test:Test
 you would be prompt for smbpasswd ; then just key in the passwd of the Test client to be logginto.

Being done so , you have created a new smbuser.

Now , use smbclient -L Test  at the command line .u would see a list of shares item.
For your client PC to logginto samba , use the name of that XP pc for the name Test and the passwd would be the same for the XP login passwd.You should be able into its home directory. For further shares, use SWAT to create
Most of the shares that cannot be allow to be access,is because the permission setting is not set properly.

Good Luck !
0
 

Expert Comment

by:ken_330
ID: 8087169
Pay attention to the smbadduser Test : Test , its a colon , here i make it with an additonal space is to allow u see the colon visibly.In the actual command line there is no space between the colon.


Patch note
0
 

Author Comment

by:Arindam_Biswas
ID: 8089806
i have tried everything u have said but still can not net send from any other winxp computer on the lan .i even tried giving my ip address in the net send command still it can't recognize my computer .and i am able to ping to my computer from others only when i specify the ip address. but computer is visible in the network neighbourhood window ofwinxp but  not able to see the shares not even asking for login and password ........
0
 

Expert Comment

by:sixsixeight
ID: 8096699
Does your XP username exist on your Linux computer?  I'm almost positive that you've got to be logged into an account on your Windows computer that has an identical username/password pair on your Linux computer.  So, if your Windows username/password pair is "arindam/secretcode", there must be adentical username pair (arindam/secrectcode) on the Linux computer...and added via smbpassword.  I think I read some documentation that specifically stated that, but, unfortunately, I can't find it right now, so, I'm just going from memory.  I do remember, though, that when setting up my Linux computer, I specifically created accounts with username/password pairs identical to my Winows 2000 accounts for this reason.  
0
 
LVL 2

Expert Comment

by:JesNoFear
ID: 8108385
on winxp, do you have any of the firewall options enabled, also are you using winxp home or pro? this makes a diffrence. I have not successfuly send a message to xp home edition from my 2k server, though i don't use that computer much. I personly like 2k, but what i am thinking is that xp home has net send blocked from recieving. you can try doing is from linux type in smbclient -M compsnameorip (without the \\) and see if it will let you send the message that way, if not then it is blocked by xp home.
0
 

Expert Comment

by:ken_330
ID: 8112624
hi what info i provided is quite accurate , and i feel that u arent paying attention to what i mentioned .Go backward and disable all firewall before trying to ping one another.If all firewall is disable and u still cant ping , meants u got a network problem.
0
 

Author Comment

by:Arindam_Biswas
ID: 8119872
i think i am not clear to some of u.i am no intention to build any server.i am in my instutition network.i am using winxp pro.anad as i have mentioned that i can ping if i give my ipaddress .but when i am giving my hostname ping can't detect it.if it was a firewall problem then i can ping to my computer from others when i give my ipaddress.
    again jesNofear i have no problem in send a winpopup message to all.but the inverse is the problem.in winxp it's giving the message alias is not found in the network.and onething in our lan there are other people having linux and swith problem in recieving netsend.
   i just want that i can recieve net send.
i think u all r little annoyed of me .sorry for that..
0
 

Expert Comment

by:ken_330
ID: 8142177
Hi ,
   No i m not annoyed , for i hope u goe thru what all guys here notes which all of us trying to help.
  Ok ,cut that crap,obviously your xp does not recongnised names , so i think its about the host not configured ,u
go to windows directory ( make sure all hidden files views is enable) , then go to find manager to find hosts file
Edit the host files with the IPs of all the network clients. You better go thru the example that , then edit your hosts and clients. Make a copy of that to a lmhosts file too by click save as lmhost (after u saved as hosts).
Reboot , good luck!
0
 
LVL 2

Accepted Solution

by:
mjdme earned 300 total points
ID: 8580202
make sure smb.conf file is setup correctly
http://us4.samba.org/samba/ftp/docs/htmldocs/Samba-PDC-HOWTO.html

when connecting from your workstation u must use root and root password to auth to the linux box as a pdc

edit your registry!!!!!!
http://www.wlug.org.nz/RequireSignOrSeal 

http://www.oreilly.com/catalog/samba/chapter/book/

also edit host and host allow file in samba and etc dir
0
 
LVL 2

Expert Comment

by:mjdme
ID: 8580299
take a look at this.  Its a small home network that I set up for someone


# Global parameters
[global]
        workgroup = HOME
        netbios name = server
        server string = Samba Server %v
        encrypt passwords = Yes
        map to guest = Bad User
        obey pam restrictions = Yes
        pam password change = Yes
        passwd program = /usr/bin/passwd %u
        passwd chat = *New*UNIX*password* %n\n *ReType*new*UNIX*password* %n\n
        username map = /etc/samba/smbusers
        password level = 1
        username level = 8
        unix password sync = Yes
        log level = 3
        log file = /var/log/samba/log.%m
        max log size = 50
        name resolve order = lmhosts bcast
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        printcap name = cups
        domain admin group = root @adm
        domain guest group = nobody @guest
        add user script = /usr/sbin/useradd -s /bin/false %u
        logon script = %U.bat
        logon path = \\%L\Profiles\%U
        logon home = \\%L\%U\.profile
        domain logons = Yes
        os level = 99
        preferred master = Yes
        domain master = Yes
        dns proxy = No
        message command = /usr/bin/linpopup "%f" "%m" %s; rm %s
        winbind uid = 10000-20000
        winbind gid = 10000-20000
        template shell = /bin/bash
        winbind use default domain = Yes
;[Documents and Settings]
;comment = Documents and Settings
;path = logons/documents_and_settings
;read only = no
;valid users = mjdme,dina,lauren,matt,root,admin

;[netlogon]
;comment = Network Logon Service
;path = /logons/netlogon
;read only = no
;valid users = mjdme,dina,lauren,matt,root,admin

; share for storing user profiles
;[profiles]
;comment = User Profiles
;path = /logons/profiles
;read only = no
;create mask = 0600
;directory mask = 0700
;valid users = mjdme,dina,lauren,matt,root,admin
;All above is for when setup as a PDC

[homes]
        comment = Home Directories
        valid users = dina,lauren,matthew,mjdme
        read only = No

[Root]
        comment = Root
        path = /
        guest account =

[logons]
        comment = Directory for Netlogons and Profiles
        path = /logons
        guest account =
        valid users = mjdme,dina,lauren,matt
        read only = No

[backupdrive]
        comment = BackUp Drive
        path = /backupdrive
        valid users = dina,lauren,matthew,mjdme
        read only = No
[documents]
        comment = Documents
        path = /documents
        guest account =
        valid users = dina,lauren,matthew,mjdme
        read only = No

[downloads]
        comment = Downloaded files
        path = /downloads
        guest account =
        valid users = dina,lauren,matthew,mjdme
        read only = No

[mp3s]
        comment = Shared MP3's for the web
        path = /mp3s
        valid users = dina,lauren,matt,mjdme
        read list = guest,ftp
        read only = No

[servers]
        comment = Directory for the different servers
        path = /servers
        guest account =
        valid users = dina,lauren,matt,mjdme
        read only = No

[software]
        comment = Software
        path = /software
        guest account =
        valid users = dina,lauren,matt,mjdme
        read only = No

[database]
        comment = MySQL Database Files
        path = /database
        guest account =
        valid users = dina,lauren,matthew,mjdme
        read only = No

[printers]
        comment = All Printers
        path = /var/spool/samba
        valid users = dina,lauren,matthew,mjdme
        create mask = 0700
        printable = Yes
        print command = lpr-cups -P %p -o raw %s -r   # using client side printer drivers.
        lpq command = lpq -P %p
        lprm command = cancel %p-%j
        browseable = No

[print$]
        path = /var/lib/samba/printers
        valid users = dina,lauren,matthew,mjdme
        write list = @adm root
[pdf-generator]
        comment = PDF Generator (only valid users)
        path = /var/tmp
        valid users = dina,lauren,matthew,mjdme
        printable = Yes
        print command = /usr/share/samba/scripts/print-pdf %s ~%u //%L/%u %m %I "%J" &

[HPLaserjet5]
        comment = HP B & W Laserjet Printer in Laurens Room
        path = /tmp
        guest account =
        printer admin = mjdme @"Domain Admins"
        hosts allow = mjdme matthew dina lauren
        printable = Yes
        printer name = HP LaserJet 5
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
This tutorial will teach you the special effect of super speed similar to the fictional character Wally West aka "The Flash" After Shake : http://www.videocopilot.net/presets/after_shake/ All lightning effects with instructions : http://www.mediaf…
Suggested Courses

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question